aboutsummaryrefslogtreecommitdiff
path: root/misc/gregexp/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-03 15:42:10 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-03 15:42:10 +0000
commit96e42eecd6dae69e01034a477ada0d3f9168d9fb (patch)
treee51c7ac15723eeb3ebcc04b1c31fac6cc25b5313 /misc/gregexp/Makefile
parent0ddedef4b5e482b6a01ad25b7e348051e45c26df (diff)
downloadports-96e42eecd6dae69e01034a477ada0d3f9168d9fb.tar.gz
ports-96e42eecd6dae69e01034a477ada0d3f9168d9fb.zip
Support CXXFLAGS properly
Fix build with system CC on -stable PR: ports/68633 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=112864
Diffstat (limited to 'misc/gregexp/Makefile')
-rw-r--r--misc/gregexp/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/misc/gregexp/Makefile b/misc/gregexp/Makefile
index e8810d7fbbf7..6c63f75f32cb 100644
--- a/misc/gregexp/Makefile
+++ b/misc/gregexp/Makefile
@@ -9,7 +9,8 @@
PORTNAME= gregexp
PORTVERSION= 0.3
CATEGORIES= misc
-MASTER_SITES= http://dentrassi.de/download/gregexp/${PORTVERSION}/
+MASTER_SITES= http://dentrassi.de/download/gregexp/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A graphical regular expression explorer
@@ -17,12 +18,9 @@ COMMENT= A graphical regular expression explorer
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
USE_X_PREFIX= yes
-USE_ICONV= yes
-USE_GETTEXT= yes
-USE_GNOME= gtk20 gnomeprefix libgnomeui
-USE_GCC= 3.3
+USE_GNOME= gnomeprefix libgnomeui
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>