aboutsummaryrefslogtreecommitdiff
path: root/misc/kde3-i18n-cs
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2001-04-09 20:48:48 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2001-04-09 20:48:48 +0000
commit57e80bd6396e8d9fcfb07fd6c36c9431889db0be (patch)
tree5d36940f5a6979ffb94c903b5b307a6e5a48dfe1 /misc/kde3-i18n-cs
parent8e5d618efa6fc5b8bcba018ad993b6109eb7731e (diff)
downloadports-57e80bd6396e8d9fcfb07fd6c36c9431889db0be.tar.gz
ports-57e80bd6396e8d9fcfb07fd6c36c9431889db0be.zip
Add the ability to select which languages to install via dialog(1)-based
menu. Sort pkg-plist.
Notes
Notes: svn path=/head/; revision=41146
Diffstat (limited to 'misc/kde3-i18n-cs')
-rw-r--r--misc/kde3-i18n-cs/Makefile6
-rw-r--r--misc/kde3-i18n-cs/scripts/Configure81
2 files changed, 87 insertions, 0 deletions
diff --git a/misc/kde3-i18n-cs/Makefile b/misc/kde3-i18n-cs/Makefile
index 55d6f1ea7887..893cd73b4beb 100644
--- a/misc/kde3-i18n-cs/Makefile
+++ b/misc/kde3-i18n-cs/Makefile
@@ -21,4 +21,10 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
+PLIST= ${WRKDIR}/PLIST
+SCRIPTS_ENV+= PLIST=${PLIST}
+
+pre-configure:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/Configure
+
.include <bsd.port.mk>
diff --git a/misc/kde3-i18n-cs/scripts/Configure b/misc/kde3-i18n-cs/scripts/Configure
new file mode 100644
index 000000000000..3d8958d60472
--- /dev/null
+++ b/misc/kde3-i18n-cs/scripts/Configure
@@ -0,0 +1,81 @@
+#! /bin/sh
+# $FreeBSD$
+
+/bin/rm -f ${PLIST} ${PLIST}.dirs
+
+if [ "${BATCH}" ]; then
+ set \"ca\" \"cs\" \"da\" \"de\" \"el\" \"eo\" \"es\" \"et\" \"fi\" \"fr\" \"he\" \"hu\" \"ja\" \"is\" \"ko\" \"it\" \"nl\" \"no\" \"no_NY\" \"pl\" \"pt\" \"pt_BR\" \"ro\" \"ru\" \"sk\" \"sl\" \"sr\" \"sv\" \"tr\" \"uk\" \"zh_CN.GB2312\" \"zh_TW.Big5\"
+else
+if [ "${LINGUAS}" ]; then
+ set `echo $LINGUAS`
+else
+ /usr/bin/dialog --title "Select languages" --clear \
+ --checklist "\n\
+Please select desired languages:" -1 -1 16 \
+ca "Canada" OFF \
+cs "Czech" OFF \
+da "Danish" OFF \
+de "German" ON \
+el "Greek" OFF \
+eo "Esperanto" OFF \
+es "Spanish" OFF \
+et "Estonian" OFF \
+fi "Finnish" ON \
+fr "French" ON \
+he "Hebrew" OFF \
+hu "Hungarian" OFF \
+ja "Japanese" ON \
+is "Icelandic" OFF \
+ko "Korean" ON \
+it "Italian" OFF \
+nl "Dutch" OFF \
+no "Norwegian (Bokmaal)" OFF \
+no_NY "Norwegian (Nynorsk)" OFF \
+pl "Polish" OFF \
+pt "Portuguese" OFF \
+pt_BR "Brazil portuguese" OFF \
+ro "Romanian" OFF \
+ru "Russian" ON \
+sk "Slovak" OFF \
+sl "Slovenian" OFF \
+sr "Serbian" OFF \
+sv "Swedish" OFF \
+tr "Turkish" OFF \
+uk "Ukrainian" OFF \
+zh_CN.GB2312 "Simplified Chinese" ON \
+zh_TW.Big5 "Chinese" ON \
+2> /tmp/chklist.tmp.$$
+
+ retval=$?
+
+ if [ -s /tmp/chklist.tmp.$$ ]; then
+ set `cat /tmp/chklist.tmp.$$`
+ fi
+ rm -f /tmp/chklist.tmp.$$
+
+ case $retval in
+ 0) if [ -z "$*" ]; then
+ echo "Nothing selected"
+ fi
+ ;;
+ 1) echo "Cancel pressed."
+ exit 1
+ ;;
+ esac
+fi
+fi
+
+/bin/rm -f ${WRKSRC}/subdirs
+/usr/bin/grep "^[^@].*/en/.*" ${CURDIR}/pkg-plist > ${PLIST}
+/usr/bin/grep "^@.*/en/.*" ${CURDIR}/pkg-plist > ${PLIST}.dirs
+
+while [ "$1" ]; do
+ a=`echo -n $1 | /usr/bin/sed -e 's#\"##g'`
+ echo $a >> ${WRKSRC}/subdirs
+ /usr/bin/grep "^[^@].*/$a/.*" ${CURDIR}/pkg-plist >> ${PLIST}
+ /usr/bin/grep "^[^@].*-$a\$" ${CURDIR}/pkg-plist >> ${PLIST}
+ /usr/bin/grep "^@.*/$a/.*" ${CURDIR}/pkg-plist >> ${PLIST}.dirs
+ shift
+done
+
+/bin/cat ${PLIST}.dirs >> ${PLIST}