aboutsummaryrefslogtreecommitdiff
path: root/misc/kde4-l10n-ro/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2002-04-21 23:47:50 +0000
committerWill Andrews <will@FreeBSD.org>2002-04-21 23:47:50 +0000
commitd1c2f0dddd4a74a79847b017915f3482671e055c (patch)
tree31ccd02a7c0d295ec66bf2eefa0f980fbb92cb91 /misc/kde4-l10n-ro/Makefile
parent98cff2373c59f930df3569d05871d0343d443fd8 (diff)
downloadports-d1c2f0dddd4a74a79847b017915f3482671e055c.tar.gz
ports-d1c2f0dddd4a74a79847b017915f3482671e055c.zip
Please welcome Qt3/KDE3 to our ports tree. This includes work since the
original versions of these ports, so some PORTREVISIONs were bumped. See http://freebsd.kde.org/ and mailing lists linked to from there for info on the packages generated to test these ports. bsd.kde.mk has already been updated a few days ago to work with these. Some patches applied to fix a few bugs were: deskutils/kdepim3: [1] Remove kpilot from build because it wasn't ready at release. editors/koffice-kde3: [2] Fix compile time bugs for FreeBSD. misc/kdeedu3: [3] Fix compile problem with kvoctrain. x11/kdebase3: [4] Fix KDM CPU usage and login bug. Some caveats: * All PLISTs are broken for deinstall due to script bug that I didn't notice until very recently. This will be fixed when I commit an update tomorrow. These ports should still install perfectly fine though. They should also deinstall without giving errors, but will leave directories behind. * You can't install this with any other version of QT or KDE already installed. I am not sure the checks are 100% working, but fixes for these will be forthcoming. This is mainly due to a policy decision made by kde@ to make QT/KDE ports install the way the rest of the world expects it to while also still conforming to FreeBSD's hier(7). For reference on this decision, please consult the KDE/FreeBSD mailing list archives. This decision fixes 2-year-old bug reports relating to how we handled this for KDE2 vs KDE1. Submitted by: [1] Adrian de Groot <adridg@cs.kun.nl>, [2] David Faure <faure@kde.org>, Andy Fawcett <andy@athame.co.uk> Lauri Watts <lauri@kde.org> [3] Lauri Watts <lauri@kde.org> [4] Alan Eldridge <alane@geeksrus.net> Oswald Buddenhagen <ossi@kde.org> Reviewed by: kde
Notes
Notes: svn path=/head/; revision=57964
Diffstat (limited to 'misc/kde4-l10n-ro/Makefile')
-rw-r--r--misc/kde4-l10n-ro/Makefile43
1 files changed, 13 insertions, 30 deletions
diff --git a/misc/kde4-l10n-ro/Makefile b/misc/kde4-l10n-ro/Makefile
index b20c579ae4b6..de1afd7711ef 100644
--- a/misc/kde4-l10n-ro/Makefile
+++ b/misc/kde4-l10n-ro/Makefile
@@ -1,45 +1,28 @@
-# New ports collection makefile for: kde2-i18n
-# Date created: 1 March 2001
-# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+# New ports collection makefile for: kde3-i18n-ro
+# Date created: 05 April 2002
+# Whom: Lauri Watts <lauri@kde.org>
#
# $FreeBSD$
#
-PORTNAME= kde-i18n
-PORTVERSION= 2.2.2
-PORTREVISION= 1
+PORTNAME= kde-i18n-ro
+PORTVERSION= 3.0
CATEGORIES?= misc kde
MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
-DIST_SUBDIR= KDE
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
+DIST_SUBDIR= KDE
+WRKSRC= ${WRKDIR}/${PORTNAME}
-MAINTAINER?= kde@FreeBSD.org
+MAINTAINER?= kde@FreeBSD.org
-BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
- automake14:${PORTSDIR}/devel/automake14
LIB_DEPENDS= intl.2:${PORTSDIR}/devel/gettext
-USE_KDELIBS_VER=2
+USE_KDELIBS_VER=3
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_TARGET=
+CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-PLIST= ${WRKDIR}/PLIST
-SCRIPTS_ENV+= PLIST=${PLIST}
-
-.include <bsd.port.pre.mk>
-
-pre-configure:
- ${MKDIR} ${WRKSRC}/auto-bin
-.for AC in autoconf autoheader
- ${LN} -sf ${LOCALBASE}/bin/${AC}213 ${WRKSRC}/auto-bin/${AC}
-.endfor
-.for AM in automake aclocal
- ${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
-.endfor
- cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
- ${GMAKE} -f Makefile.cvs
- @${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/Configure
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>