aboutsummaryrefslogtreecommitdiff
path: root/misc/kde4-xdg-env
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-12-13 16:47:28 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-12-13 16:47:28 +0000
commit6781af104daf728baeb0e8ecbd769c3cb1a4926f (patch)
treef40dbedd1198859ac0ab69c8892c4caf8164424f /misc/kde4-xdg-env
parent6a8712258bb005b9a73b0003010d9737221f5ff3 (diff)
downloadports-6781af104daf728baeb0e8ecbd769c3cb1a4926f.tar.gz
ports-6781af104daf728baeb0e8ecbd769c3cb1a4926f.zip
Fix a bug that would duplicate a path element in XDG_DATA_DIRS when
KDE_PREFIX == LOCALBASE. This triggered memory corruption in the xdgmime code used by GTK+ and gnome-vfs which led to strange crashes in GTK+ applications such as Firefox and Thunderbird. While here, add a missing XDG_DATA_DIRS entry for LOCALBASE/share/gnome. Approved by: kde (lofi)
Notes
Notes: svn path=/head/; revision=179673
Diffstat (limited to 'misc/kde4-xdg-env')
-rw-r--r--misc/kde4-xdg-env/Makefile2
-rw-r--r--misc/kde4-xdg-env/files/xdg-env.sh.in22
2 files changed, 18 insertions, 6 deletions
diff --git a/misc/kde4-xdg-env/Makefile b/misc/kde4-xdg-env/Makefile
index d8f33ee0df7c..f5ba6eef59df 100644
--- a/misc/kde4-xdg-env/Makefile
+++ b/misc/kde4-xdg-env/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xdg
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= misc kde
MASTER_SITES= # none
diff --git a/misc/kde4-xdg-env/files/xdg-env.sh.in b/misc/kde4-xdg-env/files/xdg-env.sh.in
index 8d48d5ff3def..394d578ae71f 100644
--- a/misc/kde4-xdg-env/files/xdg-env.sh.in
+++ b/misc/kde4-xdg-env/files/xdg-env.sh.in
@@ -4,12 +4,24 @@
#
# Submit missing XDG-file locations to kde@freebsd.org!
-export XDG_CONFIG_DIRS=\
+XDG_CONFIG_DIRS=\
${XDG_CONFIG_DIRS}:/etc/xdg:%%LOCALBASE%%/etc/xdg:%%X11BASE%%/etc/xdg:\
-%%LOCALBASE%%/etc/xdg/xfce4:%%KDE_PREFIX%%/etc/xdg
+%%LOCALBASE%%/etc/xdg/xfce4
-export XDG_DATA_DIRS=\
-${XDG_DATA_DIRS}:/usr/share:%%LOCALBASE%%/share:\
-%%X11BASE%%/share:%%X11BASE%%/share/gnome:%%KDE_PREFIX%%/share
+if [ %%KDE_PREFIX%% != %%LOCALBASE%% ]; then
+ XDG_CONFIG_DIRS=${XDG_CONFIG_DIRS}:%%KDE_PREFIX%%/etc/xdg
+fi
+
+export XDG_CONFIG_DIRS
+
+XDG_DATA_DIRS=\
+${XDG_DATA_DIRS}:/usr/share:%%LOCALBASE%%/share:%%LOCALBASE%%/share/gnome:\
+%%X11BASE%%/share:%%X11BASE%%/share/gnome
+
+if [ %%KDE_PREFIX%% != %%LOCALBASE%% ]; then
+ XDG_DATA_DIRS=${XDG_DATA_DIRS}:%%KDE_PREFIX%%/share
+fi
+
+export XDG_DATA_DIRS
kbuildsycoca