aboutsummaryrefslogtreecommitdiff
path: root/misc/ldconfig_compat
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2006-06-26 14:38:56 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2006-06-26 14:38:56 +0000
commitf7c550083d63311249cd5f2e231b0c950d893561 (patch)
treeb09e626506d4bdfc8f4cf4697da39ab2c95948fc /misc/ldconfig_compat
parentb30c528b5d704d9939795dbe4c5ae72876cd6360 (diff)
downloadports-f7c550083d63311249cd5f2e231b0c950d893561.tar.gz
ports-f7c550083d63311249cd5f2e231b0c950d893561.zip
- Re-add LDCONFIG*_DIR to bsd.ldconfig.mk since it causes directories not
being created at install-time (LDCONFIG*_DIR defined in bsd.port.post.mk). [1] - Update to a more recent version the ldconfig script. Reported by: fenner [1]
Notes
Notes: svn path=/head/; revision=166361
Diffstat (limited to 'misc/ldconfig_compat')
-rw-r--r--misc/ldconfig_compat/Makefile3
-rw-r--r--misc/ldconfig_compat/bsd.ldconfig.mk2
-rw-r--r--misc/ldconfig_compat/files/ldconfig_compat.sh.in12
3 files changed, 14 insertions, 3 deletions
diff --git a/misc/ldconfig_compat/Makefile b/misc/ldconfig_compat/Makefile
index 888b5987a359..c6d0cc03207f 100644
--- a/misc/ldconfig_compat/Makefile
+++ b/misc/ldconfig_compat/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ldconfig_compat
PORTVERSION= 1.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= misc
MASTER_SITES= # none
DISTFILES= # none
@@ -61,6 +61,7 @@ do-install:
.for prefix in ${LOCAL_PREFIXES}
@${ECHO_CMD} "@cwd ${prefix}" >> ${TMPPLIST}
.for dir in ${LOCAL_DIRS}
+ echo creating ${prefix}/${dir}
@${MKDIR} -p ${prefix}/${dir}
@${ECHO_CMD} "@exec mkdir -p %D/${dir}" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec rmdir %D/${dir} 2>/dev/null || true" >> ${TMPPLIST}
diff --git a/misc/ldconfig_compat/bsd.ldconfig.mk b/misc/ldconfig_compat/bsd.ldconfig.mk
index e69de29bb2d1..416f4c5f2e91 100644
--- a/misc/ldconfig_compat/bsd.ldconfig.mk
+++ b/misc/ldconfig_compat/bsd.ldconfig.mk
@@ -0,0 +1,2 @@
+LDCONFIG_DIR= libdata/ldconfig
+LDCONFIG32_DIR= libdata/ldconfig32
diff --git a/misc/ldconfig_compat/files/ldconfig_compat.sh.in b/misc/ldconfig_compat/files/ldconfig_compat.sh.in
index 1c6f4a450586..a4899035bc34 100644
--- a/misc/ldconfig_compat/files/ldconfig_compat.sh.in
+++ b/misc/ldconfig_compat/files/ldconfig_compat.sh.in
@@ -20,6 +20,8 @@ load_rc_config $name
ldconfig_start()
{
+ local _files
+
_ins=
ldconfig=${ldconfig_command}
checkyesno ldconfig_insecure && _ins="-i"
@@ -27,7 +29,10 @@ ldconfig_start()
ldconfig_paths=""
for i in ${ldconfig_local_dirs}; do
if [ -d "${i}" ]; then
- ldconfig_paths="${ldconfig_paths} `find ${i} -type f`"
+ _files=`find ${i} -type f`
+ if [ -n "${_files}" ]; then
+ ldconfig_paths="${ldconfig_paths} `cat ${_files} | sort -u`"
+ fi
fi
done
echo 'Local ldconfig path:' ${ldconfig_paths}
@@ -38,7 +43,10 @@ ldconfig_start()
ldconfig32_paths=""
for i in ${ldconfig_local32_dirs}; do
if [ -d "${i}" ]; then
- ldconfig32_paths="${ldconfig32_paths} `find ${i} -type f`"
+ _files=`find ${i} -type f`
+ if [ -n "${_files}" ]; then
+ ldconfig32_paths="${ldconfig32_paths} `cat ${_files} | sort -u`"
+ fi
fi
done
echo 'Local 32-bits ldconfig path:' ${ldconfig32_paths}