aboutsummaryrefslogtreecommitdiff
path: root/misc/mc
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2011-12-02 12:16:26 +0000
committerMax Khon <fjoe@FreeBSD.org>2011-12-02 12:16:26 +0000
commit243eb47bebc984020594e5b44f2280ee2f7d69b0 (patch)
treec214a2ce883b9237b3587d198d7d1655d08683d4 /misc/mc
parent9dfc1984f6c75c6e84d11fbdce98976f7da93e3f (diff)
downloadports-243eb47bebc984020594e5b44f2280ee2f7d69b0.tar.gz
ports-243eb47bebc984020594e5b44f2280ee2f7d69b0.zip
Fix Ctrl-O in xterm: FreeBSD xterm does not define "ti" and "te" but mc
tries to check their existence since 4.7.5.4. PR: 161828 Feature safe: yes
Notes
Notes: svn path=/head/; revision=286760
Diffstat (limited to 'misc/mc')
-rw-r--r--misc/mc/Makefile2
-rw-r--r--misc/mc/files/patch-lib-tty-win.c20
2 files changed, 21 insertions, 1 deletions
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index da71619cf187..f37fbac32287 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mc
PORTVERSION= 4.7.5.5
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= misc shells
MASTER_SITES= http://www.midnight-commander.org/downloads/ \
${MASTER_SITE_SUNSITE}
diff --git a/misc/mc/files/patch-lib-tty-win.c b/misc/mc/files/patch-lib-tty-win.c
new file mode 100644
index 000000000000..c759ff135d19
--- /dev/null
+++ b/misc/mc/files/patch-lib-tty-win.c
@@ -0,0 +1,20 @@
+--- lib/tty/win.c.orig 2011-12-02 18:59:45.000000000 +0700
++++ lib/tty/win.c 2011-12-02 19:00:11.000000000 +0700
+@@ -98,7 +98,7 @@
+ void
+ do_enter_ca_mode (void)
+ {
+- if (xterm_flag && smcup != NULL)
++ if (xterm_flag)
+ {
+ fprintf (stdout, /* ESC_STR ")0" */ ESC_STR "7" ESC_STR "[?47h");
+ fflush (stdout);
+@@ -110,7 +110,7 @@
+ void
+ do_exit_ca_mode (void)
+ {
+- if (xterm_flag && rmcup != NULL)
++ if (xterm_flag)
+ {
+ fprintf (stdout, ESC_STR "[?47l" ESC_STR "8" ESC_STR "[m");
+ fflush (stdout);