aboutsummaryrefslogtreecommitdiff
path: root/misc/mmv
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>1996-12-08 11:55:03 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>1996-12-08 11:55:03 +0000
commita3d9d452bc21dd7eeae680d9f7cb76236cd5240e (patch)
treed2a9d67e9d4b27c7d4f35005862f3889603da90a /misc/mmv
parent95f5c1697c503ea647b5aca495919306bdfbf4d4 (diff)
downloadports-a3d9d452bc21dd7eeae680d9f7cb76236cd5240e.tar.gz
ports-a3d9d452bc21dd7eeae680d9f7cb76236cd5240e.zip
Remove RESTRICTED and, instead, add NO_CDROM & NO_PACKAGE. (Redistribution
for charge is prohibited, no modification allowed.) Various cleanups include: List mmv.pch.Z as PATCHFILES instead of DISTFILES. Put full path to the MASTER_SITES. Instead of editing mmv.pch with scripts/makeitapatch, pass the name of the file to be patched to the patch command via PATCH_DIST_ARGS. Above three changes made do-fetch: & pre-clean:targets defined in this Makefile unnecessary. Call scripts/unshar via /bin/sh instead of giving it the execution bit in pre-extract: target. ln -> ln -fs rm -> ${RM} Use ${INSTALL_PROGRAM} and ${INSTALL_MAN}. Use MAN1 var to compress the man page. Reviewed by: asami
Notes
Notes: svn path=/head/; revision=4893
Diffstat (limited to 'misc/mmv')
-rw-r--r--misc/mmv/Makefile75
1 files changed, 22 insertions, 53 deletions
diff --git a/misc/mmv/Makefile b/misc/mmv/Makefile
index 7b608d2e16fd..6a7e8a048095 100644
--- a/misc/mmv/Makefile
+++ b/misc/mmv/Makefile
@@ -3,77 +3,46 @@
# Date created: 2 Feb 1995
# Whom: Michael Elbel (me)
#
-# $Id: Makefile,v 1.12 1996/11/11 05:49:49 obrien Exp $
+# $Id: Makefile,v 1.13 1996/12/03 04:07:29 asami Exp $
#
DISTNAME= mmv
PKGNAME= mmv-1.01b
CATEGORIES= misc
-MASTER_SITES= ftp://gatekeeper.dec.com/pub/usenet/comp.sources.unix/
-DISTFILES= part01.Z part02.Z mmv.pch.Z
+MASTER_SITES= ftp://gatekeeper.dec.com/pub/usenet/comp.sources.unix/volume21/mmv/
+DISTFILES= part01.Z part02.Z
+
+PATCH_SITES= ftp://gatekeeper.dec.com/pub/usenet/comp.sources.unix/volume22/
+PATCHFILES= mmv.pch.Z
MAINTAINER= me@FreeBSD.org
-RESTRICTED= "Restrictive copyright."
+NO_CDROM= "No redistribution for charge"
+NO_PACKAGE= "No modification"
DIST_SUBDIR= ${DISTNAME}
-SITE_DISTFILES= volume21/mmv/part01.Z volume21/mmv/part02.Z volume22/mmv.pch.Z
NO_WRKSUBDIR= yes
-
-# targets shamelessly hacked from the bsd.ports.mk file
-
-do-fetch:
- @${MKDIR} ${DISTDIR}/${DIST_SUBDIR}
- @(cd ${DISTDIR}/${DIST_SUBDIR}; \
- for file in ${SITE_DISTFILES}; do \
- if [ ! -f `basename $$file` ]; then \
- echo ">> `basename $$file` doesn't seem to exist on this system."; \
- echo ">> Attempting to fetch it from a master site."; \
- for site in ${MASTER_SITES}; do \
- pwd;\
- if ${FETCH_CMD} ${FETCH_BEFORE_ARGS} $${site}$${file} ${FETCH_AFTER_ARGS}; then \
- break; \
- fi \
- done; \
- if [ ! -f `basename $$file` ]; then \
- echo ">> Couldn't fetch it - please try to retreive this";\
- echo ">> port manually into ${DISTDIR}/${DIST_SUBDIR} and try again."; \
- exit 1; \
- fi; \
- fi \
- done)
-
-pre-extract:
- chmod +x scripts/unshar scripts/makeitapatch
+PATCH_DIST_ARGS= -d ${WRKSRC} --forward --quiet -E ${PATCH_DIST_STRIP} mmv.c
+MAN1= mmv.1
do-extract:
@${RM} -rf ${WRKDIR}
@${MKDIR} ${WRKDIR}/tmp
- @(cd ${DISTDIR}/${DIST_SUBDIR} ; for file in ${DISTFILES}; do \
- ${CP} $$file ${WRKDIR}/tmp; \
+ @(for file in ${DISTFILES}; do \
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/$$file ${WRKDIR}/tmp; \
done ; \
- cd ${WRKDIR}/tmp; \
- uncompress *; \
- cd .. ; \
+ uncompress ${WRKDIR}/tmp/*; \
+ cd ${WRKDIR}; \
for file in tmp/part0* ; do \
- ${SCRIPTDIR}/unshar $$file; \
+ /bin/sh ${SCRIPTDIR}/unshar $$file; \
done ; \
- ${SCRIPTDIR}/makeitapatch tmp/mmv.pch ; \
- mv tmp/mmv.pch ${PATCHDIR}/patch-0a ; \
- ${CAT} mmv.c.? >mmv.c ; rm mmv.c.? )
-
+ ${CAT} mmv.c.? >mmv.c ; ${RM} mmv.c.? )
do-install:
- (cd ${PREFIX}/bin ; rm -f mmv mad mcp mln ; \
- cd ${WRKSRC}; \
- ${INSTALL_PROGRAM} mmv ${PREFIX}/bin ; \
- ln ${PREFIX}/bin/mmv ${PREFIX}/bin/mad ; \
- ln ${PREFIX}/bin/mmv ${PREFIX}/bin/mcp ; \
- ln ${PREFIX}/bin/mmv ${PREFIX}/bin/mln ; \
- if [ ! -f mmv.1.gz ] ; then gzip mmv.1 ; fi ; \
- if [ ! -d ${PREFIX}/man/man1 ]; then ${MKDIR} ${PREFIX}/man/man1; fi; \
- ${INSTALL_MAN} mmv.1.gz ${PREFIX}/man/man1 ; )
-
-pre-clean:
- @rm -f ${PATCHDIR}/patch-0a # created by do-extract above
+ (cd ${PREFIX}/bin ; ${RM} -f mmv mad mcp mln ; \
+ ${INSTALL_PROGRAM} ${WRKSRC}/mmv ${PREFIX}/bin ; \
+ ln -fs ${PREFIX}/bin/mmv ${PREFIX}/bin/mad ; \
+ ln -fs ${PREFIX}/bin/mmv ${PREFIX}/bin/mcp ; \
+ ln -fs ${PREFIX}/bin/mmv ${PREFIX}/bin/mln ; \
+ ${INSTALL_MAN} mmv.1 ${PREFIX}/man/man1 ; )
.include <bsd.port.mk>