aboutsummaryrefslogtreecommitdiff
path: root/misc/pear-Services_Weather
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2007-07-30 13:53:16 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2007-07-30 13:53:16 +0000
commit9db77b87ea4ae2a6e8032312926b93e8be9ff79c (patch)
tree604818f75c3199e5daf0b1c57ced3f2310cb0e87 /misc/pear-Services_Weather
parent872c8f241e22685bca700286d2aac4cd42eb6573 (diff)
downloadports-9db77b87ea4ae2a6e8032312926b93e8be9ff79c.tar.gz
ports-9db77b87ea4ae2a6e8032312926b93e8be9ff79c.zip
- Update to 1.4.2.
Approved by: rafan (mentor, implicit)
Notes
Notes: svn path=/head/; revision=196716
Diffstat (limited to 'misc/pear-Services_Weather')
-rw-r--r--misc/pear-Services_Weather/Makefile49
-rw-r--r--misc/pear-Services_Weather/distinfo6
2 files changed, 35 insertions, 20 deletions
diff --git a/misc/pear-Services_Weather/Makefile b/misc/pear-Services_Weather/Makefile
index 9ebe29a80d55..2e74edad1ae7 100644
--- a/misc/pear-Services_Weather/Makefile
+++ b/misc/pear-Services_Weather/Makefile
@@ -6,30 +6,24 @@
#
PORTNAME= Services_Weather
-PORTVERSION= 1.4.0
+PORTVERSION= 1.4.2
CATEGORIES= misc www pear geography
MAINTAINER= chinsan@FreeBSD.org
COMMENT= PEAR interface to various online weather-services
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${BUILD_DEPENDS} \
+ ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
-.if !defined (WITHOUT_CACHE)
-BUILD_DEPENDS+= ${PEARDIR}/Cache.php:${PORTSDIR}/sysutils/pear-Cache
-.endif
-.if !defined (WITHOUT_DB)
-BUILD_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
-.endif
-.if !defined (WITHOUT_HTTPR)
-BUILD_DEPENDS+= ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
-.endif
-.if !defined (WITHOUT_SERIALIZER)
-BUILD_DEPENDS+= ${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer
-.endif
-.if !defined (WITHOUT_SOAP)
-BUILD_DEPENDS+= ${PEARDIR}/SOAP/Base.php:${PORTSDIR}/net/pear-SOAP
-.endif
+USE_PHP= ctype pcre
+
+LATEST_LINK= pear-Services_Weather
+OPTIONS= PEAR_NET_FTP "PEAR::Net::FTP support" off \
+ PEAR_CACHE "PEAR::Cache support" off \
+ PEAR_DB "PEAR::DB support" off \
+ PEAR_SOAP "PEAR::SOAP support" off \
+ PEAR_XML_SERIALIZER "PEAR::XML::Serializer support" off
CATEGORY= Services
FILES= Weather.php Weather/Common.php Weather/Ejse.php \
@@ -40,5 +34,26 @@ EXAMPLES= ejse-basic.php globalweather-basic.php metar-basic.php \
metar-extensive.php weather.com-basic.php weather.com-extensive.php
.include <bsd.port.pre.mk>
+
+.if defined(WITH_PEAR_NET_FTP)
+BUILD_DEPENDS+= ${PEARDIR}/Net/FTP.php:${PORTSDIR}/ftp/pear-Net_FTP
+.endif
+
+.if defined(WITH_PEAR_CACHE)
+BUILD_DEPENDS+= ${PEARDIR}/Cache.php:${PORTSDIR}/sysutils/pear-Cache
+.endif
+
+.if defined(WITH_PEAR_DB)
+BUILD_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+.endif
+
+.if defined(WITH_PEAR_SOAP)
+BUILD_DEPENDS+= ${PEARDIR}/SOAP/Base.php:${PORTSDIR}/net/pear-SOAP
+.endif
+
+.if defined(WITH_PEAR_XML_SERIALIZER)
+BUILD_DEPENDS+= ${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer
+.endif
+
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/misc/pear-Services_Weather/distinfo b/misc/pear-Services_Weather/distinfo
index 3b5643dd0933..5245cf1b0a86 100644
--- a/misc/pear-Services_Weather/distinfo
+++ b/misc/pear-Services_Weather/distinfo
@@ -1,3 +1,3 @@
-MD5 (PEAR/Services_Weather-1.4.0.tgz) = a83fbf5e2e7ffd22219c513cfefe6b52
-SHA256 (PEAR/Services_Weather-1.4.0.tgz) = 87420f024ecba2d0e9cbe4870f2559a15f558a583ff032958512d465ec4e547e
-SIZE (PEAR/Services_Weather-1.4.0.tgz) = 54183
+MD5 (PEAR/Services_Weather-1.4.2.tgz) = 6d0bb76bfc56527cb8d013eac196f05a
+SHA256 (PEAR/Services_Weather-1.4.2.tgz) = d383465eb3e0f2a5336225658ec5646a582218830ee878c573ee04e61a26b0fe
+SIZE (PEAR/Services_Weather-1.4.2.tgz) = 53471