aboutsummaryrefslogtreecommitdiff
path: root/misc/porteasy
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2001-08-14 13:58:56 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2001-08-14 13:58:56 +0000
commit5a0e464dc2b7a0a5a17f63ae7e8a0749898af88a (patch)
treef28eb1504d5cb16863ee7e8e74cfabc289640cf0 /misc/porteasy
parentfc5bea7541f572eff5ea4608ba67623b3a28e0a8 (diff)
downloadports-5a0e464dc2b7a0a5a17f63ae7e8a0749898af88a.tar.gz
ports-5a0e464dc2b7a0a5a17f63ae7e8a0749898af88a.zip
Fix handling of unconditional dependencies
Notes
Notes: svn path=/head/; revision=46240
Diffstat (limited to 'misc/porteasy')
-rw-r--r--misc/porteasy/Makefile2
-rw-r--r--misc/porteasy/src/porteasy.pl9
2 files changed, 7 insertions, 4 deletions
diff --git a/misc/porteasy/Makefile b/misc/porteasy/Makefile
index 2f06659c55c4..2b73d7daaf7c 100644
--- a/misc/porteasy/Makefile
+++ b/misc/porteasy/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= porteasy
-PORTVERSION= 2.4
+PORTVERSION= 2.5
CATEGORIES= misc
MASTER_SITES= # none
DISTFILES= # none
diff --git a/misc/porteasy/src/porteasy.pl b/misc/porteasy/src/porteasy.pl
index 230ab2e31e67..eeb3f59b5e31 100644
--- a/misc/porteasy/src/porteasy.pl
+++ b/misc/porteasy/src/porteasy.pl
@@ -33,7 +33,7 @@ use strict;
use Fcntl;
use Getopt::Long;
-my $VERSION = "2.4";
+my $VERSION = "2.5";
my $COPYRIGHT = "Copyright (c) 2000 Dag-Erling Smørgrav. All rights reserved.";
# Constants
@@ -550,11 +550,14 @@ sub find_dependencies($) {
or bsd::errx(1, "failed to obtain dependency list");
%depends = ();
foreach $item (split(' ', $dependvars)) {
- if ($item !~ m|^([^:]+):$portsdir/([^/:]+/[^/:]+)/?(:[^:]+)?$|) {
+ if ($item !~ m|^(?:([^:]+):)?$portsdir/([^/:]+/[^/:]+)/?(:[^:]+)?$|) {
bsd::warnx("invalid dependency: %s", $item);
+ next;
}
($lhs, $rhs) = ($1, $2);
- if ($exclude) {
+ # XXX this isn't quite right; lhs-less dependencies should be
+ # XXX checked against /var/db/pkg or something.
+ if ($exclude && defined($lhs)) {
if ($have_dep{$rhs}) {
next;
}