aboutsummaryrefslogtreecommitdiff
path: root/misc/porteasy
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2002-02-24 15:36:32 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2002-02-24 15:36:32 +0000
commita33c7d02b6976c7330f986c66a9e810871219f1f (patch)
tree73be5f35d69cc8d58a883573600a787728339b89 /misc/porteasy
parentf00af35fa7cbbc3664420763d17dfc9958aab38d (diff)
downloadports-a33c7d02b6976c7330f986c66a9e810871219f1f.tar.gz
ports-a33c7d02b6976c7330f986c66a9e810871219f1f.zip
Definitely not my day. Further thought revealed that porteasy.pl rev 1.20
was not only suboptimal, but incorrect to boot. Fix and bump PORTREVISION.
Notes
Notes: svn path=/head/; revision=55187
Diffstat (limited to 'misc/porteasy')
-rw-r--r--misc/porteasy/Makefile1
-rw-r--r--misc/porteasy/src/porteasy.pl14
2 files changed, 7 insertions, 8 deletions
diff --git a/misc/porteasy/Makefile b/misc/porteasy/Makefile
index e308340ea2fe..f62714be7bf7 100644
--- a/misc/porteasy/Makefile
+++ b/misc/porteasy/Makefile
@@ -9,6 +9,7 @@
PORTNAME= porteasy
PORTVERSION= 2.7.0
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= # none
DISTFILES= # none
diff --git a/misc/porteasy/src/porteasy.pl b/misc/porteasy/src/porteasy.pl
index 33a546e1adaa..ec3fdaeab489 100644
--- a/misc/porteasy/src/porteasy.pl
+++ b/misc/porteasy/src/porteasy.pl
@@ -913,15 +913,13 @@ sub build_port($) {
my @makeargs; # Arguments to make()
if ($packages) {
- push(@makeargs, "package", "DEPENDS_TARGET=package clean");
- foreach (values(%{$port_dep{$port}})) {
- if ($_ ne 'install') {
- push(@makeargs, "-DNOCLEANDEPENDS");
- last;
- }
- }
+ push(@makeargs, "package");
+ push(@makeargs, "DEPENDS_TARGET=package clean", "-DNOCLEANDEPENDS")
+ unless ($dontclean);
} else {
push(@makeargs, "install");
+ push(@makeargs, "DEPENDS_TARGET=install clean", "-DNOCLEANDEPENDS")
+ unless ($dontclean);
}
if ($force) {
push(@makeargs, "-DFORCE_PKG_REGISTER");
@@ -1095,7 +1093,7 @@ MAIN:{
}
# Step 3: update port directories and discover dependencies
- $need_deps = ($update || $build || $fetch || $list || $packages);
+ $need_deps = ($update || $list);
update_ports_tree(keys(%reqd));
# Step 4: deselect ports which are already installed