aboutsummaryrefslogtreecommitdiff
path: root/misc/porteasy
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2002-02-20 00:30:32 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2002-02-20 00:30:32 +0000
commite85f08c22adc3756ca70aaa61a2f20bdf31de886 (patch)
tree6c5f627f62b1d0a61864ce05d75a43ffbb3a34e3 /misc/porteasy
parentfdbcfc20a24760dfe082f1cf607064975c120a7b (diff)
downloadports-e85f08c22adc3756ca70aaa61a2f20bdf31de886.tar.gz
ports-e85f08c22adc3756ca70aaa61a2f20bdf31de886.zip
Add a hack to the master detection code to cater for mail/postfix.
Clean up each dependency after building it, to conserve disk space.
Notes
Notes: svn path=/head/; revision=54932
Diffstat (limited to 'misc/porteasy')
-rw-r--r--misc/porteasy/Makefile2
-rw-r--r--misc/porteasy/src/porteasy.pl6
2 files changed, 4 insertions, 4 deletions
diff --git a/misc/porteasy/Makefile b/misc/porteasy/Makefile
index 5c738edd1aa7..42e591dddf4e 100644
--- a/misc/porteasy/Makefile
+++ b/misc/porteasy/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= porteasy
-PORTVERSION= 2.6.3
+PORTVERSION= 2.6.4
CATEGORIES= misc
MASTER_SITES= # none
DISTFILES= # none
diff --git a/misc/porteasy/src/porteasy.pl b/misc/porteasy/src/porteasy.pl
index 115efa23eaa4..5adb0efc4641 100644
--- a/misc/porteasy/src/porteasy.pl
+++ b/misc/porteasy/src/porteasy.pl
@@ -33,7 +33,7 @@ use strict;
use Fcntl;
use Getopt::Long;
-my $VERSION = "2.6.3";
+my $VERSION = "2.6.4";
my $COPYRIGHT = "Copyright (c) 2000 Dag-Erling Smørgrav. All rights reserved.";
# Constants
@@ -479,7 +479,7 @@ sub find_master($) {
} elsif (/^\.?include \"([^\"]+)\/Makefile(?:[^\/\"]*)\"\s*$/) {
$master = $1;
}
- if (defined($master)) {
+ if (defined($master) && $master !~ m/WRKDIRPREFIX/) {
$master =~ s/^\$\{.CURDIR\}//;
$master = "/$port/$master";
$master =~ s|/+|/|g;
@@ -904,7 +904,7 @@ sub build_port($) {
my @makeargs; # Arguments to make()
if ($packages) {
- push(@makeargs, "package", "DEPENDS_TARGET=package");
+ push(@makeargs, "package", "DEPENDS_TARGET=package clean", "-DNOCLEANDEPENDS");
} else {
push(@makeargs, "install");
}