aboutsummaryrefslogtreecommitdiff
path: root/misc/qt4-qtdemo/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-04 23:30:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-04 23:30:38 +0000
commitd56984b0567867dd57ecb27fe0c508025c2426c5 (patch)
treeeb02dac4e0d7e5129ffac4c76b935a76a7e66676 /misc/qt4-qtdemo/Makefile
parent98813eadd27b8cd8500044af2a49b6d861809815 (diff)
downloadports-d56984b0567867dd57ecb27fe0c508025c2426c5.tar.gz
ports-d56984b0567867dd57ecb27fe0c508025c2426c5.zip
- Update to qt 4.4.1
Note: With this update several ports specific problems have been fixed. Qt4 headers and libraries have been moved to include/qt4 and lib/qt4. bsd.qt.mk defines QT_INCDIR and QT_LIBDIR now, which could be used in qt4-dependent ports if required. Thanks to: Max Brazhnikov Danny Pansters
Notes
Notes: svn path=/head/; revision=218043
Diffstat (limited to 'misc/qt4-qtdemo/Makefile')
-rw-r--r--misc/qt4-qtdemo/Makefile19
1 files changed, 17 insertions, 2 deletions
diff --git a/misc/qt4-qtdemo/Makefile b/misc/qt4-qtdemo/Makefile
index 749f3815125a..256c8914c19a 100644
--- a/misc/qt4-qtdemo/Makefile
+++ b/misc/qt4-qtdemo/Makefile
@@ -8,7 +8,7 @@
PORTNAME= qtdemo
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
+PORTREVISION=0
CATEGORIES?= misc
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -21,7 +21,8 @@ COMMENT= Qt demonstration and example programs
USE_QT_VER= 4
QT_COMPONENTS= qmake_build moc_build rcc_build uic_build assistantclient \
corelib designer gui network opengl sql svg qtestlib xml \
- imageformats_run dbus script
+ imageformats_run dbus script webkit phonon help assistant_run \
+ phonon-gst
QT_NONSTANDARD= yes
QT_DIST= yes
@@ -31,8 +32,22 @@ ALL_TARGET= first
CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
PATH=${WRKSRC}/bin:$$PATH
+
+DO_NOT_EXTRACT= doc mkspecs qmake translations
+EXTRACT_AFTER_ARGS= | ${TAR} -xf -
+.for dne in ${DO_NOT_EXTRACT}
+EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
+.endfor
+
WRKSRC= ${WRKDIR}/${DISTNAME}/demos
CONFIGURE_WRKSRC=${WRKSRC}/../
+PATCH_WRKSRC= ${CONFIGURE_WRKSRC}
+
+post-patch:
+ ${REINPLACE_CMD} -e '/app +=/s|"assistant"|"assistant-qt4"|' \
+ ${PATCH_WRKSRC}/demos/qtdemo/menumanager.cpp \
+ ${PATCH_WRKSRC}/examples/help/remotecontrol/remotecontrol.cpp \
+ ${PATCH_WRKSRC}/examples/help/simpletextviewer/assistant.cpp
pre-configure:
${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}