aboutsummaryrefslogtreecommitdiff
path: root/misc/qt4-qtdemo
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2007-04-19 17:08:04 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2007-04-19 17:08:04 +0000
commit7aeef3e5194acb6b59e88472be78b4d7f2a7014f (patch)
tree616dfe53e60011f08ba0fd9e44d23086ed7704a2 /misc/qt4-qtdemo
parent70b438b4348e8e5786613051e3c8e890dd2d18f9 (diff)
downloadports-7aeef3e5194acb6b59e88472be78b4d7f2a7014f.tar.gz
ports-7aeef3e5194acb6b59e88472be78b4d7f2a7014f.zip
Rename all binaries in qt4 which conflict with binaries installed by
qt33 to ($binary)-qt4 and adjust dependencies accordingly. This avoids conflicts once X11BASE has been changed to /usr/local and incidentally makes the naming scheme of the qt4 executables in ports equal to that of the Fedora Core and Debian packages.
Notes
Notes: svn path=/head/; revision=190368
Diffstat (limited to 'misc/qt4-qtdemo')
-rw-r--r--misc/qt4-qtdemo/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/misc/qt4-qtdemo/Makefile b/misc/qt4-qtdemo/Makefile
index b9232ad885cb..318b5244cc2c 100644
--- a/misc/qt4-qtdemo/Makefile
+++ b/misc/qt4-qtdemo/Makefile
@@ -18,10 +18,10 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt demonstration and example programs
-BUILD_DEPENDS= moc4:${PORTSDIR}/devel/qt4-moc \
+BUILD_DEPENDS= moc-qt4:${PORTSDIR}/devel/qt4-moc \
qmake-qt4:${PORTSDIR}/devel/qmake4 \
rcc:${PORTSDIR}/devel/qt4-rcc \
- uic4:${PORTSDIR}/devel/qt4-uic
+ uic-qt4:${PORTSDIR}/devel/qt4-uic
LIB_DEPENDS= QtAssistantClient:${PORTSDIR}/devel/qt4-libqtassistantclient \
QtCore:${PORTSDIR}/devel/qt4-corelib \
QtDBus:${PORTSDIR}/devel/dbus-qt4 \
@@ -59,8 +59,8 @@ pre-configure:
${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
${MKDIR} ${WRKSRC}/../mkspecs
${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../bin/qmake
- ${LN} -sf ${LOCALBASE}/bin/moc4 ${WRKSRC}/../bin/moc
- ${LN} -sf ${LOCALBASE}/bin/uic4 ${WRKSRC}/../bin/uic
+ ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../bin/moc
+ ${LN} -sf ${LOCALBASE}/bin/uic-qt4 ${WRKSRC}/../bin/uic
${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/../bin/rcc
post-build: