aboutsummaryrefslogtreecommitdiff
path: root/misc/shuffle-db
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2007-01-16 13:41:47 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2007-01-16 13:41:47 +0000
commit071e0dd097d972089309c6c735152d6761cf66df (patch)
treea45e48c0f475553cd74981dc37806682c9ff3fbb /misc/shuffle-db
parentaf1d88f66a0cc8a4f3616d09c86652871fc2aa1b (diff)
downloadports-071e0dd097d972089309c6c735152d6761cf66df.tar.gz
ports-071e0dd097d972089309c6c735152d6761cf66df.zip
Add shuffle-db, an iPod shuffle database builder written in python.
Notes
Notes: svn path=/head/; revision=182520
Diffstat (limited to 'misc/shuffle-db')
-rw-r--r--misc/shuffle-db/Makefile27
-rw-r--r--misc/shuffle-db/distinfo3
-rw-r--r--misc/shuffle-db/pkg-descr10
3 files changed, 40 insertions, 0 deletions
diff --git a/misc/shuffle-db/Makefile b/misc/shuffle-db/Makefile
new file mode 100644
index 000000000000..87f5df71a050
--- /dev/null
+++ b/misc/shuffle-db/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: shuffle-db
+# Date created: 16 Jan 2007
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= shuffle-db
+DISTVERSION= 1.0-rc1
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= rebuild_db-${DISTVERSION}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= An iPod shuffle database builder
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/rebuild_db
+PLIST_FILES= bin/rebuild_db.py
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/rebuild_db.py ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/misc/shuffle-db/distinfo b/misc/shuffle-db/distinfo
new file mode 100644
index 000000000000..2f52e4e32913
--- /dev/null
+++ b/misc/shuffle-db/distinfo
@@ -0,0 +1,3 @@
+MD5 (rebuild_db-1.0-rc1.tar.gz) = edd5f0423348068329cb5877eba406b7
+SHA256 (rebuild_db-1.0-rc1.tar.gz) = acfed7e89ba9a7c08c56d37a166e089269b75a4fdd2f4a571ae4c3c31d9d9ca5
+SIZE (rebuild_db-1.0-rc1.tar.gz) = 30826
diff --git a/misc/shuffle-db/pkg-descr b/misc/shuffle-db/pkg-descr
new file mode 100644
index 000000000000..cf53f6adbc9e
--- /dev/null
+++ b/misc/shuffle-db/pkg-descr
@@ -0,0 +1,10 @@
+This little program enables iPod shuffle users to get rid of iTunes or other
+complicated playlist management tools. Due to the simple structure of the
+shuffle, it is possible to use the player almost like any other USB flash MP3
+player: You simply copy MP3 files onto it. You only need to run the Datab ase
+Builder program after you added or removed files from the iPod.
+
+WWW: http://shuffle-db.sourceforge.net/
+
+- ehaupt
+ehaupt@FreeBSD.org