aboutsummaryrefslogtreecommitdiff
path: root/misc/sma
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-05-10 22:21:39 +0000
committerSteve Price <steve@FreeBSD.org>1998-05-10 22:21:39 +0000
commite2ff5692056745f75dd2ba5c336d3bc2f4a73a7f (patch)
tree2370c90f06b9777c84a0f0901bc2e36496e06312 /misc/sma
parentd093362e308304e87e5c21a10e215b863f9e8617 (diff)
downloadports-e2ff5692056745f75dd2ba5c336d3bc2f4a73a7f.tar.gz
ports-e2ff5692056745f75dd2ba5c336d3bc2f4a73a7f.zip
Initial import of sma version 0.9.7.
A Scour Media Agent client for UNIX. PR: 6553, 6554 Submitted by: Donald Burr <dburr@POBoxes.com>
Notes
Notes: svn path=/head/; revision=10940
Diffstat (limited to 'misc/sma')
-rw-r--r--misc/sma/Makefile37
-rw-r--r--misc/sma/distinfo1
-rw-r--r--misc/sma/pkg-comment1
-rw-r--r--misc/sma/pkg-descr20
-rw-r--r--misc/sma/pkg-message31
-rw-r--r--misc/sma/pkg-plist1
6 files changed, 91 insertions, 0 deletions
diff --git a/misc/sma/Makefile b/misc/sma/Makefile
new file mode 100644
index 000000000000..4ec6ae9b7525
--- /dev/null
+++ b/misc/sma/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: sma
+# Version required: 0.9.7
+# Date created: 8 May 1998
+# Whom: Donald Burr <dburr@POBoxes.com>
+#
+# $Id$
+#
+
+DISTNAME= SMA2
+PKGNAME= sma-0.9.7
+CATEGORIES= misc
+MASTER_SITES= http://www.scour.net/sma/
+EXTRACT_SUFX= .pl
+
+MAINTAINER= dburr@POBoxes.com
+
+RUN_DEPENDS= smbclient:${PORTSDIR}/net/samba
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+USE_PERL5= yes
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+
+pre-configure:
+ @${SED} -e '1,1s:/usr/bin/perl:${PREFIX}/bin/perl5.00404:' \
+ ${DISTDIR}/SMA2.pl > ${WRKDIR}/sma
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/sma ${PREFIX}/bin
+
+post-install:
+ @${CAT} ${PKGDIR}/MESSAGE
+
+.include <bsd.port.mk>
diff --git a/misc/sma/distinfo b/misc/sma/distinfo
new file mode 100644
index 000000000000..b84406e100f6
--- /dev/null
+++ b/misc/sma/distinfo
@@ -0,0 +1 @@
+MD5 (SMA2.pl) = 679a976fb113ea1ac75f617e5a740582
diff --git a/misc/sma/pkg-comment b/misc/sma/pkg-comment
new file mode 100644
index 000000000000..734dfef1da40
--- /dev/null
+++ b/misc/sma/pkg-comment
@@ -0,0 +1 @@
+Scour Media Agent client for UNIX
diff --git a/misc/sma/pkg-descr b/misc/sma/pkg-descr
new file mode 100644
index 000000000000..45515fb17d7f
--- /dev/null
+++ b/misc/sma/pkg-descr
@@ -0,0 +1,20 @@
+The Scour Media Agent (SMA) is a program that is used in conjunction with
+the Scour search service (http://www.scour.net/). This is a new kind of
+search service that specializes in searching for multimedia filetypes
+(video, animation, audio, etc.). They search 6 different protocols and have
+the most comprehensive webcrawlers of any search engine presently in
+existence. The database contains everything from links to streaming video
+lectures on Microbiology (coming soon) to the latest music video from the
+Spice Girls.
+
+They specialize even further by separating media files into their respective
+types (.avi, .mpg, .mov, .viv, .ram, .mp3, etc.) So, going beyond just
+being able to search for video files, you can specify all the way down to
+the file type.
+
+This free service started out as a dorm room project by a couple of Computer
+Science students at UCLA.
+
+Check it out at http://www.scour.net/.
+
+[ This port is maintained by Donald Burr <dburr@POBoxes.com>. ]
diff --git a/misc/sma/pkg-message b/misc/sma/pkg-message
new file mode 100644
index 000000000000..d6f53756e860
--- /dev/null
+++ b/misc/sma/pkg-message
@@ -0,0 +1,31 @@
+Scour is now successfully installed.
+
+You can use it either as a standalone program or as a browser plug-in.
+
+Standalone:
+===========
+When you find a file you want to look at on the Scour site, click on it
+to download it. Netscape will pop up a "save as" dialog to ask you where
+to save a file called "smadlc". Save it anywhere, then from a command line
+type "sma /path/to/smadlc" (example: if you saved it as /tmp/smadlc, type
+"sma /tmp/smadlc")
+
+Netscape plug-in:
+=================
+In the Preferences dialog, click through to the "Navigator/Applications"
+hierarchy. Click the "New" button and fill out the dialog as follows:
+
+Description: Scour Media Agent
+MIMEType: application/x-scour-directive
+Suffixes: sma
+Handled by: Check "Application", and in the box, enter "sma %s"
+
+Lynx plug-in:
+=============
+Add the following line to the lynx.cfg file:
+VIEWER:application/x-scour-directive:sma %s
+
+You will also need to install programs for whichever media type(s) you wish
+to be able to view. Look around in the /usr/ports hierarchy.
+
+Now go on over to http://www.scour.net/ and use it!
diff --git a/misc/sma/pkg-plist b/misc/sma/pkg-plist
new file mode 100644
index 000000000000..b95917b727b3
--- /dev/null
+++ b/misc/sma/pkg-plist
@@ -0,0 +1 @@
+bin/sma