aboutsummaryrefslogtreecommitdiff
path: root/misc/team
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>1995-07-01 17:57:54 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>1995-07-01 17:57:54 +0000
commit14cc16693022b8b47dd05e40de9d00c1cebbf9ad (patch)
tree7b00d2aa6378c129fa3767a85ba9c1264a70884d /misc/team
parentee12f980acefb3fed6994c59885b387e4a44700e (diff)
downloadports-14cc16693022b8b47dd05e40de9d00c1cebbf9ad.tar.gz
ports-14cc16693022b8b47dd05e40de9d00c1cebbf9ad.zip
team - portable multi-buffered tape streaming utility
Notes
Notes: svn path=/head/; revision=1910
Diffstat (limited to 'misc/team')
-rw-r--r--misc/team/Makefile15
-rw-r--r--misc/team/distinfo1
-rw-r--r--misc/team/files/patch-a34
-rw-r--r--misc/team/files/patch-b28
-rw-r--r--misc/team/pkg-comment1
-rw-r--r--misc/team/pkg-descr44
-rw-r--r--misc/team/pkg-plist3
7 files changed, 126 insertions, 0 deletions
diff --git a/misc/team/Makefile b/misc/team/Makefile
new file mode 100644
index 000000000000..92016b0aea8e
--- /dev/null
+++ b/misc/team/Makefile
@@ -0,0 +1,15 @@
+# New ports collection makefile for: team
+# Version required: 3.1 (From the RCS Id line of team.c)
+# Date created: 1 July 1995
+# Whom: joerg
+#
+# $Id$
+#
+
+DISTNAME= team-3.1
+MASTER_SITES= ftp://freefall.cdrom.com/pub/FreeBSD/LOCAL_PORTS/
+CATEGORIES+= utils
+
+MAINTAINER= joerg@FreeBSD.org
+
+.include <bsd.port.mk>
diff --git a/misc/team/distinfo b/misc/team/distinfo
new file mode 100644
index 000000000000..45ee3aa62cce
--- /dev/null
+++ b/misc/team/distinfo
@@ -0,0 +1 @@
+MD5 (team-3.1.tar.gz) = e2095ee087a61d784bd2e296724d4316
diff --git a/misc/team/files/patch-a b/misc/team/files/patch-a
new file mode 100644
index 000000000000..2a8bd311e970
--- /dev/null
+++ b/misc/team/files/patch-a
@@ -0,0 +1,34 @@
+diff -u team-3.1/Makefile ./Makefile
+--- team-3.1/Makefile Sat Jul 1 17:33:24 1995
++++ ./Makefile Sat Jul 1 17:53:20 1995
+@@ -1,25 +1,8 @@
+-CFLAGS =-O
+-LDFLAGS =-s
++PROG= team
+
+-INSTX =install -m 0755 -s
+-INSTD =install -m 0644
++BINDIR= ${PREFIX}/bin
++MANDIR= ${PREFIX}/man/man
+
+-DEST=
++CFLAGS+= -DHAVE_PARAM_H
+
+-MI =$(DEST)/usr/
+-MD =$(DEST)/usr/
+-
+-M1X =1
+-
+-BIND =$(MD)bin/
+-MANI =$(MI)man
+-
+-MANI1 =$(MANI)$(M1X)/
+-
+-all: team
+-
+-clean::
+- rm -f team team.o
+-
+-$(BIND)team: team; $(INSTX) $? $@
+-$(MANI1)team.$(M1X): team.1; $(INSTD) $? $@
++.include <bsd.prog.mk>
diff --git a/misc/team/files/patch-b b/misc/team/files/patch-b
new file mode 100644
index 000000000000..293325e09a3c
--- /dev/null
+++ b/misc/team/files/patch-b
@@ -0,0 +1,28 @@
+diff -u team-3.1/team.c ./team.c
+--- team-3.1/team.c Sat Jul 1 17:33:24 1995
++++ ./team.c Sat Jul 1 17:54:05 1995
+@@ -85,6 +85,11 @@
+ #include <sys/stat.h>
+ #include <fcntl.h>
+
++#ifdef HAVE_PARAM_H
++#include <sys/param.h>
++#endif
++
++
+ #ifdef sun
+ # undef F_SETLKW
+ #endif
+@@ -286,7 +291,12 @@
+ do
+ {
+ #if (defined i386 || defined sun)
++# if !(defined(BSD) && (BSD >= 199306))
+ extern char *(sys_errlist[]);
++# endif
++# if (defined(BSD) && (BSD >= 199306)) && __STDC__
++ const
++# endif
+ char *errmsg = sys_errlist[errno];
+ #else
+ char errmsg[32];
diff --git a/misc/team/pkg-comment b/misc/team/pkg-comment
new file mode 100644
index 000000000000..e5d0a8347a76
--- /dev/null
+++ b/misc/team/pkg-comment
@@ -0,0 +1 @@
+team - portable multi-buffered tape streaming utility
diff --git a/misc/team/pkg-descr b/misc/team/pkg-descr
new file mode 100644
index 000000000000..f5fade6e63a0
--- /dev/null
+++ b/misc/team/pkg-descr
@@ -0,0 +1,44 @@
+From: pcg@aber.ac.uk (Piercarlo Grandi)
+Newsgroups: comp.sources.unix
+Subject: v27i195: team - portable multi-buffered tape streaming utility, Part01/01
+Date: 13 Jan 1994 13:24:40 -0800
+Approved: vixie@gw.home.vix.com
+Message-ID: <1.758496249.28141@gw.home.vix.com>
+
+Submitted-By: pcg@aber.ac.uk (Piercarlo Grandi)
+Posting-Number: Volume 27, Issue 195
+Archive-Name: team/part01
+
+There exist a few filters that help tapes streams by buffering IO and
+allowing reads to overlaps with writes under Unix. Most of these filters
+rely on relatively unportable features, for example SYSV like shared
+memory.
+
+team is a filter that runs essentially unchanged on any Unix version, as
+it relies only on features present in V7. A number of team processes
+(team members) share a common input fd and a common output fd, and they
+take turns at reading from the former and writing to the latter; they
+synchronize by using a ring of pipes between them, where a "read-enable"
+and a "write-enable" token circulate.
+
+team is not just very portable, but also portable and efficient. It also
+has some bells & whistles, like command line options to specify the
+number of processes in a team, the block size for IO, and the volume
+size of the input or output media. It also optionally reports its
+progress.
+
+Previous versions of team have been circulating (e.g. via alt.sources)
+for several years; I have not found a bug for a long time, even if
+surely they will exist.
+
+The team source is GPL'ed, and it comes with no warranty.
+
+ Note: this program was developed entirely by the author in his own
+ time, using his own resources, on his machine, in the context of
+ his own research activities. In no way has the University of Wales,
+ Aberystwyth contributed aided or abetted to this work, for which
+ they bear no responsibility whatsoever. I am grateful to UWA for the
+ ability to use their systems (as a paying customer) to post this work.
+
+ pcg@aber.ac.uk (Piercarlo Grandi)
+
diff --git a/misc/team/pkg-plist b/misc/team/pkg-plist
new file mode 100644
index 000000000000..509395628c9a
--- /dev/null
+++ b/misc/team/pkg-plist
@@ -0,0 +1,3 @@
+@cwd /usr/local
+bin/team
+man/man1/team.1.gz