aboutsummaryrefslogtreecommitdiff
path: root/misc/terraform/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-08-12 21:32:09 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-08-12 21:32:09 +0000
commit52a3ae6476df45a7065285b06783f31e70abe9e8 (patch)
treedc957514a2e12dc66648d0a467824a492a1736e9 /misc/terraform/Makefile
parent623542359094644f2eaa3cc73d1708f796645b85 (diff)
downloadports-52a3ae6476df45a7065285b06783f31e70abe9e8.tar.gz
ports-52a3ae6476df45a7065285b06783f31e70abe9e8.zip
Update to 0.9.5
PR: 159487 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=279569
Diffstat (limited to 'misc/terraform/Makefile')
-rw-r--r--misc/terraform/Makefile41
1 files changed, 28 insertions, 13 deletions
diff --git a/misc/terraform/Makefile b/misc/terraform/Makefile
index b23fb7045123..9b36a1693c88 100644
--- a/misc/terraform/Makefile
+++ b/misc/terraform/Makefile
@@ -7,32 +7,47 @@
#
PORTNAME= terraform
-PORTVERSION= 0.9.0
-PORTREVISION= 11
+PORTVERSION= 0.9.5
+DISTVERSIONPREFIX= src-
CATEGORIES= misc gnome
-MASTER_SITES= SF
+MASTER_SITES= GOOGLE_CODE
+EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Interactive height field generation and manipulation program
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
+
BUILD_DEPENDS= ${LOCALBASE}/lib/libtrio.a:${PORTSDIR}/devel/trio
-USE_XORG= x11
-USE_BISON= build
-USE_GNOME= gnomeprefix gnomehack gnomeprint
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_GNOME= gnomehack gnomehier libgnomeprintui libgnomeui
+USE_GETTEXT= yes
USE_GMAKE= yes
+USE_AUTOTOOLS= automake:env
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
+MAKE_JOBS_SAFE= yes
+
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
post-patch:
- @${REINPLACE_CMD} -e "s|Bison |Bison|g ; \
- s|-ltrio $$LIBS|-ltrio -lm $$LIBS|g ; \
- s|#define 1|#define HAVE_LIB_TRIO 1|g ; \
- s|(HAVE_LIB_TRIO)||g" ${WRKSRC}/configure
- @${REINPLACE_CMD} -e "s|malloc\.h|stdlib.h|g" ${WRKSRC}/src/xmlsupport.c
+ @${REINPLACE_CMD} -e '/^SUBDIRS/s| desktop-links docs | |' \
+ ${WRKSRC}/Makefile.in
+
+pre-configure:
+ @${LN} -sf ${AUTOMAKE_DIR}/depcomp ${WRKSRC}
post-install:
+ @${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/desktop-links/Terraform.desktop \
+ ${PREFIX}/share/applications
+ @${MKDIR} ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/desktop-links/terraform.png \
+ ${PREFIX}/share/pixmaps
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in FAQ.sgml README.sgml UsersGuide.sgml i18n.txt