aboutsummaryrefslogtreecommitdiff
path: root/misc/translate/Makefile
diff options
context:
space:
mode:
authorOllivier Robert <roberto@FreeBSD.org>2002-06-17 19:41:50 +0000
committerOllivier Robert <roberto@FreeBSD.org>2002-06-17 19:41:50 +0000
commit487736ea12bbdee68c4689147e5438e4977e6c13 (patch)
tree4712e934a6a8e8d81f4331c1bdd919b9e6a3eaa0 /misc/translate/Makefile
parent2feca7e178ea59b36aa01a766019d10c64ea4ece (diff)
downloadports-487736ea12bbdee68c4689147e5438e4977e6c13.tar.gz
ports-487736ea12bbdee68c4689147e5438e4977e6c13.zip
translate uses the Babelfish engine from Altavista to translate sentences
in different languages. PR: ports/39242 Submitted by: Michael L. Hostbaek <mich@freebsdcluster.org>
Notes
Notes: svn path=/head/; revision=61439
Diffstat (limited to 'misc/translate/Makefile')
-rw-r--r--misc/translate/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/misc/translate/Makefile b/misc/translate/Makefile
new file mode 100644
index 000000000000..475ed863a8d1
--- /dev/null
+++ b/misc/translate/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: translate
+# Date created: Thu Jun 13, 2002
+# Whom: Michael L. Hostbaek (mich@freebsdcluster.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= translate
+PORTVERSION= 1.00
+CATEGORIES= misc
+MASTER_SITES= http://www.freebsdcluster.org/~mich/software/ \
+ ${MASTER_SITE_LOCAL}
+DISTNAME= translate
+
+MAINTAINER= mich@freebsdcluster.org
+
+RUN_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+USE_PERL5= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>