aboutsummaryrefslogtreecommitdiff
path: root/misc/txt2regex
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-22 17:23:30 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-22 17:23:30 +0000
commit3b9032fabc47df7c423b0fe802d1060c7b4e5816 (patch)
treebc94b068979a41f61931d2bd7979481f6acd573b /misc/txt2regex
parent7b3cf63dbe867642387b83d0d46a6ef77e970a05 (diff)
downloadports-3b9032fabc47df7c423b0fe802d1060c7b4e5816.tar.gz
ports-3b9032fabc47df7c423b0fe802d1060c7b4e5816.zip
Replace ${PERL} with ${REINPLACE_CMD}
PR: 39665 Submitted by: Oliver Braun <obraun@informatik.unibw-muenchen.de>
Notes
Notes: svn path=/head/; revision=61744
Diffstat (limited to 'misc/txt2regex')
-rw-r--r--misc/txt2regex/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/misc/txt2regex/Makefile b/misc/txt2regex/Makefile
index 214ffffa958c..e3c6e41f7a53 100644
--- a/misc/txt2regex/Makefile
+++ b/misc/txt2regex/Makefile
@@ -16,12 +16,13 @@ MAINTAINER= ports@FreeBSD.org
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
+USE_REINPLACE= yes
NO_BUILD= yes
post-patch:
- @${PERL} -pi -e "s,/bin/bash,${LOCALBASE}/bin/bash,g ; \
+ @${REINPLACE_CMD} -e "s,/bin/bash,${LOCALBASE}/bin/bash,g ; \
s,\`seq,\`gseq,g" ${WRKSRC}/${DISTNAME}.sh
- @${PERL} -pi -e "s,/usr,${LOCALBASE},g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s,/usr,${LOCALBASE},g" ${WRKSRC}/Makefile
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME}.sh ${PREFIX}/bin/txt2regex