aboutsummaryrefslogtreecommitdiff
path: root/misc/usbrh-libusb
diff options
context:
space:
mode:
authorMIHIRA Sanpei Yoshiro <sanpei@FreeBSD.org>2013-10-22 12:13:15 +0000
committerMIHIRA Sanpei Yoshiro <sanpei@FreeBSD.org>2013-10-22 12:13:15 +0000
commitffcfcf4e3ee5cc42e298fd217426a3be9a84bbee (patch)
tree2261d22ab8f7eb81ea27db428581b0ca745fb2f0 /misc/usbrh-libusb
parenta98125b745c2309eaf23887ef951e6e0b3538ce4 (diff)
downloadports-ffcfcf4e3ee5cc42e298fd217426a3be9a84bbee.tar.gz
ports-ffcfcf4e3ee5cc42e298fd217426a3be9a84bbee.zip
fix on clang enviroment(use cc instead of gcc)
Notes
Notes: svn path=/head/; revision=331257
Diffstat (limited to 'misc/usbrh-libusb')
-rw-r--r--misc/usbrh-libusb/Makefile2
-rw-r--r--misc/usbrh-libusb/files/patch-Makefile2
2 files changed, 1 insertions, 3 deletions
diff --git a/misc/usbrh-libusb/Makefile b/misc/usbrh-libusb/Makefile
index 65c0e9629f6f..df3ee4df30a5 100644
--- a/misc/usbrh-libusb/Makefile
+++ b/misc/usbrh-libusb/Makefile
@@ -12,8 +12,6 @@ DISTNAME= usbrh-${PORTVERSION}
MAINTAINER= sanpei@FreeBSD.org
COMMENT= Yet another reads temperatures and humidity from a Strawberry Linux USB-RH
-USE_GCC= any
-
PLIST_FILES= bin/usbrh
NO_STAGE= yes
diff --git a/misc/usbrh-libusb/files/patch-Makefile b/misc/usbrh-libusb/files/patch-Makefile
index faa3d8a75372..72bdc441f6e3 100644
--- a/misc/usbrh-libusb/files/patch-Makefile
+++ b/misc/usbrh-libusb/files/patch-Makefile
@@ -7,7 +7,7 @@
+all: $(EXE)
$(EXE): $(SRC)
- gcc -lusb -g -o $@ $^
-+ gcc -lusb -g -o $@ $(SRC)
++ cc -lusb -g -o $@ $(SRC)
clean:
rm $(EXE)