aboutsummaryrefslogtreecommitdiff
path: root/misc/wminfo
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2004-02-20 20:32:50 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2004-02-20 20:32:50 +0000
commitf4e43742fb0b298b812e65ada5f621873cd6da65 (patch)
treedcabdc8d985f0affe92e79722fc753dc14672734 /misc/wminfo
parent0da9c27b867f610a48d235dd85ac45c33a18a9cb (diff)
downloadports-f4e43742fb0b298b812e65ada5f621873cd6da65.tar.gz
ports-f4e43742fb0b298b812e65ada5f621873cd6da65.zip
Add wminfo 1.51, dockapp to run shell scripts and display the output.
PR: 62600 Submitted by: Thomas Kempka <t.kempka@web.de>
Notes
Notes: svn path=/head/; revision=101532
Diffstat (limited to 'misc/wminfo')
-rw-r--r--misc/wminfo/Makefile31
-rw-r--r--misc/wminfo/distinfo1
-rw-r--r--misc/wminfo/pkg-descr8
-rw-r--r--misc/wminfo/pkg-plist1
4 files changed, 41 insertions, 0 deletions
diff --git a/misc/wminfo/Makefile b/misc/wminfo/Makefile
new file mode 100644
index 000000000000..8bd55235f8ac
--- /dev/null
+++ b/misc/wminfo/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: wminfo
+# Date created: 09 February 2004
+# Whom: Thomas Kempka <t.kempka@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wminfo
+PORTVERSION= 1.51
+CATEGORIES= misc windowmaker
+MASTER_SITES= http://kling.mine.nu/files/
+
+MAINTAINER= t.kempka@web.de
+COMMENT= Dockapp to run shell scripts and display the output
+
+WRKSRC= ${WRKDIR}/${PORTNAME}/${PORTNAME}
+
+USE_X_PREFIX= yes
+USE_XPM= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$(LIBS)$$|& $$(OBJS)|g' \
+ -e 's|/usr/X11R6|$$(X11BASE)|g' \
+ -e 's|/share/include|/include|g' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/wminfo ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/misc/wminfo/distinfo b/misc/wminfo/distinfo
new file mode 100644
index 000000000000..4d84448ab008
--- /dev/null
+++ b/misc/wminfo/distinfo
@@ -0,0 +1 @@
+MD5 (wminfo-1.51.tar.gz) = dd4b168a31847694dfdb74772c57b7da
diff --git a/misc/wminfo/pkg-descr b/misc/wminfo/pkg-descr
new file mode 100644
index 000000000000..0be3488d5d5e
--- /dev/null
+++ b/misc/wminfo/pkg-descr
@@ -0,0 +1,8 @@
+This dockapp is designed to be very general purpose. It can display
+any kind of information as long as it is in text-format. It uses
+plugins to retrieve the information. Any script or program that
+sends its output to stdout can be used (have a look at the scripts
+in the plugins directory of the source tarball for examples).
+
+WWW: http://kling.mine.nu/wminfo.htm
+Author: Robert Kling <robkli-8@student.luth.se>
diff --git a/misc/wminfo/pkg-plist b/misc/wminfo/pkg-plist
new file mode 100644
index 000000000000..1f50faa112da
--- /dev/null
+++ b/misc/wminfo/pkg-plist
@@ -0,0 +1 @@
+bin/wminfo