aboutsummaryrefslogtreecommitdiff
path: root/misc/xfce4-weather-plugin/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-04-05 23:34:35 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-04-05 23:34:35 +0000
commit6bfbb2232415c4b7be12b4e53f26b7ed19f3feae (patch)
tree6196f6eff079996842efcfc200c1beb3dec466a8 /misc/xfce4-weather-plugin/Makefile
parente740886af012506944231c1d6d3484c3b31c8068 (diff)
downloadports-6bfbb2232415c4b7be12b4e53f26b7ed19f3feae.tar.gz
ports-6bfbb2232415c4b7be12b4e53f26b7ed19f3feae.zip
Add xfce4-weather-plugin 0.3.0, XFce 4 weather module for xfce4-panel.
PR: ports/65203 Submitted by: Filippo Natali <filippo@widestore.net>
Notes
Notes: svn path=/head/; revision=106276
Diffstat (limited to 'misc/xfce4-weather-plugin/Makefile')
-rw-r--r--misc/xfce4-weather-plugin/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/misc/xfce4-weather-plugin/Makefile b/misc/xfce4-weather-plugin/Makefile
new file mode 100644
index 000000000000..fb0629783e35
--- /dev/null
+++ b/misc/xfce4-weather-plugin/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: xfce4-weather-plugin
+# Date created: 04 April 2004
+# Whom: Filippo Natali <filippo@widestore.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-weather-plugin
+PORTVERSION= 0.3.0
+CATEGORIES= misc xfce
+MASTER_SITES= http://download.berlios.de/xfce-goodies/
+
+MAINTAINER= filippo@widestore.net
+COMMENT= XFce 4 weather module for xfce4-panel
+
+BUILD_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
+ xfcegui4.1:${PORTSDIR}/x11-toolkits/libxfce4gui \
+ xml2.5:${PORTSDIR}/textproc/libxml2 \
+ startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+
+USE_GNOME= gtk20
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER=13
+INSTALLS_SHLIB= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+.include <bsd.port.mk>