aboutsummaryrefslogtreecommitdiff
path: root/misc/xosd/Makefile
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2004-06-04 05:05:34 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2004-06-04 05:05:34 +0000
commitd5aa55de6c7640e84290a6beaf254ca21b76102a (patch)
treecb464ca91176f27b1bfff8d9d368001d8094b872 /misc/xosd/Makefile
parent7847d8fbdef6b9fc74cc158d5ec8c5df87e3873c (diff)
downloadports-d5aa55de6c7640e84290a6beaf254ca21b76102a.tar.gz
ports-d5aa55de6c7640e84290a6beaf254ca21b76102a.zip
Update to 2.2.7
PR: 67352 Submitted by: Roman Bogorodskiy <bogorodskiy@inbox.ru>
Notes
Notes: svn path=/head/; revision=110804
Diffstat (limited to 'misc/xosd/Makefile')
-rw-r--r--misc/xosd/Makefile37
1 files changed, 20 insertions, 17 deletions
diff --git a/misc/xosd/Makefile b/misc/xosd/Makefile
index 5839dce008b9..d237ce2d42fe 100644
--- a/misc/xosd/Makefile
+++ b/misc/xosd/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xosd
-PORTVERSION= 2.2.5
-PORTREVISION= 1
+PORTVERSION= 2.2.7
CATEGORIES= misc
MASTER_SITES= http://www.ignavus.net/ \
${MASTER_SITE_LOCAL}
@@ -17,11 +16,9 @@ MAINTAINER= perky@FreeBSD.org
COMMENT= X On-Screen-Display Library and XMMS plug-in
LIB_DEPENDS= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
-.if !defined(WITHOUT_XMMS)
-LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
-.endif
XMMS_CONFIG?= ${X11BASE}/bin/xmms-config
+USE_BZIP2= yes
USE_GETOPT_LONG=yes
USE_X_PREFIX= yes
USE_GMAKE= yes
@@ -33,21 +30,27 @@ CONFIGURE_ENV= LIBS=${PTHREAD_LIBS}' -L${LOCALBASE}/lib' \
CFLAGS='${CFLAGS}' X11BASE='${X11BASE}' \
GTK_CONFIG='${GTK_CONFIG}' GLIB_CONFIG='${GLIB_CONFIG}' \
XMMS_PLUGINDIR=${X11BASE}/lib/xmms
-.if defined(WITHOUT_XMMS)
+
+MAN1= osd_cat.1 xosd-config.1
+MAN3= xosd.3 xosd_create.3 xosd_destroy.3 xosd_display.3 \
+ xosd_get_number_lines.3 xosd_hide.3 xosd_is_onscreen.3 \
+ xosd_set_align.3 xosd_set_bar_length.3 \
+ xosd_set_horizontal_offset.3 xosd_set_pos.3 \
+ xosd_set_shadow_offset.3 xosd_set_vertical_offset.3 \
+ xosd_show.3 xosd_uninit.3
+
+OPTIONS= XMMS "Install XMMS-OSD plugin" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_XMMS)
+LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
+PLIST_SUB= WITH_XMMS=""
+.else
CONFIGURE_ARGS= --disable-new-plugin
PLIST_SUB= WITH_XMMS="@comment "
-PKGNAMESUFFIX= -without-xmms
-.else
-PLIST_SUB= WITH_XMMS=""
.endif
-MAN1= osd_cat.1 xosd-config.1
-MAN3= xosd_destroy.3 xosd_is_onscreen.3 xosd_set_shadow_offset.3 \
- xosd_display.3 xosd_set_align.3 xosd_set_vertical_offset.3 \
- xosd.3 xosd_get_number_lines.3 xosd_set_horizontal_offset.3 \
- xosd_show.3 xosd_create.3 xosd_hide.3 xosd_set_pos.3 \
- xosd_uninit.3 xosd_set_bar_length.3
-
pre-patch:
${REINPLACE_CMD} -e 's,-lc_r,-lblahblah,g' ${WRKSRC}/ltmain.sh
${REINPLACE_CMD} -e 's,-lpthread,${PTHREAD_LIBS},g' ${WRKSRC}/configure
@@ -55,4 +58,4 @@ pre-patch:
${REINPLACE_CMD} -e 's,^\(CFLAGS =\)\(.*\)$$,\1 -I.. \2,g' ${WRKSRC}/$f
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>