aboutsummaryrefslogtreecommitdiff
path: root/misc/xosd/Makefile
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2006-02-09 15:49:06 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2006-02-09 15:49:06 +0000
commite4d5f383f059b8fee747492a2e3a9fae25794610 (patch)
treea8e127db5193d9f79de21730ce98e7e693f98989 /misc/xosd/Makefile
parent787920917cfb142d819070bd2bca0b083dbee127 (diff)
downloadports-e4d5f383f059b8fee747492a2e3a9fae25794610.tar.gz
ports-e4d5f383f059b8fee747492a2e3a9fae25794610.zip
- gdk-pixbuf and gtk12 are required only for xmms plugin, so depend
on gdk-pixbuf only if building xmms plugin and remove gtk12 dependency as it would be catched up xmms. - Don't print sed's output PR: 92347 Submitted by: novel Approved by: maintainer timeout (2 weeks)
Notes
Notes: svn path=/head/; revision=155602
Diffstat (limited to 'misc/xosd/Makefile')
-rw-r--r--misc/xosd/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/misc/xosd/Makefile b/misc/xosd/Makefile
index 81a12593b14b..1fafca1aea58 100644
--- a/misc/xosd/Makefile
+++ b/misc/xosd/Makefile
@@ -15,14 +15,11 @@ MASTER_SITE_SUBDIR= perky
MAINTAINER= perky@FreeBSD.org
COMMENT= X On-Screen-Display Library and XMMS plug-in
-LIB_DEPENDS= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
-
XMMS_CONFIG?= ${X11BASE}/bin/xmms-config
USE_BZIP2= yes
USE_GETOPT_LONG=yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gtk12
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
@@ -44,7 +41,8 @@ OPTIONS= XMMS "Install XMMS-OSD plugin" on
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_XMMS)
-LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
+LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms \
+ gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
PLIST_SUB= WITH_XMMS=""
.else
CONFIGURE_ARGS= --disable-new-plugin
@@ -52,10 +50,10 @@ PLIST_SUB= WITH_XMMS="@comment "
.endif
pre-patch:
- ${REINPLACE_CMD} -e 's,-lc_r,-lblahblah,g' ${WRKSRC}/ltmain.sh
- ${REINPLACE_CMD} -e 's,-lpthread,${PTHREAD_LIBS},g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's,-lc_r,-lblahblah,g' ${WRKSRC}/ltmain.sh
+ @${REINPLACE_CMD} -e 's,-lpthread,${PTHREAD_LIBS},g' ${WRKSRC}/configure
.for f in src/libxosd/Makefile.in src/xmms_plugin/Makefile.in
- ${REINPLACE_CMD} -e 's,^\(CFLAGS =\)\(.*\)$$,\1 -I.. \2,g' ${WRKSRC}/$f
+ @${REINPLACE_CMD} -e 's,^\(CFLAGS =\)\(.*\)$$,\1 -I.. \2,g' ${WRKSRC}/$f
.endfor
.include <bsd.port.post.mk>