aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2013-01-10 20:49:04 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2013-01-10 20:49:04 +0000
commit1d0ebdb3ab948b4418c9fae06e797161164899d0 (patch)
tree95f0e3e36cc4f366431c17843edea566b6089e5c /misc
parent619325b19d4d65841ceec60eb3a82df2becb370e (diff)
downloadports-1d0ebdb3ab948b4418c9fae06e797161164899d0.tar.gz
ports-1d0ebdb3ab948b4418c9fae06e797161164899d0.zip
Stop hard coding ICU version and fix plist (missed by r310086).
Notes
Notes: svn path=/head/; revision=310204
Diffstat (limited to 'misc')
-rw-r--r--misc/sword/Makefile2
-rw-r--r--misc/sword/pkg-plist22
2 files changed, 12 insertions, 12 deletions
diff --git a/misc/sword/Makefile b/misc/sword/Makefile
index b0a99ac02ce2..1c1004a4387c 100644
--- a/misc/sword/Makefile
+++ b/misc/sword/Makefile
@@ -48,7 +48,7 @@ CONFIGURE_ARGS+= --without-curl
LIB_DEPENDS+= clucene:${PORTSDIR}/textproc/clucene \
icudata:${PORTSDIR}/devel/icu
CONFIGURE_ARGS+= --with-clucene --with-icu
-PLIST_SUB+= ICU=""
+PLIST_SUB+= ICU="" ICUVER="`${LOCALBASE}/bin/icu-config --version`"
.else
CONFIGURE_ARGS+= --without-clucene --without-icu
PLIST_SUB+= ICU="@comment "
diff --git a/misc/sword/pkg-plist b/misc/sword/pkg-plist
index 5878aa15ddaa..f72f2baeaf74 100644
--- a/misc/sword/pkg-plist
+++ b/misc/sword/pkg-plist
@@ -182,16 +182,16 @@ lib/libsword-%%PORTVERSION%%.so
lib/libsword.a
lib/libsword.la
lib/libsword.so
-%%ICU%%lib/sword/%%PORTVERSION%%_icu_50.1/translit_Any_Latex.res
-%%ICU%%lib/sword/%%PORTVERSION%%_icu_50.1/translit_Any_Latin1.res
-%%ICU%%lib/sword/%%PORTVERSION%%_icu_50.1/translit_BETA_Greek.res
-%%ICU%%lib/sword/%%PORTVERSION%%_icu_50.1/translit_BGreek_Greek.res
-%%ICU%%lib/sword/%%PORTVERSION%%_icu_50.1/translit_CCAT_Hebrew.res
-%%ICU%%lib/sword/%%PORTVERSION%%_icu_50.1/translit_CCAT_Syriac.res
-%%ICU%%lib/sword/%%PORTVERSION%%_icu_50.1/translit_Latin_Coptic.res
-%%ICU%%lib/sword/%%PORTVERSION%%_icu_50.1/translit_Latin_Gothic.res
-%%ICU%%lib/sword/%%PORTVERSION%%_icu_50.1/translit_Latin_Ugaritic.res
-%%ICU%%lib/sword/%%PORTVERSION%%_icu_50.1/translit_swordindex.res
+%%ICU%%lib/sword/%%PORTVERSION%%_icu_%%ICUVER%%/translit_Any_Latex.res
+%%ICU%%lib/sword/%%PORTVERSION%%_icu_%%ICUVER%%/translit_Any_Latin1.res
+%%ICU%%lib/sword/%%PORTVERSION%%_icu_%%ICUVER%%/translit_BETA_Greek.res
+%%ICU%%lib/sword/%%PORTVERSION%%_icu_%%ICUVER%%/translit_BGreek_Greek.res
+%%ICU%%lib/sword/%%PORTVERSION%%_icu_%%ICUVER%%/translit_CCAT_Hebrew.res
+%%ICU%%lib/sword/%%PORTVERSION%%_icu_%%ICUVER%%/translit_CCAT_Syriac.res
+%%ICU%%lib/sword/%%PORTVERSION%%_icu_%%ICUVER%%/translit_Latin_Coptic.res
+%%ICU%%lib/sword/%%PORTVERSION%%_icu_%%ICUVER%%/translit_Latin_Gothic.res
+%%ICU%%lib/sword/%%PORTVERSION%%_icu_%%ICUVER%%/translit_Latin_Ugaritic.res
+%%ICU%%lib/sword/%%PORTVERSION%%_icu_%%ICUVER%%/translit_swordindex.res
libdata/pkgconfig/sword.pc
%%DATADIR%%/locales.d/locales.conf
%%DATADIR%%/locales.d/abbr.conf
@@ -279,6 +279,6 @@ libdata/pkgconfig/sword.pc
@dirrm %%DATADIR%%/mods.d
@dirrm %%DATADIR%%/locales.d
@dirrm %%DATADIR%%
-%%ICU%%@dirrm lib/sword/%%PORTVERSION%%_icu_50.1
+%%ICU%%@dirrm lib/sword/%%PORTVERSION%%_icu_%%ICUVER%%
@dirrm lib/sword
@dirrm include/sword