aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-05-19 22:08:58 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-05-19 22:08:58 +0000
commita447e03db394610c5d080fcdb7606fc7d9ad2f91 (patch)
tree5032d3b4aa8666175602e789da4ee231cc5a9a6d /misc
parentbd93642ce3b0f384a44ab9a2c8befcdeda4e1711 (diff)
downloadports-a447e03db394610c5d080fcdb7606fc7d9ad2f91.tar.gz
ports-a447e03db394610c5d080fcdb7606fc7d9ad2f91.zip
Fix build with python26,
minor cleanups
Notes
Notes: svn path=/head/; revision=234239
Diffstat (limited to 'misc')
-rw-r--r--misc/kdeutils3/Makefile5
-rw-r--r--misc/kdeutils3/files/patch-configure23
2 files changed, 20 insertions, 8 deletions
diff --git a/misc/kdeutils3/Makefile b/misc/kdeutils3/Makefile
index ce61387ec218..5039f99902d5 100644
--- a/misc/kdeutils3/Makefile
+++ b/misc/kdeutils3/Makefile
@@ -25,22 +25,21 @@ CONFLICTS= kgpg-[0-9]* superkaramba-[0-9]*
USE_KDELIBS_VER=3
USE_KDEBASE_VER=3
-PREFIX= ${KDE_PREFIX}
USE_PYTHON= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:15
DO_NOT_COMPILE+=klaptopdaemon kmilo
CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
CONFIGURE_ARGS+=--with-pythondir=${LOCALBASE}
USE_LDCONFIG= yes
-LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
post-patch:
${REINPLACE_CMD} -e 's|>tar<|>gtar<|g' ${WRKSRC}/ark/ark.kcfg
+ ${REINPLACE_CMD} -e 's|%%PYTHON_VER%%|${PYTHON_VER}|g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/misc/kdeutils3/files/patch-configure b/misc/kdeutils3/files/patch-configure
index 2099c96dec80..2825c6de049f 100644
--- a/misc/kdeutils3/files/patch-configure
+++ b/misc/kdeutils3/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2007-10-08 10:31:38.000000000 -0400
-+++ configure 2008-08-14 10:17:24.000000000 -0400
-@@ -22642,10 +22642,10 @@
+--- ./configure.orig 2008-08-20 19:53:06.000000000 +0400
++++ ./configure 2009-05-19 21:14:00.000000000 +0400
+@@ -22643,10 +22643,10 @@
# This can be used to rebuild libtool when needed
@@ -13,7 +13,7 @@
# Prevent multiple expansion
-@@ -35082,153 +35082,7 @@
+@@ -35228,153 +35228,7 @@
fi
@@ -168,7 +168,7 @@
if test "xyes" = "x$have_l_funcs" ; then
-@@ -35789,89 +35643,6 @@
+@@ -35935,89 +35789,6 @@
fi
@@ -258,3 +258,16 @@
LIBGMP=
kde_safe_cppflags=$CPPFLAGS
+@@ -38739,10 +38510,10 @@
+
+
+
+-if test -z ""2.5""; then
++if test -z ""%%PYTHON_VER%%""; then
+ version="1.5"
+ else
+- version=""2.5""
++ version=""%%PYTHON_VER%%""
+ fi
+
+ { echo "$as_me:$LINENO: checking for Python$version" >&5