aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorRoger Hardiman <roger@FreeBSD.org>1999-06-07 22:10:33 +0000
committerRoger Hardiman <roger@FreeBSD.org>1999-06-07 22:10:33 +0000
commit37df4c349d1c774619f92915e73293e17baa942b (patch)
tree74099c027a0a67c26cff62624b614f596a013c79 /misc
parent4a5cc251ee5f3378b37ff685698e7fc172e56f56 (diff)
downloadports-37df4c349d1c774619f92915e73293e17baa942b.tar.gz
ports-37df4c349d1c774619f92915e73293e17baa942b.zip
initial import of vbidecode.
A program to read /dev/vbi0 and extract various data including Videotext/Teletext as .vtx files, Intercast data and VPS signals.
Notes
Notes: svn path=/head/; revision=19299
Diffstat (limited to 'misc')
-rw-r--r--misc/vbidecode/Makefile23
-rw-r--r--misc/vbidecode/distinfo1
-rw-r--r--misc/vbidecode/files/patch-aa20
-rw-r--r--misc/vbidecode/pkg-comment1
-rw-r--r--misc/vbidecode/pkg-descr21
-rw-r--r--misc/vbidecode/pkg-plist1
6 files changed, 67 insertions, 0 deletions
diff --git a/misc/vbidecode/Makefile b/misc/vbidecode/Makefile
new file mode 100644
index 000000000000..6f2291b9104a
--- /dev/null
+++ b/misc/vbidecode/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: vbidecode
+# Version required: 1.1.3
+# Date created: Mon June 7 16:11:00 BST 1999
+# Whom: Roger Hardiman <roger@freebsd.org>
+#
+# $Id: Makefile,v 1.17 1999/03/16 14:01:06 roger Exp $
+#
+# Note: vbidecode is one part of the bttv distribution, the Linux bt848 driver
+# It therefore has a DISTNAME of vbidecode but DISTFILES of bttv
+
+DISTNAME= vbidecode-1.1.3
+CATEGORIES= misc
+MASTER_SITES= http://www.ipass.net/~dbhopper/aa8vb/fxtv/
+DISTFILES= bttv-0.6.4.tar.gz
+
+MAINTAINER= roger@freebsd.org
+
+WRKSRC= ${WRKDIR}/bttv/apps/vbidecode
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/vbidecode ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/misc/vbidecode/distinfo b/misc/vbidecode/distinfo
new file mode 100644
index 000000000000..bc5f9ac6ba81
--- /dev/null
+++ b/misc/vbidecode/distinfo
@@ -0,0 +1 @@
+MD5 (bttv-0.6.4.tar.gz) = 4ae80a698ecab674981f62fcfc0353bd
diff --git a/misc/vbidecode/files/patch-aa b/misc/vbidecode/files/patch-aa
new file mode 100644
index 000000000000..6816e204e29d
--- /dev/null
+++ b/misc/vbidecode/files/patch-aa
@@ -0,0 +1,20 @@
+*** vbidecode.cc.orig Mon Jun 7 17:12:04 1999
+--- vbidecode.cc Mon Jun 7 17:12:20 1999
+*************** TODO:
+*** 52,58 ****
+ #include <sys/stat.h>
+
+ #include "tables.h"
+! #include "../../driver/bttv.h"
+
+ int verbosity=0;
+
+--- 52,59 ----
+ #include <sys/stat.h>
+
+ #include "tables.h"
+! /* #include "../../driver/bttv.h" */
+! #define VBI_MAXLINES 16
+
+ int verbosity=0;
+
diff --git a/misc/vbidecode/pkg-comment b/misc/vbidecode/pkg-comment
new file mode 100644
index 000000000000..f65b2c95fe3f
--- /dev/null
+++ b/misc/vbidecode/pkg-comment
@@ -0,0 +1 @@
+Get Videotext/Teletext (.vtx) and other VBI data from TV channels
diff --git a/misc/vbidecode/pkg-descr b/misc/vbidecode/pkg-descr
new file mode 100644
index 000000000000..4d525e7e761d
--- /dev/null
+++ b/misc/vbidecode/pkg-descr
@@ -0,0 +1,21 @@
+vbidecode - VBI data decoder
+Copyright (C) 1997,98 Ralph Metzler (rjkm@thp.uni-koeln.de)
+
+Vbidecode decodes some of the data structures that are transmitted in the
+VBI (Vertical Blanking Interval) of television transmissions.
+It can decode the following formats, with some restrictions for NTSC users.
+
+- videotext/teletext
+ text based information pages (40x25 characters)
+
+- intercast
+ WWW pages transmitted via line 31 videotext in a kind of compressed
+ SLIP format
+
+- VPS
+ channel information and signals for automatic start/stop of VCRs
+
+- Videocrypt 1 and 2
+
+VBI data is read from /dev/vbi0 which is provided by a Video Capture
+card such as those using the Bt848/Bt878 family of video capture chips.
diff --git a/misc/vbidecode/pkg-plist b/misc/vbidecode/pkg-plist
new file mode 100644
index 000000000000..be42180f8c78
--- /dev/null
+++ b/misc/vbidecode/pkg-plist
@@ -0,0 +1 @@
+bin/vbidecode