aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1999-05-20 20:46:29 +0000
committerSatoshi Asami <asami@FreeBSD.org>1999-05-20 20:46:29 +0000
commit51992523b41ae8fc7a71d80887b120181234ae06 (patch)
tree811f42c05e9a99f18a5fa58bc5397d3d847c9ab9 /misc
parent65281e8ece38eac4d60832195868edffb6a7ab51 (diff)
downloadports-51992523b41ae8fc7a71d80887b120181234ae06.tar.gz
ports-51992523b41ae8fc7a71d80887b120181234ae06.zip
3.2R upgrade kit. (Yes, we already need one, due to a bugfix in fetch!)
Requested by: jmg
Notes
Notes: svn path=/head/; revision=18907
Diffstat (limited to 'misc')
-rw-r--r--misc/32upgrade/Makefile35
-rw-r--r--misc/32upgrade/pkg-comment1
-rw-r--r--misc/32upgrade/pkg-descr5
-rw-r--r--misc/32upgrade/pkg-install5
-rw-r--r--misc/32upgrade/pkg-plist1
-rw-r--r--misc/32upgrade/pkg-req5
6 files changed, 52 insertions, 0 deletions
diff --git a/misc/32upgrade/Makefile b/misc/32upgrade/Makefile
new file mode 100644
index 000000000000..b712b780bcae
--- /dev/null
+++ b/misc/32upgrade/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: 3.2R to 3-stable upgrade kit
+# Version required: n/a
+# Date created: 20 May 1999
+# Whom: asami
+#
+# $Id$
+#
+
+DISTNAME= 32upgrade-1999.05.20
+CATEGORIES= misc
+DISTFILES= # empty
+
+MAINTAINER= asami@Freebsd.ORG
+
+.include <bsd.port.pre.mk>
+
+.if !defined(PACKAGE_BUILDING)
+BROKEN= this \"port\" is for building packages for distribution only, please get the package from http://www.freebsd.org/ports/ if you need an upgrade
+.elif ${OSVERSION} < 320000
+FORBIDDEN= this needs to be built on a 3.2-stable system
+.endif
+NO_MTREE= yes
+PREFIX= /
+NO_BUILD= yes
+PKGINSTALL= ${WRKDIR}/INSTALL
+
+do-install:
+ ${SED} -e "s/%%VERSION%%/${BSDPORTMKVERSION}/" ${PKGDIR}/INSTALL \
+ > ${PKGINSTALL}
+
+deinstall:
+ @${ECHO} "You can't delete this port."
+ @${FALSE}
+
+.include <bsd.port.post.mk>
diff --git a/misc/32upgrade/pkg-comment b/misc/32upgrade/pkg-comment
new file mode 100644
index 000000000000..5da9104fd538
--- /dev/null
+++ b/misc/32upgrade/pkg-comment
@@ -0,0 +1 @@
+A convenience package to upgrade your 3.2 system to 3.2-stable for ports.
diff --git a/misc/32upgrade/pkg-descr b/misc/32upgrade/pkg-descr
new file mode 100644
index 000000000000..08494159e61b
--- /dev/null
+++ b/misc/32upgrade/pkg-descr
@@ -0,0 +1,5 @@
+This package will allow you to upgrade your 3.2R system to
+3.2-stable, so you can compile and use all ports in ports-current.
+
+Satoshi
+asami@freebsd.org
diff --git a/misc/32upgrade/pkg-install b/misc/32upgrade/pkg-install
new file mode 100644
index 000000000000..8ed8de67d62f
--- /dev/null
+++ b/misc/32upgrade/pkg-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+if [ "$2" != "PRE-INSTALL" ]; then
+ exit 0
+fi
+echo %%VERSION%% > /var/db/port.mkversion
diff --git a/misc/32upgrade/pkg-plist b/misc/32upgrade/pkg-plist
new file mode 100644
index 000000000000..b641c83f4500
--- /dev/null
+++ b/misc/32upgrade/pkg-plist
@@ -0,0 +1 @@
+usr/bin/fetch
diff --git a/misc/32upgrade/pkg-req b/misc/32upgrade/pkg-req
new file mode 100644
index 000000000000..1eb81c651314
--- /dev/null
+++ b/misc/32upgrade/pkg-req
@@ -0,0 +1,5 @@
+#!/bin/sh
+if [ $2 = "DEINSTALL" ]; then
+ echo "Package $1 cannot be removed -- to do so will render your system useless."
+ exit 1
+fi