aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorSeiichirou Hiraoka <flathill@FreeBSD.org>1999-05-10 16:44:07 +0000
committerSeiichirou Hiraoka <flathill@FreeBSD.org>1999-05-10 16:44:07 +0000
commitca1813bb8381bbf71d14c99eeb1fd65f5d56f20e (patch)
tree3c5992fd6cf63df0fa3f9a0a53c9725e5883f118 /misc
parent0dc93ffdfbc41dbdf2663a183a11f8d0c564a17e (diff)
downloadports-ca1813bb8381bbf71d14c99eeb1fd65f5d56f20e.tar.gz
ports-ca1813bb8381bbf71d14c99eeb1fd65f5d56f20e.zip
PR: ports/11619
Submitted by: jim@blues.ghis.net A dockapp that displays 4 or 9 buttons to run apps of your choice.
Notes
Notes: svn path=/head/; revision=18755
Diffstat (limited to 'misc')
-rw-r--r--misc/asbutton/Makefile40
-rw-r--r--misc/asbutton/distinfo1
-rw-r--r--misc/asbutton/pkg-comment1
-rw-r--r--misc/asbutton/pkg-descr7
-rw-r--r--misc/asbutton/pkg-plist53
5 files changed, 102 insertions, 0 deletions
diff --git a/misc/asbutton/Makefile b/misc/asbutton/Makefile
new file mode 100644
index 000000000000..fef767f5d45e
--- /dev/null
+++ b/misc/asbutton/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: asbutton
+# Version required: 0.2
+# Date created: 10 May 1999
+# Whom: Jim Mock <jim@phrantic.phear.net>
+#
+# $Id$
+#
+
+DISTNAME= asbutton-0.2
+CATEGORIES= misc windowmaker afterstep
+MASTER_SITES= http://www.tigr.net/afterstep/as-apps/download/asbutton/
+
+MAINTAINER= jim@phrantic.phear.net
+
+LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
+
+USE_X_PREFIX= yes
+
+do-build:
+ (cd ${WRKSRC} && make)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/asbutton ${PREFIX}/bin
+ @${ECHO} " "
+ @${ECHO} "===> Installing icons in ${PREFIX}/share/asbutton"
+ @${ECHO} " "
+ @${MKDIR} ${PREFIX}/share/asbutton && chmod a+rx ${PREFIX}/share/asbutton
+ ${INSTALL_DATA} ${WRKSRC}/icons/*.xpm ${PREFIX}/share/asbutton
+
+post-install:
+ @${ECHO} " "
+ @${ECHO} "===> Installing sample asbuttonrc in ${PREFIX}/share/examples/asbutton"
+ @${ECHO} "===> Copy to ~/.asbuttonrc and modify to desired config."
+ @${ECHO} " "
+ @${MKDIR} ${PREFIX}/share/examples/asbutton && chmod a+rx ${PREFIX}/share/examples/asbutton
+ ${INSTALL_DATA} ${WRKSRC}/.asbuttonrc ${PREFIX}/share/examples/asbutton/asbuttonrc && chmod u+rw ${PREFIX}/share/examples/asbutton/asbuttonrc
+ @${ECHO} " "
+ @${ECHO} "===> Use 'asbutton -h' for help."
+
+.include <bsd.port.mk>
diff --git a/misc/asbutton/distinfo b/misc/asbutton/distinfo
new file mode 100644
index 000000000000..94fe99d6aa4c
--- /dev/null
+++ b/misc/asbutton/distinfo
@@ -0,0 +1 @@
+MD5 (asbutton-0.2.tar.gz) = 70b6ef9037352161dcd8e4b36f7c939e
diff --git a/misc/asbutton/pkg-comment b/misc/asbutton/pkg-comment
new file mode 100644
index 000000000000..4710b47e398f
--- /dev/null
+++ b/misc/asbutton/pkg-comment
@@ -0,0 +1 @@
+A dockapp that displays 4 or 9 buttons to run apps of your choice.
diff --git a/misc/asbutton/pkg-descr b/misc/asbutton/pkg-descr
new file mode 100644
index 000000000000..37d7edf46ddc
--- /dev/null
+++ b/misc/asbutton/pkg-descr
@@ -0,0 +1,7 @@
+A swallowable applet presents a number of little buttons inside a
+Wharf or dock icon and each of those starts an application when
+clicked.
+
+WWW Homepage: http://www.mindspring.com/~pancake/asbutton.htm
+
+- Jim <jim@phrantic.phear.net>
diff --git a/misc/asbutton/pkg-plist b/misc/asbutton/pkg-plist
new file mode 100644
index 000000000000..3f60c076f742
--- /dev/null
+++ b/misc/asbutton/pkg-plist
@@ -0,0 +1,53 @@
+bin/asbutton
+share/asbutton/asb4-1.xpm
+share/asbutton/asb4-2.xpm
+share/asbutton/asb4-3.xpm
+share/asbutton/asb4-4.xpm
+share/asbutton/asb4-blank.xpm
+share/asbutton/asb4-bullethole.xpm
+share/asbutton/asb4-filingcabinet.xpm
+share/asbutton/asb4-gear.xpm
+share/asbutton/asb4-gnu-button-thang.xpm
+share/asbutton/asb4-gnu-defaultapp.xpm
+share/asbutton/asb4-gv.xpm
+share/asbutton/asb4-info.xpm
+share/asbutton/asb4-info2.xpm
+share/asbutton/asb4-netscape.xpm
+share/asbutton/asb4-network.xpm
+share/asbutton/asb4-package.xpm
+share/asbutton/asb4-redhat.xpm
+share/asbutton/asb4-term-bsd.xpm
+share/asbutton/asb4-term-linux.xpm
+share/asbutton/asb4-turn.xpm
+share/asbutton/asb4-wilbur.xpm
+share/asbutton/asb4-xv.xpm
+share/asbutton/asb9-1.xpm
+share/asbutton/asb9-2.xpm
+share/asbutton/asb9-3.xpm
+share/asbutton/asb9-4.xpm
+share/asbutton/asb9-5.xpm
+share/asbutton/asb9-6.xpm
+share/asbutton/asb9-7.xpm
+share/asbutton/asb9-8.xpm
+share/asbutton/asb9-9.xpm
+share/asbutton/asb9-blank.xpm
+share/asbutton/asb9-bullethole.xpm
+share/asbutton/asb9-filecabinet.xpm
+share/asbutton/asb9-gear.xpm
+share/asbutton/asb9-gnu-button-thang.xpm
+share/asbutton/asb9-gnu-defaultapp.xpm
+share/asbutton/asb9-gv.xpm
+share/asbutton/asb9-info.xpm
+share/asbutton/asb9-info2.xpm
+share/asbutton/asb9-netscape.xpm
+share/asbutton/asb9-network.xpm
+share/asbutton/asb9-package.xpm
+share/asbutton/asb9-redhat.xpm
+share/asbutton/asb9-term-bsd.xpm
+share/asbutton/asb9-term-linux.xpm
+share/asbutton/asb9-turn.xpm
+share/asbutton/asb9-wilbur.xpm
+share/asbutton/asb9-xv.xpm
+share/examples/asbutton/asbuttonrc
+@dirrm share/asbutton
+@dirrm share/examples/asbutton