aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-01-21 22:15:45 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-01-21 22:15:45 +0000
commit1cb458c20befe3a4310488102e8d4a5899925bcd (patch)
tree64811c4db9dd468ffef1ab5d14eb959a93fedeaf /misc
parentfeb7b457a05615630751b8c5a0f6d078e943c79d (diff)
downloadports-1cb458c20befe3a4310488102e8d4a5899925bcd.tar.gz
ports-1cb458c20befe3a4310488102e8d4a5899925bcd.zip
Implement PERL_BUILD_DEPENDS / PERL_RUN_DEPENDS for my ports.
Notes
Notes: svn path=/head/; revision=154095
Diffstat (limited to 'misc')
-rw-r--r--misc/tinderbox/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/misc/tinderbox/Makefile b/misc/tinderbox/Makefile
index c29b26f656c7..7a7103944bc7 100644
--- a/misc/tinderbox/Makefile
+++ b/misc/tinderbox/Makefile
@@ -13,9 +13,9 @@ MASTER_SITES= http://tinderbox.marcuscom.com/
MAINTAINER= edwin@mavetju.org
COMMENT= Port build tinderbox system
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net \
- ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB \
+PERL_RUN_DEPENDS= Digest-MD5:${PORTSDIR}/security/p5-Digest-MD5 \
+ Net-SMTP:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB \
cvsup:${PORTSDIR}/net/cvsup-without-gui
OPTIONS= PGSQL "With pgsql" On \
@@ -37,13 +37,13 @@ USE_PHP= session
.if defined(WITH_PGSQL)
USE_PGSQL= yes
USE_PHP+= pgsql
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+PERL_RUN_DEPENDS+= DBD-Pg:${PORTSDIR}/databases/p5-DBD-Pg
.endif
.if defined(WITH_MYSQL)
USE_PHP+= mysql
USE_MYSQL= yes
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+PERL_RUN_DEPENDS+= DBD-mysql:${PORTSDIR}/databases/p5-DBD-mysql
.endif
.include "${PORTSDIR}/Mk/bsd.php.mk"