aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2002-08-26 15:33:08 +0000
committerMax Khon <fjoe@FreeBSD.org>2002-08-26 15:33:08 +0000
commit0ac3ead5bb90074edc570032d52bc592bd9ad199 (patch)
tree1dabf6ba5cf1c02856e1f81ebfa293bc1fecbc03 /misc
parenta6c0334406c4bfa0e854728e897fab7e253c069a (diff)
downloadports-0ac3ead5bb90074edc570032d52bc592bd9ad199.tar.gz
ports-0ac3ead5bb90074edc570032d52bc592bd9ad199.zip
- always link with locally built libedit and libvfs-mc
- add LOCALBASE to CONFIGURE_ENV PR: 41840
Notes
Notes: svn path=/head/; revision=65048
Diffstat (limited to 'misc')
-rw-r--r--misc/mc/Makefile3
-rw-r--r--misc/mc/files/patch-aa29
2 files changed, 30 insertions, 2 deletions
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index b0373cdef909..f9ce60b870c6 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -54,7 +54,8 @@ CONFIGURE_ARGS+=--without-gnome
CONFIGURE_ARGS+=--without-edit
.endif
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
- LDFLAGS="-L${LOCALBASE}/lib -lintl"
+ LDFLAGS="-L${LOCALBASE}/lib -lintl" \
+ LOCALBASE=${LOCALBASE}
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
.if ${PORTNAME} == "mc"
PLIST_SUB+= GNOMEMC="@comment " MC="" SHARE_PATH="share"
diff --git a/misc/mc/files/patch-aa b/misc/mc/files/patch-aa
index ad601425d952..6b2a244e8f08 100644
--- a/misc/mc/files/patch-aa
+++ b/misc/mc/files/patch-aa
@@ -1,5 +1,5 @@
--- configure.orig Fri Aug 24 15:05:06 2001
-+++ configure Tue Aug 6 16:45:45 2002
++++ configure Mon Aug 26 22:26:15 2002
@@ -2552,6 +2552,8 @@
echo "$as_me:2552: result: no" >&5
echo "${ECHO_T}no" >&6
@@ -9,6 +9,15 @@
rm -f conftest*
echo "$as_me:2557: checking for minix/config.h" >&5
+@@ -11904,7 +11906,7 @@
+ if test $use_vfs = yes
+ then
+ LIBVFS="libvfs-mc.a"
+- LVFS="-lvfs-mc"
++ LVFS="../vfs/libvfs-mc.a"
+ MCCPPFLAGS="$MCCPPFLAGS -I\$(vfsdir)"
+ echo "$as_me:11909: result: Using the VFS switch code" >&5
+ echo "${ECHO_T}Using the VFS switch code" >&6
@@ -12971,7 +12973,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
@@ -27,6 +36,24 @@
screen_manager="SLang (system-installed library)"
echo "$as_me:13256: result: Using system installed SLang library" >&5
echo "${ECHO_T}Using system installed SLang library" >&6
+@@ -13489,7 +13491,7 @@
+
+ LIBEDIT_A="libedit.a"
+ MCEDIT="mcedit"
+- LEDIT="-ledit"
++ LEDIT="../edit/libedit.a"
+ EDIT_msg="yes"
+ echo "$as_me:13494: result: will call internal editor" >&5
+ echo "${ECHO_T}will call internal editor" >&6
+@@ -13505,7 +13507,7 @@
+
+ LIBEDIT_A="libedit.a"
+ MCEDIT="mcedit"
+- LEDIT="-ledit"
++ LEDIT="../edit/libedit.a"
+ EDIT_msg="yes"
+ echo "$as_me:13510: result: will call internal editor" >&5
+ echo "${ECHO_T}will call internal editor" >&6
@@ -14223,7 +14225,7 @@
#define HAVE_SYSTEM_SLANG 1
EOF