aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-29 12:42:04 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-29 12:42:04 +0000
commit222461c302e52a3848555e999ecc7a10f98b278e (patch)
tree4fad0f8d9c328a570a49371daf5f0078d7075272 /misc
parentb6155c63444b79580e9bd13727472581d1ed66f1 (diff)
downloadports-222461c302e52a3848555e999ecc7a10f98b278e.tar.gz
ports-222461c302e52a3848555e999ecc7a10f98b278e.zip
Convert to new option framework
Notes
Notes: svn path=/head/; revision=300215
Diffstat (limited to 'misc')
-rw-r--r--misc/hotkeys/Makefile9
-rw-r--r--misc/mc-light/Makefile16
-rw-r--r--misc/xosd/Makefile8
3 files changed, 18 insertions, 15 deletions
diff --git a/misc/hotkeys/Makefile b/misc/hotkeys/Makefile
index 8203730a1150..1883e181a722 100644
--- a/misc/hotkeys/Makefile
+++ b/misc/hotkeys/Makefile
@@ -28,11 +28,12 @@ USE_GMAKE= yes
MAN1= hotkeys.1
-OPTIONS= XOSD "Enable On-Screen-Display support" on
+OPTIONS_DEFINE= OSD
+OPTIONS_DEFAULT= OSD
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_XOSD)
+.if ${PORT_OPTIONS:MOSD}
LIB_DEPENDS+= xosd.4:${PORTSDIR}/misc/xosd
CONFIGURE_ARGS+= --with-xosd
.endif
@@ -53,4 +54,4 @@ post-install:
fi
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/misc/mc-light/Makefile b/misc/mc-light/Makefile
index e75c679da0e3..b9c804104263 100644
--- a/misc/mc-light/Makefile
+++ b/misc/mc-light/Makefile
@@ -19,9 +19,9 @@ RUN_DEPENDS+= gawk:${PORTSDIR}/lang/gawk
CONFLICTS= mc-4.7*
-OPTIONS= NLS "Enable gettext support" on \
- SUBSHELL "Build with subshell support (only for bash!)" off \
- MC_IN_MC "Allow run mc inside mc (useful for mcedit)" off
+OPTIONS_DEFINE= NLS SUBSHELL MC_IN_MC
+SUBSHELL_DESC= Build with subshell support (only for bash!)
+MC_IN_MC_DESC= Allow run mc inside mc (useful for mcedit)
USE_GMAKE= yes
USE_ICONV= yes
@@ -37,13 +37,13 @@ CONFIGURE_ARGS+=--with-included-slang \
MAN1= mc.1 mcedit.1
MAN8= mcserv.8
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITH_SUBSHELL)
+.if ${PORT_OPTIONS:MSUBSHELL}
CONFIGURE_ARGS+=--without-subshell
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
@@ -51,7 +51,7 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.if defined(WITH_MC_IN_MC)
+.if ${PORT_OPTIONS:MMC_IN_MC}
CPPFLAGS+= -DMC_IN_MC_ALLOWED
.endif
@@ -60,4 +60,4 @@ post-install:
${CHMOD} 755 ${PREFIX}/share/mc/extfs/${i}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/misc/xosd/Makefile b/misc/xosd/Makefile
index dd5e7c2c540c..4d07d8f03f74 100644
--- a/misc/xosd/Makefile
+++ b/misc/xosd/Makefile
@@ -34,11 +34,13 @@ MAN3= xosd.3 xosd_create.3 xosd_destroy.3 xosd_display.3 \
xosd_set_shadow_offset.3 xosd_set_vertical_offset.3 \
xosd_show.3 xosd_uninit.3
-OPTIONS= XMMS "Install XMMS-OSD plugin" on
+OPTIONS_DEFINE= XMMS
+OPTIONS_DEFAULT= XMMS
+XMMS_DESC= Install XMMS-OSD plugin
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_XMMS)
+.if ${PORT_OPTIONS:MXMMS}
LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms \
gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
PLIST_SUB= WITH_XMMS=""
@@ -54,4 +56,4 @@ pre-patch:
@${REINPLACE_CMD} -e 's,^\(CFLAGS =\)\(.*\)$$,\1 -I.. \2,g' ${WRKSRC}/$f
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>