aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2010-04-07 14:13:06 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2010-04-07 14:13:06 +0000
commit76e642b9034f638a25f0507a34aedd9812a3c1ec (patch)
treeca907d51d5bfebd860be3a25ad0227144ed66649 /misc
parented456ecdc69575cfc448f76c5689d103d5e869c1 (diff)
downloadports-76e642b9034f638a25f0507a34aedd9812a3c1ec.tar.gz
ports-76e642b9034f638a25f0507a34aedd9812a3c1ec.zip
New port py-progressbar version 2.2: A text progressbar library for python
Notes
Notes: svn path=/head/; revision=252386
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-progressbar/Makefile29
-rw-r--r--misc/py-progressbar/distinfo3
-rw-r--r--misc/py-progressbar/pkg-descr19
4 files changed, 52 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index d5a27c2defc9..27708e7c77a6 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -445,6 +445,7 @@
SUBDIR += py-distutils
SUBDIR += py-osd
SUBDIR += py-pexpect
+ SUBDIR += py-progressbar
SUBDIR += py-qt4-demo
SUBDIR += py-qt4-doc
SUBDIR += py-yolk
diff --git a/misc/py-progressbar/Makefile b/misc/py-progressbar/Makefile
new file mode 100644
index 000000000000..b393ca665370
--- /dev/null
+++ b/misc/py-progressbar/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: progressbar
+# Date created: Wed Apr 7 13:54:04 UTC 2010
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= progressbar
+PORTVERSION= 2.2
+CATEGORIES= misc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= A text progressbar library for python
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+INSTALLS_EGGINFO= yes
+
+PLIST_FILES= \
+ %%PYTHON_SITELIBDIR%%/progressbar.py \
+ %%PYTHON_SITELIBDIR%%/progressbar.pyc \
+ %%PYTHON_SITELIBDIR%%/progressbar.pyo
+
+post-patch:
+ @${REINPLACE_CMD} -E -e 's|/usr/bin/python|${PYTHON_CMD}|' \
+ ${WRKSRC}/${PORTNAME}.py
+
+.include <bsd.port.mk>
diff --git a/misc/py-progressbar/distinfo b/misc/py-progressbar/distinfo
new file mode 100644
index 000000000000..dfcaf05c7c07
--- /dev/null
+++ b/misc/py-progressbar/distinfo
@@ -0,0 +1,3 @@
+MD5 (progressbar-2.2.tar.gz) = 8ea4e2c17a8ec9e7d153767c5f2a7b28
+SHA256 (progressbar-2.2.tar.gz) = dfee5201237ca0e942baa4d451fee8bf8a54065a337fabe7378b8585aeda56a3
+SIZE (progressbar-2.2.tar.gz) = 5118
diff --git a/misc/py-progressbar/pkg-descr b/misc/py-progressbar/pkg-descr
new file mode 100644
index 000000000000..c9c13f58601c
--- /dev/null
+++ b/misc/py-progressbar/pkg-descr
@@ -0,0 +1,19 @@
+This library provides a text mode progressbar. This is tipically
+used to display the progress of a long running operation, providing
+a visual clue that processing is underway.
+
+The ProgressBar class manages the progress, and the format of the
+line is given by a number of widgets. A widget is an object that
+may display diferently depending on the state of the progress.
+
+There are three types of widget:
+
+- a string, which always shows itself;
+
+- a ProgressBarWidget, which may return a diferent value every time
+it's update method is called; and
+
+- a ProgressBarWidgetHFill, which is like ProgressBarWidget, except
+it expands to fill the remaining width of the line.
+
+WWW: http://pypi.python.org/pypi/progressbar/