aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2003-11-09 01:13:23 +0000
committerJames E. Housley <jeh@FreeBSD.org>2003-11-09 01:13:23 +0000
commit205d3efaa02757ebf7c066a8e87bb2f86b8f6c00 (patch)
treeb350263671ecd41491728f0449160c7d8aba42f3 /misc
parent51854c28c8f719e483f096d2ed9a820554d320cf (diff)
downloadports-205d3efaa02757ebf7c066a8e87bb2f86b8f6c00.tar.gz
ports-205d3efaa02757ebf7c066a8e87bb2f86b8f6c00.zip
Upgraded Port: misc/firestring to 0.9.6
PR: 58547 Submitted By: MAINTAINER
Notes
Notes: svn path=/head/; revision=93481
Diffstat (limited to 'misc')
-rw-r--r--misc/firestring/Makefile64
-rw-r--r--misc/firestring/distinfo2
-rw-r--r--misc/firestring/files/patch-configure65
-rw-r--r--misc/firestring/pkg-descr22
-rw-r--r--misc/firestring/pkg-plist7
5 files changed, 54 insertions, 106 deletions
diff --git a/misc/firestring/Makefile b/misc/firestring/Makefile
index d28b995a7fbf..50bb38eda207 100644
--- a/misc/firestring/Makefile
+++ b/misc/firestring/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= firestring
-PORTVERSION= 0.1.23
+PORTVERSION= 0.9.6
CATEGORIES= misc net devel
-MASTER_SITES= http://ares.penguinhosting.net/~ian/projects/ \
+MASTER_SITES= http://firestuff.org/projects/ \
http://www.wa.apana.org.au/~dean/sources/ \
ftp://ftp.wa.apana.org.au/pub/pc/unix/packages/
DISTNAME= ${PORTNAME}
@@ -20,30 +20,44 @@ COMMENT= A library to make string handling easier in C
HAS_CONFIGURE= yes
INSTALLS_SHLIB= yes
-MAN3= firestring_chomp.3 firestring_chug.3 \
- firestring_concat.3 firestring_conf_add.3 \
- firestring_conf_find.3 firestring_conf_find_next.3 \
- firestring_conf_free.3 firestring_conf_parse.3 \
- firestring_conf_parse_next.3 firestring_estr_0.3 \
- firestring_estr_alloc.3 firestring_estr_base64_decode.3 \
- firestring_estr_base64_encode.3 firestring_estr_ends.3 \
- firestring_estr_estrcasecmp.3 firestring_estr_estrcat.3 \
- firestring_estr_estrcmp.3 firestring_estr_estrcpy.3 \
- firestring_estr_estristr.3 \
- firestring_estr_estrncasecmp.3 firestring_estr_estrstr.3 \
- firestring_estr_expand.3 firestring_estr_free.3 \
- firestring_estr_read.3 firestring_estr_sprintf.3 \
- firestring_estr_starts.3 firestring_estr_strcasecmp.3 \
- firestring_estr_strcat.3 firestring_estr_strchr.3 \
- firestring_estr_strcmp.3 firestring_estr_strcpy.3 \
- firestring_estr_stristr.3 firestring_estr_strstr.3 \
+MAN3= firestring_chomp.3 firestring_estr_munch.3 \
+ firestring_chug.3 firestring_estr_read.3 \
+ firestring_concat.3 firestring_estr_replace.3 \
+ firestring_conf_add.3 firestring_estr_sprintf.3 \
+ firestring_conf_delete.3 firestring_estr_starts.3 \
+ firestring_conf_find.3 firestring_estr_strcasecmp.3 \
+ firestring_conf_find_next.3 firestring_estr_strcat.3 \
+ firestring_conf_free.3 firestring_estr_strchr.3 \
+ firestring_conf_parse.3 firestring_estr_strcmp.3 \
+ firestring_conf_parse_next.3 \
+ firestring_estr_strcpy.3 \
+ firestring_estr_0.3 firestring_estr_stristr.3 \
+ firestring_estr_aestrcat.3 firestring_estr_strstr.3 \
+ firestring_estr_aestrcpy.3 firestring_estr_tolower.3 \
+ firestring_estr_alloc.3 firestring_estr_toupper.3 \
+ firestring_estr_areplace.3 firestring_estr_trim.3 \
+ firestring_estr_astrcat.3 firestring_estr_vsprintf.3 \
+ firestring_estr_astrcpy.3 \
firestring_estr_xml_decode.3 \
- firestring_estr_xml_encode.3 firestring_hextoi.3 \
- firestring_malloc.3 firestring_realloc.3 \
- firestring_snprintf.3 firestring_strcasecmp.3 \
- firestring_strdup.3 firestring_strncasecmp.3 \
- firestring_strncat.3 firestring_strncpy.3 \
- libfirestring.3
+ firestring_estr_base64_decode.3 \
+ firestring_estr_xml_encode.3 \
+ firestring_estr_base64_encode.3 firestring_fprintf.3 \
+ firestring_estr_chomp.3 firestring_hextoi.3 \
+ firestring_estr_chug.3 firestring_malloc.3 \
+ firestring_estr_ends.3 firestring_printf.3 \
+ firestring_estr_estrcasecmp.3 firestring_realloc.3 \
+ firestring_estr_estrcat.3 \
+ firestring_set_error_handler.3 \
+ firestring_estr_estrcmp.3 firestring_snprintf.3 \
+ firestring_estr_estrcpy.3 firestring_strcasecmp.3 \
+ firestring_estr_estristr.3 firestring_strdup.3 \
+ firestring_estr_estrncasecmp.3 \
+ firestring_strncasecmp.3 \
+ firestring_estr_estrstr.3 firestring_strncat.3 \
+ firestring_estr_expand.3 firestring_strncpy.3 \
+ firestring_estr_free.3 firestring_trim.3 \
+ firestring_estr_ip_chug.3 firestring_vfprintf.3 \
+ firestring_estr_ip_trim.3 libfirestring.3
post-install:
@cd ${PREFIX}/lib; ${MV} libfirestring.so libfirestring.so.0; \
diff --git a/misc/firestring/distinfo b/misc/firestring/distinfo
index d909bc169e3f..eeb2571b2883 100644
--- a/misc/firestring/distinfo
+++ b/misc/firestring/distinfo
@@ -1 +1 @@
-MD5 (firestring-0.1.23.tar.gz) = f5d1b6fedbbd4137483efb3864d772b6
+MD5 (firestring-0.9.6.tar.gz) = 398c841107aed4226824bde5af2bc272
diff --git a/misc/firestring/files/patch-configure b/misc/firestring/files/patch-configure
deleted file mode 100644
index c5905d7a7b1a..000000000000
--- a/misc/firestring/files/patch-configure
+++ /dev/null
@@ -1,65 +0,0 @@
---- configure.orig Sun Sep 22 06:37:40 2002
-+++ configure Thu Oct 31 12:44:24 2002
-@@ -322,7 +322,7 @@
- $ECHO "INCLUDEDIR ?= \$(PREFIX)/include" >> Makefile
- $ECHO "MANDIR ?= \$(PREFIX)/man" >> Makefile
- $ECHO "CONFDIR ?= \$(PREFIX)/etc" >> Makefile
--$ECHO "INSTALL_GROUP ?= root" >> Makefile
-+$ECHO "INSTALL_GROUP ?= wheel" >> Makefile
- $ECHO "INSTALL_USER ?= root" >> Makefile
-
- $ECHO "LIBS := \$(LIBS) $INLIBS" >> Makefile
-@@ -517,7 +517,7 @@
- $ECHO "done"
- for BINARY in $BINARIES; do
- $ECHO -n " adding rule to install binary $BINARY..."
-- $ECHO " ./install.sh $BINARY \$(BINDIR) \$(INSTALL_USER) \$(INSTALL_GROUP) 0755" >> Makefile
-+ $ECHO " ./install.sh $BINARY \$(PREFIX)/bin \$(INSTALL_USER) \$(INSTALL_GROUP) 0755" >> Makefile
- $ECHO "done"
- done;
- $ECHO >> Makefile
-@@ -527,7 +527,7 @@
- $ECHO "done"
- for LIBRARY in $STATIC; do
- $ECHO -n " adding rule to install static library $LIBRARY..."
-- $ECHO " ./install.sh $LIBRARY \$(LIBDIR) \$(INSTALL_USER) \$(INSTALL_GROUP) 0755" >> Makefile
-+ $ECHO " ./install.sh $LIBRARY \$(PREFIX)/lib \$(INSTALL_USER) \$(INSTALL_GROUP) 0755" >> Makefile
- $ECHO "done"
- done;
- $ECHO >> Makefile
-@@ -537,7 +537,7 @@
- $ECHO "done"
- for LIBRARY in $SHARED; do
- $ECHO -n " adding rule to install shared library $LIBRARY..."
-- $ECHO " ./install.sh $LIBRARY \$(LIBDIR) \$(INSTALL_USER) \$(INSTALL_GROUP) 0755" >> Makefile
-+ $ECHO " ./install.sh $LIBRARY \$(PREFIX)/lib \$(INSTALL_USER) \$(INSTALL_GROUP) 0755" >> Makefile
- $ECHO "done"
- done;
- $ECHO >> Makefile
-@@ -556,7 +556,7 @@
- $ECHO "install-headers: $HEADERS" >> Makefile
- for HEADER in $HEADERS; do
- $ECHO -n " adding rule to install header $HEADER..."
-- $ECHO " ./install.sh $HEADER \$(INCLUDEDIR) \$(INSTALL_USER) \$(INSTALL_GROUP) 0644" >> Makefile
-+ $ECHO " ./install.sh $HEADER \$(PREFIX)/include \$(INSTALL_USER) \$(INSTALL_GROUP) 0644" >> Makefile
- $ECHO "done"
- done;
- $ECHO >> Makefile
-@@ -569,7 +569,7 @@
- if test "$LS" != ""; then
- $ECHO $LS >> Makefile
- for MANPAGE in $LS; do
-- $ECHO " ./install.sh $MANPAGE \$(MANDIR)/man$SECTION \$(INSTALL_USER) \$(INSTALL_GROUP) 0644" >> Makefile
-+ $ECHO " ./install.sh $MANPAGE \$(PREFIX)/man/man$SECTION \$(INSTALL_USER) \$(INSTALL_GROUP) 0644" >> Makefile
- done;
- $ECHO "done"
- else
-@@ -596,7 +596,7 @@
- done
- $ECHO >> Makefile
- for CONF in $CONFS; do
-- $ECHO " if test ! -f \$(CONFDIR)/$CONF; then ./install.sh conf/$CONF \$(CONFDIR) \$(INSTALL_USER) \$(INSTALL_GROUP) 0644; fi" >> Makefile
-+ $ECHO " if test ! -f \$(PREFIX)/etc/$CONF; then ./install.sh conf/$CONF \$(PREFIX)/etc \$(INSTALL_USER) \$(INSTALL_GROUP) 0644; fi" >> Makefile
- done
- $ECHO "done"
- else
diff --git a/misc/firestring/pkg-descr b/misc/firestring/pkg-descr
index af5cb9ebc86f..742bb09f83b9 100644
--- a/misc/firestring/pkg-descr
+++ b/misc/firestring/pkg-descr
@@ -1,24 +1,22 @@
From libfirestring(3):
"libfirestring is a string handling library that provides
-maximum length aware string handling functions to pro-
-grams. Several functions provide saner interfaces than
-the standard libc functions. libfirestring also provides
-functions that are in most libc's but not provided for by
-ANSI C, enabling programmers to write ANSI C-compliant
-code while using such safe functions (strcasecmp, strn-
-casecmp, snprintf).
+maximum length aware string handling functions to programs.
+Several functions provide saner interfaces than the standard
+libc functions. libfirestring also provides functions that
+are in most libc's but not provided for by ANSI C, enabling
+programmers to write ANSI C-compliant code while using such
+safe functions (strcasecmp, strncasecmp, snprintf).
libfirestring provides a set of functions for dealing with
-EStrings. EStrings are binary-safe objects that, when
-used with the firestring functions, are overflow safe,
-because they include allocated memory size information
-with them.
+EStrings. EStrings are binary-safe objects that, when used
+with the firestring functions, are overflow safe, because
+they include allocated memory size information with them.
libfirestring also includes functions for dealing with
reading configuration files in an easy to program fashion."
-WWW: http://ares.penguinhosting.net/~ian/
+WWW: http://firestuff.org/
- Dean
diff --git a/misc/firestring/pkg-plist b/misc/firestring/pkg-plist
index cf57d54da61f..1020f15d1048 100644
--- a/misc/firestring/pkg-plist
+++ b/misc/firestring/pkg-plist
@@ -1,5 +1,6 @@
@comment $FreeBSD$
-include/firestring.h
-lib/libfirestring.so
-lib/libfirestring.so.0
lib/libfirestring.a
+lib/libfirestring.so.0.9.6
+lib/libfirestring.so.0.9
+lib/libfirestring.so
+include/firestring.h