aboutsummaryrefslogtreecommitdiff
path: root/multimedia/bmpx/Makefile
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2007-08-19 11:42:40 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2007-08-19 11:42:40 +0000
commitb7adec8e553747ddbc9c1fde2e994a34db8389be (patch)
treeeec618df73eb4fd7e63a9a6bee9db8fff7672197 /multimedia/bmpx/Makefile
parent95bf0725f7e3b825358921de1f2b1be030f40172 (diff)
downloadports-b7adec8e553747ddbc9c1fde2e994a34db8389be.tar.gz
ports-b7adec8e553747ddbc9c1fde2e994a34db8389be.zip
- Remove neon, mp4v2 and fam dependencies, since they are not needed
anymore [1] - Disable hal support by default and andd WITH_HAL knob which turns it on. However bmpx with hal support might be not stable [1] - Mark BROKEN on 5.x [2] - Disable docs installation, they're pretty useless at this moment, but require additional dependencies Suggested by: David Le Brun [1] Repored by: pointyhat via kris [2]
Notes
Notes: svn path=/head/; revision=197915
Diffstat (limited to 'multimedia/bmpx/Makefile')
-rw-r--r--multimedia/bmpx/Makefile22
1 files changed, 15 insertions, 7 deletions
diff --git a/multimedia/bmpx/Makefile b/multimedia/bmpx/Makefile
index a7d0d4176ebb..a9d3d245f85c 100644
--- a/multimedia/bmpx/Makefile
+++ b/multimedia/bmpx/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bmpx
PORTVERSION= 0.40.1
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://files.beep-media-player.org/releases/0.40/
@@ -17,24 +18,20 @@ LIB_DEPENDS= tag.5:${PORTSDIR}/audio/taglib \
cairomm-1.0.1:${PORTSDIR}/graphics/cairomm \
musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz \
cdda_paranoia.0:${PORTSDIR}/audio/cdparanoia \
- neon.26:${PORTSDIR}/www/neon \
glademm-2.4.1:${PORTSDIR}/devel/libglademm24 \
gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
rsvg-2:${PORTSDIR}/graphics/librsvg2 \
boost_date_time.4:${PORTSDIR}/devel/boost \
dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- hal.1:${PORTSDIR}/sysutils/hal \
sexymm.2:${PORTSDIR}/x11-toolkits/libsexymm \
ofa.0:${PORTSDIR}/audio/libofa \
soup-2.2.8:${PORTSDIR}/devel/libsoup
CONFLICTS= bmpx-devel-[0-9]*
-USE_AUTOTOOLS= autoconf:261
+USE_AUTOTOOLS= automake:19 autoconf:261
USE_BISON= yes
USE_BZIP2= yes
-USE_FAM= yes
-USE_GCC= 3.4+
USE_GMAKE= yes
USE_GNOME= gtk20 libglade2 desktopfileutils
INSTALLS_ICONS= yes
@@ -53,6 +50,12 @@ CONFIGURE_ARGS+= --x-includes=${X11BASE}/include \
MAN1= beep-media-player-2.1
+.if !defined(WITH_HAL)
+CONFIGURE_ARGS+= --disable-hal
+.else
+LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
+.endif
+
.if defined(WITHOUT_STARTUP_NOTIFICATION)
CONFIGURE_ARGS+= --disable-sn
.else
@@ -79,11 +82,16 @@ PLIST_SUB+= SID="@comment "
.if defined(WITH_FAAD) || defined(WITH_MPEG4IP)
CONFIGURE_ARGS+= --enable-mp4v2
-LIB_DEPENDS+= mp4v2.0:${PORTSDIR}/multimedia/mpeg4ip-libmp4v2
USE_GSTREAMER+= faad
PLIST_SUB+= MPEG4IP=""
.else
PLIST_SUB+= MPEG4IP="@comment "
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000
+BROKEN= Does not compile on 5.x
+.endif
+
+.include <bsd.port.post.mk>