aboutsummaryrefslogtreecommitdiff
path: root/multimedia/clipgrab
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-12-13 00:26:31 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-12-13 00:26:31 +0000
commit7b4ad546cd755023d16c62465a99b96a39083cbe (patch)
tree49af124a88ded4d1785072375dc40c0e5daf399a /multimedia/clipgrab
parentb511496d46ba88b20c5baa1ca8e9902e9b5d7704 (diff)
downloadports-7b4ad546cd755023d16c62465a99b96a39083cbe.tar.gz
ports-7b4ad546cd755023d16c62465a99b96a39083cbe.zip
ClipGrab doesn\'t only allow you to download videos from sites like Youtube,
Dailymotion or Veoh but also gives you the ability to convert them at a single blow into "usabl" formats like WMV, MPEG or MP3. So you\'ll be able to wat h (or listen to) your favourite Youtube clips wherever you are. ClipGrab currently supports these sites: -YouTube -Dailymotion -Vimeo -MyVideo -MySpass WWW: http://clipgrab.de PR: ports/141203 Submitted by: Gvozdikov Veniamin <g.veniamin at googlemail.com>
Notes
Notes: svn path=/head/; revision=245674
Diffstat (limited to 'multimedia/clipgrab')
-rw-r--r--multimedia/clipgrab/Makefile40
-rw-r--r--multimedia/clipgrab/distinfo3
-rw-r--r--multimedia/clipgrab/pkg-descr13
3 files changed, 56 insertions, 0 deletions
diff --git a/multimedia/clipgrab/Makefile b/multimedia/clipgrab/Makefile
new file mode 100644
index 000000000000..4ebf1861a85c
--- /dev/null
+++ b/multimedia/clipgrab/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: clipgrab
+# Date created: 2009-12-06
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= clipgrab
+PORTVERSION= 3.0.4.1
+CATEGORIES= multimedia
+MASTER_SITES= http://clipgrab.de/download/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= Program to download videos from YouTube and etc
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui xml qmake_build uic_build moc_build \
+ rcc_build network
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/${PORTNAME}/icon.png \
+ share/${PORTNAME}/logo.png \
+ share/${PORTNAME}/splash.png
+PLIST_DIRS= share/${PORTNAME}
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,img/,share/${PORTNAME}/,g' \
+ ${WRKSRC}/*.cpp
+
+do-configure:
+ cd ${WRKSRC} && ${QMAKE}
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/*.png ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/multimedia/clipgrab/distinfo b/multimedia/clipgrab/distinfo
new file mode 100644
index 000000000000..5169a8febda9
--- /dev/null
+++ b/multimedia/clipgrab/distinfo
@@ -0,0 +1,3 @@
+MD5 (clipgrab-3.0.4.1.tar.bz2) = 1e07d9a2b0fb2ae528b2637e495d9455
+SHA256 (clipgrab-3.0.4.1.tar.bz2) = 677ad67aa634597201ff3e82ded868ba344c71be46fcd9d81dd2a2b9902360f6
+SIZE (clipgrab-3.0.4.1.tar.bz2) = 277322
diff --git a/multimedia/clipgrab/pkg-descr b/multimedia/clipgrab/pkg-descr
new file mode 100644
index 000000000000..1759fe8bc368
--- /dev/null
+++ b/multimedia/clipgrab/pkg-descr
@@ -0,0 +1,13 @@
+ClipGrab doesn\'t only allow you to download videos from sites like Youtube,
+Dailymotion or Veoh but also gives you the ability to convert them at a single
+blow into "usabl" formats like WMV, MPEG or MP3. So you\'ll be able to wat
+h (or listen to) your favourite Youtube clips wherever you are.
+ClipGrab currently supports these sites:
+
+-YouTube
+-Dailymotion
+-Vimeo
+-MyVideo
+-MySpass
+
+WWW: http://clipgrab.de