aboutsummaryrefslogtreecommitdiff
path: root/multimedia/clive
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-06-28 13:42:33 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-06-28 13:42:33 +0000
commita9f7db349cf11fc4a853ee8a32cafdada71d5e61 (patch)
tree97e033f2b3febefab2a4e3e25bd2bba19dc46ebb /multimedia/clive
parentf52d6a47b5d0f989c160aa7f5b983687a4197073 (diff)
downloadports-a9f7db349cf11fc4a853ee8a32cafdada71d5e61.tar.gz
ports-a9f7db349cf11fc4a853ee8a32cafdada71d5e61.zip
- Update to 2.2.1
- Fix COMMENT and pkg-descr to be more accurate PR: ports/136009 Submitted by: Toni Gundogdu <legatvs@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=236720
Diffstat (limited to 'multimedia/clive')
-rw-r--r--multimedia/clive/Makefile41
-rw-r--r--multimedia/clive/distinfo6
-rw-r--r--multimedia/clive/files/patch-Makefile34
-rw-r--r--multimedia/clive/pkg-descr25
-rw-r--r--multimedia/clive/pkg-plist27
5 files changed, 46 insertions, 87 deletions
diff --git a/multimedia/clive/Makefile b/multimedia/clive/Makefile
index c5912ab36707..03c8ac0ef22e 100644
--- a/multimedia/clive/Makefile
+++ b/multimedia/clive/Makefile
@@ -6,55 +6,38 @@
#
PORTNAME= clive
-PORTVERSION= 2.1.14
+PORTVERSION= 2.2.1
CATEGORIES= multimedia
MASTER_SITES= GOOGLE_CODE
MAINTAINER= legatvs@gmail.com
-COMMENT= Video extraction utility for YouTube, GoogleVideo, and others
+COMMENT= Command line video extraction tool for YouTube and others
-RUN_DEPENDS= p5-Config-Tiny>=2.12:${PORTSDIR}/devel/p5-Config-Tiny \
- p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA \
+RUN_DEPENDS= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA \
p5-HTML-Parser>=3.59:${PORTSDIR}/www/p5-HTML-Parser \
- p5-WWW-Curl>=4.05:${PORTSDIR}/www/p5-WWW-Curl
+ p5-WWW-Curl>=4.05:${PORTSDIR}/www/p5-WWW-Curl \
+ p5-Class-Singleton>=1.4:${PORTSDIR}/devel/p5-Class-Singleton \
+ p5-Getopt-ArgvFile>=1.11:${PORTSDIR}/devel/p5-Getopt-ArgvFile
# deskutils/ljclive, multimedia/clive1 (same executable/manpage/distfile name)
CONFLICTS= clive-[0-1]* ljclive-[0-9]*
-OPTIONS= PASTE "Enable pasting from X clipboard" off \
- CACHE "Enable cache" off \
- PAGER "Enable pager for viewing cache entries" off \
- EXPECT "Enable clivepass interface" off \
- MANPAGE "Install manual page" on
+OPTIONS= CACHE "With video page cache" off \
+ SIGWINCH "With resizable progressbar" on
-PLIST_FILES= bin/clive
+MAN1= clive.1
-NO_BUILD= yes
+PERL_CONFIGURE= yes
USE_BZIP2= yes
-USE_GMAKE= yes
-USE_PERL5_RUN= 5.8.2+
.include <bsd.port.pre.mk>
-.if defined(WITH_PASTE)
-RUN_DEPENDS+= p5-Clipboard>=0.09:${PORTSDIR}/x11/p5-Clipboard
-.endif
-
.if defined(WITH_CACHE)
RUN_DEPENDS+= p5-BerkeleyDB>=0.36:${PORTSDIR}/databases/p5-BerkeleyDB
.endif
-.if defined(WITH_PAGER)
-RUN_DEPENDS+= p5-IO-Pager>=0.06:${PORTSDIR}/devel/p5-IO-Pager
-.endif
-
-.if defined(WITH_EXPECT)
-RUN_DEPENDS+= p5-Expect>=1.21:${PORTSDIR}/lang/p5-Expect
-.endif
-
-.if defined(WITH_MANPAGE) && !defined(NO_INSTALL_MANPAGES)
-MAKE_ENV= WITH_MAN=yes
-MAN1= clive.1
+.if defined(WITH_SIGWINCH)
+RUN_DEPENDS+= p5-Term-ReadKey>=2.30:${PORTSDIR}/devel/p5-Term-ReadKey
.endif
.include <bsd.port.post.mk>
diff --git a/multimedia/clive/distinfo b/multimedia/clive/distinfo
index 868d14faa7e0..8de65d8aef04 100644
--- a/multimedia/clive/distinfo
+++ b/multimedia/clive/distinfo
@@ -1,3 +1,3 @@
-MD5 (clive-2.1.14.tar.bz2) = ce55bb3b7cfeb679cb457e8a82d78bf3
-SHA256 (clive-2.1.14.tar.bz2) = 42c415c8c7072c09f4982e94f9b78505dd5b4d01b3b2129b7aefd977159fa14b
-SIZE (clive-2.1.14.tar.bz2) = 32736
+MD5 (clive-2.2.1.tar.bz2) = cee2823a40c7f46cf7436f82be6d06c8
+SHA256 (clive-2.2.1.tar.bz2) = 903ae1629f67fddb5ae698e11b4e37ec7837bbc142f10eef922b5246f1b27f1d
+SIZE (clive-2.2.1.tar.bz2) = 39479
diff --git a/multimedia/clive/files/patch-Makefile b/multimedia/clive/files/patch-Makefile
deleted file mode 100644
index 69428d19678a..000000000000
--- a/multimedia/clive/files/patch-Makefile
+++ /dev/null
@@ -1,34 +0,0 @@
---- Makefile.orig 2009-02-19 15:27:58.000000000 +0200
-+++ Makefile 2009-02-19 15:31:01.000000000 +0200
-@@ -1,26 +1,21 @@
- # GNU Makefile
-
--SHELL = /bin/sh
--
--prefix = $(HOME)
-+prefix = $(PREFIX)
- bindir = $(prefix)/bin
- datarootdir = $(prefix)/share
- datadir = $(datarootdir)
--mandir = $(datarootdir)/man
-+mandir = $(MANPREFIX)/man
- man1dir = $(mandir)/man1
-
--INSTALL = install -c
--INSTALL_D = install -d
--INSTALL_M = install -c -m 444
-+INSTALL = $(BSD_INSTALL_SCRIPT)
-+INSTALL_D = mkdir -p
-+INSTALL_M = $(BSD_INSTALL_MAN)
- RM = rm -f
- PERL = perl
- POD2MAN = pod2man
- AWK = awk
- TR = tr
-
--WITH_MAN = yes
--WITH_CHECK = yes
--
- ifndef V
- QUIET_POD2MAN = @echo POD2MAN clive.1;
- endif
diff --git a/multimedia/clive/pkg-descr b/multimedia/clive/pkg-descr
index bcc703cd61b1..938a478fc14e 100644
--- a/multimedia/clive/pkg-descr
+++ b/multimedia/clive/pkg-descr
@@ -1,22 +1,5 @@
-clive is a portable Perl command line tool for extracting videos from
-Youtube, Google Video, Break, LiveLeak, LastFm, EvisorTV, Sevenload,
-Sevenload and Dailymotion websites. clive may be used in a non-interactive
-fashion -- this allows the user to start an extraction and disconnect from
-the system, letting clive finish the work.
+clive is a command line utility for extracting videos from Youtube and other
+video-sharing websites. It was written to bypass the Adobe Flash requirement
+to view the hosted videos.
-Main features:
-
- - Proxy support; option and http_proxy environment setting
- - Youtube log-in support with flagged-content override
- - High/low-quality support where applicable (e.g. Youtube)
- - Chaining with a 3rd party player software for playing
- - Chaining with ffmpeg for subsequent re-encoding
- - URL caching; re-fetch video page only when necessary
- - Gzip compressed video page data transfers
- - Integration with X clipboard
- - Continue partially downloaded files
- - Recall last URL batch
- - Supports UNIX pipes
- - URL batch support
-
-WWW: http://clive.sourceforge.net/
+WWW: http://code.google.com/p/clive/
diff --git a/multimedia/clive/pkg-plist b/multimedia/clive/pkg-plist
new file mode 100644
index 000000000000..5a4f7de32c1e
--- /dev/null
+++ b/multimedia/clive/pkg-plist
@@ -0,0 +1,27 @@
+bin/clive
+%%SITE_PERL%%/clive/Host/Vimeo.pm
+%%SITE_PERL%%/clive/Host/Redtube.pm
+%%SITE_PERL%%/clive/Host/Evisor.pm
+%%SITE_PERL%%/clive/Host/Liveleak.pm
+%%SITE_PERL%%/clive/Host/Dailymotion.pm
+%%SITE_PERL%%/clive/Host/Sevenload.pm
+%%SITE_PERL%%/clive/Host/Cctv.pm
+%%SITE_PERL%%/clive/Host/Youtube.pm
+%%SITE_PERL%%/clive/Host/Break.pm
+%%SITE_PERL%%/clive/Host/Google.pm
+%%SITE_PERL%%/clive/Progress/Bar.pm
+%%SITE_PERL%%/clive/Exec.pm
+%%SITE_PERL%%/clive/Util.pm
+%%SITE_PERL%%/clive/App.pm
+%%SITE_PERL%%/clive/Cache.pm
+%%SITE_PERL%%/clive/HostFactory.pm
+%%SITE_PERL%%/clive/Video.pm
+%%SITE_PERL%%/clive/Config.pm
+%%SITE_PERL%%/clive/Curl.pm
+%%SITE_PERL%%/clive/Log.pm
+%%SITE_PERL%%/clive/Error.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/clive/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/clive
+@dirrmtry %%SITE_PERL%%/clive/Host
+@dirrmtry %%SITE_PERL%%/clive/Progress
+@dirrmtry %%SITE_PERL%%/clive