aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer-plugins-good
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2006-04-29 23:03:03 +0000
committerMichael Johnson <ahze@FreeBSD.org>2006-04-29 23:03:03 +0000
commitd8e1e16e64701b6d51c9402ad779fd5560b8ce51 (patch)
tree266f139932061c245ade2aa3ef5c087c802dc5e3 /multimedia/gstreamer-plugins-good
parent96ae3a6609c06c520d2aad7f2f89fb23d7b54e8e (diff)
downloadports-d8e1e16e64701b6d51c9402ad779fd5560b8ce51.tar.gz
ports-d8e1e16e64701b6d51c9402ad779fd5560b8ce51.zip
- Update gstreamer to 0.10
- Move all old gstreamer 0.8 ports to gstreamer*80 [1] - Chase all ports with new gstreamer or gstreaemer moves Repocopied by: marcus [1]
Notes
Notes: svn path=/head/; revision=160858
Diffstat (limited to 'multimedia/gstreamer-plugins-good')
-rw-r--r--multimedia/gstreamer-plugins-good/Makefile43
-rw-r--r--multimedia/gstreamer-plugins-good/files/patch-sys_oss_gstosshelper.c20
-rw-r--r--multimedia/gstreamer-plugins-good/pkg-plist84
3 files changed, 147 insertions, 0 deletions
diff --git a/multimedia/gstreamer-plugins-good/Makefile b/multimedia/gstreamer-plugins-good/Makefile
new file mode 100644
index 000000000000..9cf4d9ab75a3
--- /dev/null
+++ b/multimedia/gstreamer-plugins-good/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: gstreamer-plugins-good
+# Date created: 20 Jan 2006
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/multimedia/gstreamer-plugins-good/Makefile,v 1.5 2006/04/02 07:33:41 marcus Exp $
+#
+
+PORTREVISION= 3
+CATEGORIES= multimedia
+
+COMMENT= Good gstreamer-plugins
+
+GST_PLUGIN= good
+GST_PLUGIN_SUFFIX= -good
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+
+BUILD_DEPENDS+= gstreamer-plugins>=${GST_VERSION}${GST_MINOR_VERSION}:${PORTSDIR}/multimedia/gstreamer-plugins
+RUN_DEPENDS+= gstreamer-plugins>=${GST_VERSION}${GST_MINOR_VERSION}:${PORTSDIR}/multimedia/gstreamer-plugins
+
+EXTRACT_ONLY= ${GOOD_DISTFILE}
+WRKSRC= ${WRKDIR}/${GOOD_DISTNAME}
+
+GOOD_GST_DIRS= gst sys
+PLIST_SUB= VERSION="${GST_VERSION}"
+NO_GSTREAMER_COMMON= yes
+PLIST= ${.CURDIR}/pkg-plist
+FILESDIR=${.CURDIR}/files
+PATCHDIR=${.CURDIR}/files
+
+do-build:
+.for dir in ${GOOD_GST_DIRS}
+ @(cd ${BUILD_WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
+.endfor
+
+do-install:
+.for dir in ${GOOD_GST_DIRS}
+ @(cd ${INSTALL_WRKSRC}/${dir} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
+
+.endfor
+
+.include "${MASTERDIR}/Makefile"
diff --git a/multimedia/gstreamer-plugins-good/files/patch-sys_oss_gstosshelper.c b/multimedia/gstreamer-plugins-good/files/patch-sys_oss_gstosshelper.c
new file mode 100644
index 000000000000..34fdd31191a2
--- /dev/null
+++ b/multimedia/gstreamer-plugins-good/files/patch-sys_oss_gstosshelper.c
@@ -0,0 +1,20 @@
+--- sys/oss/gstosshelper.c.orig Sun Apr 2 03:23:53 2006
++++ sys/oss/gstosshelper.c Sun Apr 2 03:25:44 2006
+@@ -343,13 +344,17 @@ gst_oss_helper_rate_check_rate (GstOssPr
+ int format;
+ int n_channels;
+ int ret;
++ int rst;
+
+ rate = irate;
+ format = probe->format;
+ n_channels = probe->n_channels;
++ rst = 4000; /* XXX Lowest supported rate for FreeBSD. */
+
+ GST_LOG ("checking format %d, channels %d, rate %d",
+ format, n_channels, rate);
++ /* Reset rate to lowest supported rate. */
++ ioctl (probe->fd, SNDCTL_DSP_SPEED, &rst);
+ ret = ioctl (probe->fd, SNDCTL_DSP_SETFMT, &format);
+ if (ret < 0)
+ return -1;
diff --git a/multimedia/gstreamer-plugins-good/pkg-plist b/multimedia/gstreamer-plugins-good/pkg-plist
new file mode 100644
index 000000000000..6565484ea7ca
--- /dev/null
+++ b/multimedia/gstreamer-plugins-good/pkg-plist
@@ -0,0 +1,84 @@
+lib/gstreamer-%%VERSION%%/libgstalaw.a
+lib/gstreamer-%%VERSION%%/libgstalaw.la
+lib/gstreamer-%%VERSION%%/libgstalaw.so
+lib/gstreamer-%%VERSION%%/libgstalpha.a
+lib/gstreamer-%%VERSION%%/libgstalpha.la
+lib/gstreamer-%%VERSION%%/libgstalpha.so
+lib/gstreamer-%%VERSION%%/libgstalphacolor.a
+lib/gstreamer-%%VERSION%%/libgstalphacolor.la
+lib/gstreamer-%%VERSION%%/libgstalphacolor.so
+lib/gstreamer-%%VERSION%%/libgstapetag.a
+lib/gstreamer-%%VERSION%%/libgstapetag.la
+lib/gstreamer-%%VERSION%%/libgstapetag.so
+lib/gstreamer-%%VERSION%%/libgstauparse.a
+lib/gstreamer-%%VERSION%%/libgstauparse.la
+lib/gstreamer-%%VERSION%%/libgstauparse.so
+lib/gstreamer-%%VERSION%%/libgstautodetect.a
+lib/gstreamer-%%VERSION%%/libgstautodetect.la
+lib/gstreamer-%%VERSION%%/libgstautodetect.so
+lib/gstreamer-%%VERSION%%/libgstavi.a
+lib/gstreamer-%%VERSION%%/libgstavi.la
+lib/gstreamer-%%VERSION%%/libgstavi.so
+lib/gstreamer-%%VERSION%%/libgstcutter.a
+lib/gstreamer-%%VERSION%%/libgstcutter.la
+lib/gstreamer-%%VERSION%%/libgstcutter.so
+lib/gstreamer-%%VERSION%%/libgstdebug.a
+lib/gstreamer-%%VERSION%%/libgstdebug.la
+lib/gstreamer-%%VERSION%%/libgstdebug.so
+lib/gstreamer-%%VERSION%%/libgsteffectv.a
+lib/gstreamer-%%VERSION%%/libgsteffectv.la
+lib/gstreamer-%%VERSION%%/libgsteffectv.so
+lib/gstreamer-%%VERSION%%/libgstflxdec.a
+lib/gstreamer-%%VERSION%%/libgstflxdec.la
+lib/gstreamer-%%VERSION%%/libgstflxdec.so
+lib/gstreamer-%%VERSION%%/libgstgoom.a
+lib/gstreamer-%%VERSION%%/libgstgoom.la
+lib/gstreamer-%%VERSION%%/libgstgoom.so
+lib/gstreamer-%%VERSION%%/libgstid3demux.a
+lib/gstreamer-%%VERSION%%/libgstid3demux.la
+lib/gstreamer-%%VERSION%%/libgstid3demux.so
+lib/gstreamer-%%VERSION%%/libgstlevel.a
+lib/gstreamer-%%VERSION%%/libgstlevel.la
+lib/gstreamer-%%VERSION%%/libgstlevel.so
+lib/gstreamer-%%VERSION%%/libgstmatroska.a
+lib/gstreamer-%%VERSION%%/libgstmatroska.la
+lib/gstreamer-%%VERSION%%/libgstmatroska.so
+lib/gstreamer-%%VERSION%%/libgstmulaw.a
+lib/gstreamer-%%VERSION%%/libgstmulaw.la
+lib/gstreamer-%%VERSION%%/libgstmulaw.so
+lib/gstreamer-%%VERSION%%/libgstmultipart.a
+lib/gstreamer-%%VERSION%%/libgstmultipart.la
+lib/gstreamer-%%VERSION%%/libgstmultipart.so
+lib/gstreamer-%%VERSION%%/libgstnavigationtest.a
+lib/gstreamer-%%VERSION%%/libgstnavigationtest.la
+lib/gstreamer-%%VERSION%%/libgstnavigationtest.so
+lib/gstreamer-%%VERSION%%/libgstossaudio.a
+lib/gstreamer-%%VERSION%%/libgstossaudio.la
+lib/gstreamer-%%VERSION%%/libgstossaudio.so
+lib/gstreamer-%%VERSION%%/libgstrtp.a
+lib/gstreamer-%%VERSION%%/libgstrtp.la
+lib/gstreamer-%%VERSION%%/libgstrtp.so
+lib/gstreamer-%%VERSION%%/libgstrtsp.a
+lib/gstreamer-%%VERSION%%/libgstrtsp.la
+lib/gstreamer-%%VERSION%%/libgstrtsp.so
+lib/gstreamer-%%VERSION%%/libgstsmpte.a
+lib/gstreamer-%%VERSION%%/libgstsmpte.la
+lib/gstreamer-%%VERSION%%/libgstsmpte.so
+lib/gstreamer-%%VERSION%%/libgstudp.a
+lib/gstreamer-%%VERSION%%/libgstudp.la
+lib/gstreamer-%%VERSION%%/libgstudp.so
+lib/gstreamer-%%VERSION%%/libgstvideobox.a
+lib/gstreamer-%%VERSION%%/libgstvideobox.la
+lib/gstreamer-%%VERSION%%/libgstvideobox.so
+lib/gstreamer-%%VERSION%%/libgstvideoflip.a
+lib/gstreamer-%%VERSION%%/libgstvideoflip.la
+lib/gstreamer-%%VERSION%%/libgstvideoflip.so
+lib/gstreamer-%%VERSION%%/libgstvideomixer.a
+lib/gstreamer-%%VERSION%%/libgstvideomixer.la
+lib/gstreamer-%%VERSION%%/libgstvideomixer.so
+lib/gstreamer-%%VERSION%%/libgstwavenc.a
+lib/gstreamer-%%VERSION%%/libgstwavenc.la
+lib/gstreamer-%%VERSION%%/libgstwavenc.so
+lib/gstreamer-%%VERSION%%/libgstwavparse.a
+lib/gstreamer-%%VERSION%%/libgstwavparse.la
+lib/gstreamer-%%VERSION%%/libgstwavparse.so