aboutsummaryrefslogtreecommitdiff
path: root/multimedia/handbrake-gtk2
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2004-11-25 04:01:29 +0000
committerMichael Johnson <ahze@FreeBSD.org>2004-11-25 04:01:29 +0000
commit55298e769724fcc5bbed18d26f33f0814c6b9986 (patch)
tree2b775e4ac0f8ed2c067a406e68d59eae8edf7b5b /multimedia/handbrake-gtk2
parent82dc3a5621252366bc9f1510ca21ac312fb9c649 (diff)
downloadports-55298e769724fcc5bbed18d26f33f0814c6b9986.tar.gz
ports-55298e769724fcc5bbed18d26f33f0814c6b9986.zip
Add USE_GETOPT_LONG to fix 4.x build
Remove faad from ffmpeg since no dvd's have mp4 audio. PR: ports/74353 Submitted by: maintainer Approved by: adamw (implicit)
Notes
Notes: svn path=/head/; revision=122382
Diffstat (limited to 'multimedia/handbrake-gtk2')
-rw-r--r--multimedia/handbrake-gtk2/Makefile4
-rw-r--r--multimedia/handbrake-gtk2/files/patch-Jamfile4
2 files changed, 5 insertions, 3 deletions
diff --git a/multimedia/handbrake-gtk2/Makefile b/multimedia/handbrake-gtk2/Makefile
index 278747613a4d..8012a975a15c 100644
--- a/multimedia/handbrake-gtk2/Makefile
+++ b/multimedia/handbrake-gtk2/Makefile
@@ -55,13 +55,14 @@ FFMPEG_CONFIGURE_ARGS+= --enable-gpl --disable-ffserver \
--enable-pthreads \
--enable-faac \
--enable-mp3lame \
- --enable-faad \
--enable-a52 \
--enable-xvid
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
+USE_GETOPT_LONG= yes
+MAKE_ENV= EXTRA_LIBS="-lcipher"
WITH_DVD_DEVICE?= acd0c
.else
WITH_DVD_DEVICE?= acd0
@@ -96,6 +97,7 @@ post-patch:
${FFMPEG_SRC_DIR}/libavcodec/xvidff.c
.endif
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' \
+ -e 's|-Wall||' \
${FFMPEG_SRC_DIR}/configure
cd ${FFMPEG_SRC_DIR} && \
${PATCH} -p0 < ${PATCHDIR}/ffmpeg-patch
diff --git a/multimedia/handbrake-gtk2/files/patch-Jamfile b/multimedia/handbrake-gtk2/files/patch-Jamfile
index af6a54cdbd2b..beb1759b08a5 100644
--- a/multimedia/handbrake-gtk2/files/patch-Jamfile
+++ b/multimedia/handbrake-gtk2/files/patch-Jamfile
@@ -10,9 +10,9 @@
+ SystemLibraries $(TEST_BIN) : %%LIBAVCODEC%%/libavcodec.a
+ -L%%PREFIX%%/lib %%PTHREAD_LIBS%% -la52
+ -ldvdcss -ldvdread -lfaac -lmp3lame -lmp4v2 -lmpeg2 -logg
-+ -lsamplerate -lvorbis -lvorbisenc -lxvidcore ;
++ -lsamplerate -lvorbis -lvorbisenc -lxvidcore $(EXTRA_LIBS) ;
+ SystemLibraries $(GTK2_BIN) : %%LIBAVCODEC%%/libavcodec.a
-+ -L%%PREFIX%%/lib %%PTHREAD_LIBS%% `pkg-config gtk+-2.0 --libs`
++ -L%%PREFIX%%/lib %%PTHREAD_LIBS%% $(EXTRA_LIBS) `pkg-config gtk+-2.0 --libs`
+ -la52 -ldvdcss -ldvdread -lfaac -lmp3lame -lmp4v2
+ -lmpeg2 -logg -lsamplerate -lvorbis -lvorbisenc -lxvidcore ;
+ ObjectCcFlags $(GTK2_SRC) : `pkg-config gtk+-2.0 --cflags` ;