aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libaacs/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-07-18 11:02:58 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-07-18 11:02:58 +0000
commit14e2af0516e5f48d06d25c38a2f7fdeb49092165 (patch)
tree6380f453c1d4dd663e11e967617af9f779dac0fa /multimedia/libaacs/Makefile
parent6a4ff9b6b8f09c1fd5b02c88bba690427b3104b7 (diff)
downloadports-14e2af0516e5f48d06d25c38a2f7fdeb49092165.tar.gz
ports-14e2af0516e5f48d06d25c38a2f7fdeb49092165.zip
audio/rhythmbox: drop :keepla
multimedia/banshee: add USES=libtool and INSTALL_TARGET=install-strip multimedia/libmtp: add USES=libtool and INSTALL_TARGET=install-strip multimedia/libaacs: - USES=libtool pathfix - Add INSTALL_TARGET=install-strip - Avoid USE_AUTOTOOLS - Remove plist target, superseded by makeplist multimedia/libbluray: - USES=libtool pathfix - Add INSTALL_TARGET=install-strip - Avoid USE_AUTOTOOLS - Remove plist target, superseded by makeplist - Use OPTIONS_SUB - Replace patch with post-patch command Bump dependent ports
Notes
Notes: svn path=/head/; revision=362200
Diffstat (limited to 'multimedia/libaacs/Makefile')
-rw-r--r--multimedia/libaacs/Makefile26
1 files changed, 6 insertions, 20 deletions
diff --git a/multimedia/libaacs/Makefile b/multimedia/libaacs/Makefile
index a702263a506d..bd52a5b7990c 100644
--- a/multimedia/libaacs/Makefile
+++ b/multimedia/libaacs/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libaacs
PORTVERSION= 0.7.0
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= ftp://ftp.videolan.org/pub/videolan/${PORTNAME}/${PORTVERSION}/ \
http://blu.opsec.eu/
@@ -16,26 +17,11 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt \
libgpg-error.so:${PORTSDIR}/security/libgpg-error
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-debug
+CONFIGURE_ENV= LEX="${LOCALBASE}/bin/flex"
+INSTALL_TARGET= install-strip
+USES= bison gettext iconv libtool pathfix tar:bzip2
USE_LDCONFIG= yes
-USE_AUTOTOOLS= autoconf aclocal automake libtool
-USES= bison gettext iconv tar:bzip2
-
-HAS_CONFIGURE= yes
-CONFIGURE_ENV+= LEX="${LOCALBASE}/bin/flex"
-CONFIGURE_ARGS+= --prefix="${PREFIX}" \
- --disable-debug
-# Evil hack, necessitating another evil hack in the plist target.
-MAKE_ARGS+= pkgconfigdir="${PREFIX}/libdata/pkgconfig" \
- CFLAGS=${CFLAGS:Q}
-
-run-autotools:
- @cd ${WRKSRC} && ${SH} bootstrap
-
-plist: stage
- @${ECHO} "===> Rebuilding PLIST."
- @${MTREE_CMD} -cp "${STAGEDIR}${PREFIX}/" > "${WRKDIR}/plist.mtree"
- @${MTREE_CMD} -Sf "${WRKDIR}/plist.mtree" -f "${MTREE_FILE}" \
- | ${SED} -ne '/ dir /{s/ .*//;s/^/@dirrm /;H;};t dirs' \
- -e 's/ .*//p;:dirs' -e '$${g;s/^\n//p;}' > ${PLIST}
.include <bsd.port.mk>