aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libdv
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2006-12-15 01:28:36 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2006-12-15 01:28:36 +0000
commit86030e115bc22cdc19a6d46b42dbe63c417f3dc8 (patch)
treed2ef46fad3f664b0a040e1c4d0f197fd9515b9c4 /multimedia/libdv
parent24689a65f8ba961bb0f0db161468ebe483352c6a (diff)
downloadports-86030e115bc22cdc19a6d46b42dbe63c417f3dc8.tar.gz
ports-86030e115bc22cdc19a6d46b42dbe63c417f3dc8.zip
o Fix: the reorder_block() zigzag behaves incorrectly in the
(!ARCH_X86 && !ARCH_X86_64) case. The current code fails to take into account the effects of _dv_prepare_reorder_tables(), which changes the indexes contained in the reorder_88[] and reorder_248[] arrays. o Bump PORTREVISION PR: 94188 Submitted by: Brent Casavant <bcasavan@sgi.com>
Notes
Notes: svn path=/head/; revision=179807
Diffstat (limited to 'multimedia/libdv')
-rw-r--r--multimedia/libdv/Makefile2
-rw-r--r--multimedia/libdv/files/patch-libdv__encode.c12
2 files changed, 13 insertions, 1 deletions
diff --git a/multimedia/libdv/Makefile b/multimedia/libdv/Makefile
index 991f411dbfea..8d0e82611d45 100644
--- a/multimedia/libdv/Makefile
+++ b/multimedia/libdv/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libdv
PORTVERSION= 0.104
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/multimedia/libdv/files/patch-libdv__encode.c b/multimedia/libdv/files/patch-libdv__encode.c
new file mode 100644
index 000000000000..e3c47375d776
--- /dev/null
+++ b/multimedia/libdv/files/patch-libdv__encode.c
@@ -0,0 +1,12 @@
+--- libdv/encode.c.orig Thu Dec 14 23:24:41 2006
++++ libdv/encode.c Thu Dec 14 23:25:20 2006
+@@ -513,8 +513,7 @@
+ emms();
+ #else
+ for (i = 0; i < 64; i++) {
+- // *(unsigned short*) ((char*) zigzag + reorder[i])=bl->coeffs[i];
+- zigzag[reorder[i] - 1] = bl->coeffs[i];
++ *(unsigned short*) ((char*) zigzag + reorder[i])=bl->coeffs[i];
+ }
+ memcpy(bl->coeffs, zigzag, 64 * sizeof(dv_coeff_t));
+ #endif