aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libxine/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-10-26 16:58:00 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-10-26 16:58:00 +0000
commit04e3b1a90f6d62c4486eb569443469db1801c8f2 (patch)
treec4f74a79a3ece1041c7d4b451259cddf66b3199f /multimedia/libxine/Makefile
parentb3f9ad85233bb1b7b2afe2ef7c388b06e9acd021 (diff)
downloadports-04e3b1a90f6d62c4486eb569443469db1801c8f2.tar.gz
ports-04e3b1a90f6d62c4486eb569443469db1801c8f2.zip
o update to 0.9.2
o use ports libraries instead of internal versions: liba52 and ffmpeg o support for both vorbis and ogg o WITH_CSS: plugin for css processing o add WWW tag to DESCR Reviewed by: MAINTAINER, freebsd-multimedia
Notes
Notes: svn path=/head/; revision=49225
Diffstat (limited to 'multimedia/libxine/Makefile')
-rw-r--r--multimedia/libxine/Makefile54
1 files changed, 49 insertions, 5 deletions
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index fcbd42dbbed1..4b17581f48e0 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -6,20 +6,22 @@
#
PORTNAME= xine
-PORTVERSION= 0.9.1
-PORTREVISION= 1
+PORTVERSION= 0.9.2
CATEGORIES= graphics
MASTER_SITES= http://xine.sourceforge.net/files/ \
${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMEPREFIX= lib
-DISTNAME= ${PORTNAME}-lib-${PORTVERSION}
+DISTFILES= ${PORTNAME}-lib-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= nobutaka@nobutaka.com
-LIB_DEPENDS= aa.1:${PORTSDIR}/graphics/aalib
+BUILD_DEPENDS= ${LOCALBASE}/lib/libavcodec.a:${PORTSDIR}/graphics/ffmpeg
+LIB_DEPENDS= a52.0:${PORTSDIR}/audio/liba52 \
+ aa.1:${PORTSDIR}/graphics/aalib
-GNU_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-lib-${PORTVERSION}
+USE_AUTOMAKE= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_IMLIB= yes
@@ -29,6 +31,7 @@ INSTALLS_SHLIB= yes
MAN1= xine-config.1
MAN3= ao_driver_t.3 ao_functions_t.3 autoplay_group.3 \
+ audio_cap.3 audio_group.3 audio_prop.3 \
browse_group.3 build_info.3 cfg_data_t.3 config_group.3 \
config_values_s.3 config_values_t.3 demux_strategy.3 \
event_group.3 loadplugins_group.3 mrl_t.3 mrl_types.3 \
@@ -52,4 +55,45 @@ PLIST_SUB+= HAVE_ARTS=""
PLIST_SUB+= HAVE_ARTS="@comment "
.endif
+.if exists(${LOCALBASE}/include/vorbis/codec.h)
+LIB_DEPENDS+= vorbis.0:${PORTSDIR}/audio/libvorbis
+
+PLIST_SUB+= HAVE_VORBIS=""
+.else
+PLIST_SUB+= HAVE_VORBIS="@comment "
+.endif
+
+.if exists(${LOCALBASE}/include/ogg/ogg.h)
+LIB_DEPENDS+= ogg.2:${PORTSDIR}/audio/libogg
+
+PLIST_SUB+= HAVE_OGG=""
+.else
+PLIST_SUB+= HAVE_OGG="@comment "
+.endif
+
+.if defined(WITH_CSS)
+# http://members.home.nl/mphm.janssen/linuxvideo/linuxvideo.html
+MASTER_SITES+= http://members.home.nl/mphm.janssen/files/
+DISTFILES+= ${PLUGIN_CSS}${EXTRACT_SUFX}
+
+LIB_DEPENDS+= dvdcss.0:${PORTSDIR}/graphics/libdvdcss
+
+PLUGIN_CSS= dvd-plugin-${PLUGIN_CSS_VERSION}
+PLUGIN_CSS_VERSION= 0.4
+.endif
+
+pre-everything::
+.if !defined(WITH_CSS)
+ @${ECHO_MSG} "====>"
+ @${ECHO_MSG} "====> To enable css support, define WITH_CSS"
+ @${ECHO_MSG} "====>"
+.endif
+
+post-patch:
+.if defined(WITH_CSS)
+ @${PERL} -pi.orig -e 's/(xineplug_inp_dvd_la_LDFLAGS = -avoid-version -module)/\1 -ldvdcss/' \
+ ${WRKSRC}/src/input/Makefile.am
+ @${CP} -f ${WRKDIR}/${PLUGIN_CSS}/*.[ch] ${WRKSRC}/src/input
+.endif
+
.include <bsd.port.post.mk>