aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libxine/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-09-20 07:50:12 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-09-20 07:50:12 +0000
commitf396f64b0d5cbb493baf8c1598c0309bbd85d0a1 (patch)
tree559e02f13889633dd1f82c0030f80bddd3d89462 /multimedia/libxine/Makefile
parent7875f791b18865fe910ae0e1ec23bd7ea4af9a90 (diff)
downloadports-f396f64b0d5cbb493baf8c1598c0309bbd85d0a1.tar.gz
ports-f396f64b0d5cbb493baf8c1598c0309bbd85d0a1.zip
Update xine to 0.9.1 and separate libxine from xine.
Hand the maintainership over to MANTANI Nobutaka. PR: ports/30413 Submitted by: Roman Shterenzon <roman@xpert.com> (MAINTAINER) MANTANI Nobutaka <nobutaka@nobutaka.com> Patrick Li <pat@databits.net>
Notes
Notes: svn path=/head/; revision=48004
Diffstat (limited to 'multimedia/libxine/Makefile')
-rw-r--r--multimedia/libxine/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
new file mode 100644
index 000000000000..d4512e897bf9
--- /dev/null
+++ b/multimedia/libxine/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: libxine
+# Date created: 14 Oct 2000
+# Whom: alex
+#
+# $FreeBSD$
+#
+
+PORTNAME= xine
+PORTVERSION= 0.9.1
+CATEGORIES= graphics
+MASTER_SITES= http://xine.sourceforge.net/files/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= lib
+DISTNAME= ${PORTNAME}-lib-${PORTVERSION}
+
+MAINTAINER= nobutaka@nobutaka.com
+
+LIB_DEPENDS= aa.1:${PORTSDIR}/graphics/aalib
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_IMLIB= yes
+USE_ESOUND= yes
+CONFIGURE_ARGS= --with-w32-path=${LOCALBASE}/lib/win32
+INSTALLS_SHLIB= yes
+
+MAN1= xine-config.1
+MAN3= ao_driver_t.3 ao_functions_t.3 autoplay_group.3 \
+ browse_group.3 build_info.3 cfg_data_t.3 config_group.3 \
+ config_values_s.3 config_values_t.3 demux_strategy.3 \
+ event_group.3 loadplugins_group.3 mrl_t.3 mrl_types.3 \
+ status_group.3 ui_callbacks.3 version_group.3 video_cap.3 \
+ video_group.3 video_prop.3 video_ratio.3 visual_types.3 \
+ vo_driver_s.3 vo_driver_t.3 vo_frame_t.3 vo_overlay_t.3 \
+ xine-lib.3 xine.h.3 xine_api.3 xine_init.3 xine_management.3 \
+ xine_t.3 xine_version.3
+
+.include <bsd.port.pre.mk>
+
+.if ${XFREE86_VERSION} >= 4
+PLIST_SUB= HAVE_LIBXV=""
+.else
+PLIST_SUB= HAVE_LIBXV="@comment "
+.endif
+
+.if exists(${LOCALBASE}/bin/artsc-config)
+PLIST_SUB+= HAVE_ARTS=""
+.else
+PLIST_SUB+= HAVE_ARTS="@comment "
+.endif
+
+.include <bsd.port.post.mk>