aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libxine
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2004-01-07 14:14:16 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2004-01-07 14:14:16 +0000
commitad839b5a966d2ac7bf2ad2ac82d3048cd91500bb (patch)
treeed7d91c55a57efd022c27cfaf165b43578ea8c93 /multimedia/libxine
parentf7527a57e54509f4963f28bde03b34bd3fdc2386 (diff)
downloadports-ad839b5a966d2ac7bf2ad2ac82d3048cd91500bb.tar.gz
ports-ad839b5a966d2ac7bf2ad2ac82d3048cd91500bb.zip
Update 1-rc3a.
Correct dependency on libmad. PR: ports/59706, ports/60951 Submitted by: Sergey Akifyev, adamw
Notes
Notes: svn path=/head/; revision=97570
Diffstat (limited to 'multimedia/libxine')
-rw-r--r--multimedia/libxine/Makefile11
-rw-r--r--multimedia/libxine/distinfo2
-rw-r--r--multimedia/libxine/files/extra-patch-src:xine-engine:audio_out.c30
-rw-r--r--multimedia/libxine/files/patch-src:libmad:xine_decoder.c16
-rw-r--r--multimedia/libxine/pkg-plist59
5 files changed, 58 insertions, 60 deletions
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index ac826b8a285b..917dca7b1b0c 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= xine
-PORTVERSION= 1.0.r2
-PORTREVISION= 5
+PORTVERSION= 1.0.r3
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMEPREFIX= lib
-DISTNAME= ${PORTNAME}-lib-1-rc2
+DISTNAME= ${PORTNAME}-lib-1-rc3a
MAINTAINER= nobutaka@FreeBSD.org
COMMENT= Libraries for xine multimedia player
@@ -21,7 +20,7 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libdjbfft.a:${PORTSDIR}/math/djbfft
LIB_DEPENDS= FLAC.5:${PORTSDIR}/audio/flac \
a52.0:${PORTSDIR}/audio/liba52 \
vorbis.3:${PORTSDIR}/audio/libvorbis \
- mad.2:${PORTSDIR}/audio/mad \
+ mad.2:${PORTSDIR}/audio/libmad \
speex.2:${PORTSDIR}/audio/speex \
iconv.3:${PORTSDIR}/converters/libiconv \
intl.5:${PORTSDIR}/devel/gettext \
@@ -34,7 +33,7 @@ GNU_CONFIGURE= yes
WANT_GNOME= yes
USE_GNOME= gnomehack gnometarget
USE_GMAKE= yes
-USE_MESA= yes
+USE_GL= yes
USE_SDL= yes
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/dvdread -I${X11BASE}/include" \
@@ -42,7 +41,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/dvdread -
THREAD_CFLAGS="${PTHREAD_CFLAGS}" \
THREAD_LIBS="${PTHREAD_LIBS}" \
X_EXTRA_LIBS="-lGL -lGLU -lXext -lX11 -lm"
-CONFIGURE_ARGS= --with-w32-path=${LOCALBASE}/lib/win32
+CONFIGURE_ARGS= --with-w32-path=${LOCALBASE}/lib/win32 --enable-ipv6
INSTALLS_SHLIB= yes
MAN1= xine-config.1
diff --git a/multimedia/libxine/distinfo b/multimedia/libxine/distinfo
index ed5bd0e1b796..4981916f2d7d 100644
--- a/multimedia/libxine/distinfo
+++ b/multimedia/libxine/distinfo
@@ -1 +1 @@
-MD5 (xine-lib-1-rc2.tar.gz) = 06ee51beaf77b4b9238f2bcc5b093860
+MD5 (xine-lib-1-rc3a.tar.gz) = 6dfd0c67b5b694adb283c0f6d8d3ab03
diff --git a/multimedia/libxine/files/extra-patch-src:xine-engine:audio_out.c b/multimedia/libxine/files/extra-patch-src:xine-engine:audio_out.c
index 64c3b24d76c9..ac023dc064f7 100644
--- a/multimedia/libxine/files/extra-patch-src:xine-engine:audio_out.c
+++ b/multimedia/libxine/files/extra-patch-src:xine-engine:audio_out.c
@@ -1,15 +1,15 @@
---- src/xine-engine/audio_out.c.orig Sun Aug 10 00:32:20 2003
-+++ src/xine-engine/audio_out.c Sun Aug 10 00:43:36 2003
-@@ -425,7 +425,7 @@
+--- src/xine-engine/audio_out.c.orig Thu Dec 25 09:24:36 2003
++++ src/xine-engine/audio_out.c Wed Jan 7 21:19:54 2004
+@@ -429,7 +429,7 @@
num_frames = pts_len * this->frames_per_kpts / 1024;
- xprintf (this->xine, XINE_VERBOSITY_LOG,
-- "inserting %d 0-frames to fill a gap of %" PRId64 " pts\n",
-+ "inserting %d 0-frames to fill a gap of %lld pts\n",
- num_frames, pts_len);
+ xprintf (this->xine, XINE_VERBOSITY_DEBUG,
+- "inserting %d 0-frames to fill a gap of %" PRId64 " pts\n", num_frames, pts_len);
++ "inserting %d 0-frames to fill a gap of %lld pts\n", num_frames, pts_len);
if ((this->output.mode == AO_CAP_MODE_A52) || (this->output.mode == AO_CAP_MODE_AC5)) {
-@@ -790,7 +790,7 @@
+ write_pause_burst(this,num_frames);
+@@ -792,7 +792,7 @@
this->resample_sync_factor = (avg_gap < 0) ? 0.995 : 1.005;
llprintf (LOG_RESAMPLE_SYNC,
@@ -18,7 +18,7 @@
return 0;
} else if (info->reduce_gap && abs(avg_gap) < 50) {
-@@ -824,7 +824,7 @@
+@@ -826,7 +826,7 @@
* this during calculation */
num_frames = (this->do_resample) ? (buf->num_frames * this->frame_rate_factor)
: buf->num_frames;
@@ -27,7 +27,7 @@
avg_gap, gap_diff, num_frames * info->window * info->last_factor,
this->resample_sync_factor);
#endif
-@@ -965,7 +965,7 @@
+@@ -981,7 +981,7 @@
*/
hw_vpts = cur_time;
@@ -36,7 +36,7 @@
/* External A52 decoder delay correction */
if ((this->output.mode==AO_CAP_MODE_A52) || (this->output.mode==AO_CAP_MODE_AC5))
-@@ -978,7 +978,7 @@
+@@ -994,7 +994,7 @@
* calculate gap:
*/
gap = in_buf->vpts - hw_vpts;
@@ -45,7 +45,7 @@
hw_vpts, in_buf->vpts, gap);
if (this->resample_sync_method) {
-@@ -1003,7 +1003,7 @@
+@@ -1018,7 +1018,7 @@
lprintf ("loop: drop package, next fifo\n");
fifo_append (this->free_fifo, in_buf);
@@ -54,7 +54,7 @@
in_buf->vpts, gap);
in_buf = NULL;
-@@ -1238,7 +1238,7 @@
+@@ -1252,7 +1252,7 @@
this->frames_per_kpts = (this->output.rate * 1024) / 90000;
this->audio_step = ((int64_t)90000 * (int64_t)32768) / (int64_t)this->input.rate;
@@ -63,8 +63,8 @@
return this->output.rate;
}
-@@ -1335,7 +1335,7 @@
- buf->num_frames);
+@@ -1355,7 +1355,7 @@
+
buf->extra_info->vpts = buf->vpts;
- lprintf ("ao_put_buffer, pts=%" PRId64 ", vpts=%" PRId64 ", flushmode=%d\n",
diff --git a/multimedia/libxine/files/patch-src:libmad:xine_decoder.c b/multimedia/libxine/files/patch-src:libmad:xine_decoder.c
index 72b04986dfe5..170e5929bc44 100644
--- a/multimedia/libxine/files/patch-src:libmad:xine_decoder.c
+++ b/multimedia/libxine/files/patch-src:libmad:xine_decoder.c
@@ -1,16 +1,10 @@
---- src/libmad/xine_decoder.c.orig Sat Nov 30 11:56:16 2002
-+++ src/libmad/xine_decoder.c Sat Nov 30 12:00:04 2002
-@@ -24,12 +24,11 @@
+--- src/libmad/xine_decoder.c.orig Mon Dec 15 07:13:23 2003
++++ src/libmad/xine_decoder.c Tue Jan 6 23:43:14 2004
+@@ -24,6 +24,7 @@
#include <stdlib.h>
#include <string.h>
+#include <mad.h>
- #include "xine_internal.h"
- #include "audio_out.h"
- #include "buffer.h"
--#include "frame.h"
--#include "synth.h"
- #include "xineutils.h"
-
- /*
+ #define LOG_MODULE "mad_decoder"
+ #define LOG_VERBOSE
diff --git a/multimedia/libxine/pkg-plist b/multimedia/libxine/pkg-plist
index 7a4a48bcb236..df3f4565d086 100644
--- a/multimedia/libxine/pkg-plist
+++ b/multimedia/libxine/pkg-plist
@@ -23,7 +23,6 @@ include/xine/video_out.h
include/xine/video_overlay.h
include/xine/vo_scale.h
include/xine/xine_buffer.h
-include/xine/xine_check.h
include/xine/xine_internal.h
include/xine/xine_plugin.h
include/xine/xineintl.h
@@ -31,7 +30,7 @@ include/xine/xineutils.h
include/xine/xmllexer.h
include/xine/xmlparser.h
lib/libxine.so
-lib/libxine.so.8
+lib/libxine.so.9
lib/xine/plugins/1.0.0/post/xineplug_post_goom.so
lib/xine/plugins/1.0.0/post/xineplug_post_mosaico.so
lib/xine/plugins/1.0.0/post/xineplug_post_planar.so
@@ -84,7 +83,6 @@ lib/xine/plugins/1.0.0/xineplug_decode_roqvideo.so
lib/xine/plugins/1.0.0/xineplug_decode_speex.so
lib/xine/plugins/1.0.0/xineplug_decode_spu.so
lib/xine/plugins/1.0.0/xineplug_decode_spucc.so
-lib/xine/plugins/1.0.0/xineplug_decode_spuogm.so
lib/xine/plugins/1.0.0/xineplug_decode_sputext.so
lib/xine/plugins/1.0.0/xineplug_decode_svq1.so
lib/xine/plugins/1.0.0/xineplug_decode_yuv_frames.so
@@ -140,23 +138,22 @@ lib/xine/plugins/1.0.0/xineplug_vo_out_xshm.so
%%XVMC%%lib/xine/plugins/1.0.0/xineplug_vo_out_xvmc.so
libdata/pkgconfig/libxine.pc
share/aclocal/xine.m4
-share/doc/xine/README
-share/doc/xine/README.config_en
-share/doc/xine/README.dvb
-share/doc/xine/README.dxr3
-share/doc/xine/README.dxr3_pl
-share/doc/xine/README.freebsd
-share/doc/xine/README.irix
-share/doc/xine/README.network_dvd
-share/doc/xine/README.opengl
-share/doc/xine/README.solaris
-share/doc/xine/README.syncfb
-share/doc/xine/faq/faq.html
-share/doc/xine/faq/faq.txt
-share/doc/xine/hackersguide/architecture.png
-share/doc/xine/hackersguide/hackersguide.html
-share/doc/xine/hackersguide/library.png
-share/doc/xine/hackersguide/overlays.png
+%%DOCSDIR%%/README
+%%DOCSDIR%%/README.config_en
+%%DOCSDIR%%/README.dvb
+%%DOCSDIR%%/README.dxr3
+%%DOCSDIR%%/README.freebsd
+%%DOCSDIR%%/README.irix
+%%DOCSDIR%%/README.network_dvd
+%%DOCSDIR%%/README.opengl
+%%DOCSDIR%%/README.solaris
+%%DOCSDIR%%/README.syncfb
+%%DOCSDIR%%/faq/faq.html
+%%DOCSDIR%%/faq/faq.txt
+%%DOCSDIR%%/hackersguide/architecture.png
+%%DOCSDIR%%/hackersguide/hackersguide.html
+%%DOCSDIR%%/hackersguide/library.png
+%%DOCSDIR%%/hackersguide/overlays.png
share/locale/cs/LC_MESSAGES/libxine1.mo
share/locale/de/LC_MESSAGES/libxine1.mo
share/locale/es/LC_MESSAGES/libxine1.mo
@@ -169,30 +166,38 @@ share/xine/libxine1/fonts/cc-16.xinefont.gz
share/xine/libxine1/fonts/cc-20.xinefont.gz
share/xine/libxine1/fonts/cc-24.xinefont.gz
share/xine/libxine1/fonts/cc-32.xinefont.gz
+share/xine/libxine1/fonts/cc-48.xinefont.gz
+share/xine/libxine1/fonts/cc-64.xinefont.gz
share/xine/libxine1/fonts/cci-16.xinefont.gz
share/xine/libxine1/fonts/cci-20.xinefont.gz
share/xine/libxine1/fonts/cci-24.xinefont.gz
share/xine/libxine1/fonts/cci-32.xinefont.gz
+share/xine/libxine1/fonts/cci-48.xinefont.gz
+share/xine/libxine1/fonts/cci-64.xinefont.gz
share/xine/libxine1/fonts/cetus-16.xinefont.gz
share/xine/libxine1/fonts/cetus-20.xinefont.gz
share/xine/libxine1/fonts/cetus-24.xinefont.gz
share/xine/libxine1/fonts/cetus-32.xinefont.gz
+share/xine/libxine1/fonts/cetus-48.xinefont.gz
+share/xine/libxine1/fonts/cetus-64.xinefont.gz
share/xine/libxine1/fonts/mono-16.xinefont.gz
share/xine/libxine1/fonts/mono-20.xinefont.gz
share/xine/libxine1/fonts/mono-24.xinefont.gz
share/xine/libxine1/fonts/mono-32.xinefont.gz
+share/xine/libxine1/fonts/mono-48.xinefont.gz
+share/xine/libxine1/fonts/mono-64.xinefont.gz
share/xine/libxine1/fonts/sans-16.xinefont.gz
share/xine/libxine1/fonts/sans-20.xinefont.gz
share/xine/libxine1/fonts/sans-24.xinefont.gz
share/xine/libxine1/fonts/sans-32.xinefont.gz
-share/xine/libxine1/fonts/sanshu-16.xinefont.gz
-share/xine/libxine1/fonts/sanshu-20.xinefont.gz
-share/xine/libxine1/fonts/sanshu-24.xinefont.gz
-share/xine/libxine1/fonts/sanshu-32.xinefont.gz
+share/xine/libxine1/fonts/sans-48.xinefont.gz
+share/xine/libxine1/fonts/sans-64.xinefont.gz
share/xine/libxine1/fonts/serif-16.xinefont.gz
share/xine/libxine1/fonts/serif-20.xinefont.gz
share/xine/libxine1/fonts/serif-24.xinefont.gz
share/xine/libxine1/fonts/serif-32.xinefont.gz
+share/xine/libxine1/fonts/serif-48.xinefont.gz
+share/xine/libxine1/fonts/serif-64.xinefont.gz
@dirrm include/xine
@dirrm lib/xine/plugins/1.0.0/vidix
@dirrm lib/xine/plugins/1.0.0/post
@@ -200,9 +205,9 @@ share/xine/libxine1/fonts/serif-32.xinefont.gz
@dirrm lib/xine/plugins
@dirrm lib/xine
@unexec rmdir %D/libdata/pkgconfig 2>/dev/null || true
-@dirrm share/doc/xine/hackersguide
-@dirrm share/doc/xine/faq
-@dirrm share/doc/xine
+@dirrm %%DOCSDIR%%/hackersguide
+@dirrm %%DOCSDIR%%/faq
+@dirrm %%DOCSDIR%%
@unexec rmdir %D/share/locale/cs/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/cs 2>/dev/null || true
@unexec rmdir %D/share/locale/de/LC_MESSAGES 2>/dev/null || true