aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libxine
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2002-01-24 09:22:15 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2002-01-24 09:22:15 +0000
commit7b87ae92f5b1e42f78e8e748632ae6481a5e3be8 (patch)
tree2cf69240797b29bead8af5cae94d4d21d60464f5 /multimedia/libxine
parenta4eadd06446af56699d6adae498abbedeaa11018 (diff)
downloadports-7b87ae92f5b1e42f78e8e748632ae6481a5e3be8.tar.gz
ports-7b87ae92f5b1e42f78e8e748632ae6481a5e3be8.zip
Update to 0.9.8.
Notes
Notes: svn path=/head/; revision=53675
Diffstat (limited to 'multimedia/libxine')
-rw-r--r--multimedia/libxine/Makefile40
-rw-r--r--multimedia/libxine/distinfo2
-rw-r--r--multimedia/libxine/files/patch-src:xine-engine:Makefile.am12
-rw-r--r--multimedia/libxine/pkg-plist13
4 files changed, 24 insertions, 43 deletions
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index a12a075c5143..5395bfc57ab2 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xine
-PORTVERSION= 0.9.7
-PORTREVISION= 1
+PORTVERSION= 0.9.8
CATEGORIES= graphics
MASTER_SITES= http://xine.sourceforge.net/files/ \
${MASTER_SITE_SOURCEFORGE}
@@ -19,10 +18,13 @@ MAINTAINER= nobutaka@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/libavcodec.a:${PORTSDIR}/graphics/ffmpeg
LIB_DEPENDS= a52.0:${PORTSDIR}/audio/liba52 \
- aa.1:${PORTSDIR}/graphics/aalib
+ aa.1:${PORTSDIR}/graphics/aalib \
+ intl.1:${PORTSDIR}/devel/gettext
WRKSRC= ${WRKDIR}/${PORTNAME}-lib-${PORTVERSION}
CONFIGURE_ARGS= --with-w32-path=${LOCALBASE}/lib/win32
+CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LIBS=-L${LOCALBASE}/lib
+
USE_AUTOMAKE= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
@@ -72,41 +74,9 @@ PLIST_SUB+= HAVE_OGG=""
PLIST_SUB+= HAVE_OGG="@comment "
.endif
-# DVD input plugin for xine-0.9.7 is not available yet.
-.if 0
-.if defined(WITH_CSS)
-# http://members.home.nl/mphm.janssen/linuxvideo/linuxvideo.html
-MASTER_SITES+= http://members.home.nl/mphm.janssen/files/
-DISTFILES+= ${PLUGIN_CSS}${EXTRACT_SUFX}
-
-LIB_DEPENDS+= dvdcss.0:${PORTSDIR}/graphics/libdvdcss
-
-PLUGIN_CSS= dvd-plugin-${PLUGIN_CSS_VERSION}
-PLUGIN_CSS_VERSION= 0.4
-.endif
-.endif
-
-pre-everything::
-.if 0
-.if !defined(WITH_CSS)
- @${ECHO_MSG} "====>"
- @${ECHO_MSG} "====> To enable css support, define WITH_CSS"
- @${ECHO_MSG} "====>"
-.endif
-.endif
-
# XXX: To avoid internal error in gcc.
post-configure:
@${SED} -e "s/-funroll-loops//" < ${WRKSRC}/src/libw32dll/wine/Makefile > ${WRKSRC}/src/libw32dll/wine/Makefile.tmp
@${MV} ${WRKSRC}/src/libw32dll/wine/Makefile.tmp ${WRKSRC}/src/libw32dll/wine/Makefile
-post-patch:
-.if 0
-.if defined(WITH_CSS)
- @${PERL} -pi.orig -e 's/(xineplug_inp_dvd_la_LDFLAGS = -avoid-version -module)/\1 -ldvdcss/' \
- ${WRKSRC}/src/input/Makefile.am
- @${CP} -f ${WRKDIR}/${PLUGIN_CSS}/*.[ch] ${WRKSRC}/src/input
-.endif
-.endif
-
.include <bsd.port.post.mk>
diff --git a/multimedia/libxine/distinfo b/multimedia/libxine/distinfo
index ee69c68bd513..58ffe42c94ed 100644
--- a/multimedia/libxine/distinfo
+++ b/multimedia/libxine/distinfo
@@ -1 +1 @@
-MD5 (xine-lib-0.9.7.tar.gz) = 52f3cfdcf2066d36746fb98b735b0fbc
+MD5 (xine-lib-0.9.8.tar.gz) = d8fc9b30e15b50af8ab7552bbda7aeda
diff --git a/multimedia/libxine/files/patch-src:xine-engine:Makefile.am b/multimedia/libxine/files/patch-src:xine-engine:Makefile.am
index dc8aa08f2b97..6eac654e2594 100644
--- a/multimedia/libxine/files/patch-src:xine-engine:Makefile.am
+++ b/multimedia/libxine/files/patch-src:xine-engine:Makefile.am
@@ -1,12 +1,12 @@
---- src/xine-engine/Makefile.am.orig Sun Oct 21 09:06:25 2001
-+++ src/xine-engine/Makefile.am Sun Oct 21 09:07:43 2001
-@@ -18,8 +18,7 @@
- -lm
+--- src/xine-engine/Makefile.am.orig Sat Dec 29 02:31:25 2001
++++ src/xine-engine/Makefile.am Thu Jan 24 13:42:50 2002
+@@ -15,8 +15,7 @@
+ libxine_la_LIBADD = $(THREAD_LIBS) $(DYNAMIC_LD_LIBS) @INTLLIBS@ -lm -lz
libxine_la_LDFLAGS = \
- -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
-- -release $(LT_RELEASE)
+- -release $(LT_RELEASE)
+ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
include_HEADERS = buffer.h metronom.h configfile.h \
- monitor.h cpu_accel.h attributes.h utils.h \
+ audio_out.h resample.h video_out.h xine_internal.h spu_decoder.h \
diff --git a/multimedia/libxine/pkg-plist b/multimedia/libxine/pkg-plist
index 3ca34f8a6430..e0eb4362c956 100644
--- a/multimedia/libxine/pkg-plist
+++ b/multimedia/libxine/pkg-plist
@@ -6,7 +6,6 @@ include/xine/buffer.h
include/xine/configfile.h
include/xine/demux.h
include/xine/dxr3_video_out.h
-include/xine/dxr3_vo_encoder.h
include/xine/events.h
include/xine/input_plugin.h
include/xine/lrb.h
@@ -20,6 +19,7 @@ include/xine/video_out.h
include/xine/video_out_x11.h
include/xine/video_overlay.h
include/xine/xine_internal.h
+include/xine/xineintl.h
include/xine/xineutils.h
include/xine.h
lib/libxine.la
@@ -52,6 +52,8 @@ lib/xine/plugins/xineplug_decode_mpeg2.la
lib/xine/plugins/xineplug_decode_mpeg2.so
lib/xine/plugins/xineplug_decode_spu.la
lib/xine/plugins/xineplug_decode_spu.so
+lib/xine/plugins/xineplug_decode_spucc.la
+lib/xine/plugins/xineplug_decode_spucc.so
lib/xine/plugins/xineplug_decode_sputext.la
lib/xine/plugins/xineplug_decode_sputext.so
%%HAVE_VORBIS%%lib/xine/plugins/xineplug_decode_vorbis.la
@@ -147,6 +149,15 @@ share/doc/xine/xine-lib-API/html/structxine__t.html
share/doc/xine/xine-lib-API/html/xine_8h-source.html
share/doc/xine/xine-lib-API/html/xine_8h.html
share/doc/xine/xine-lib-API/html/xine_logo.png
+share/locale/fr/LC_MESSAGES/xine-lib.mo
+share/xine/fonts/cc-16.xinefont.gz
+share/xine/fonts/cc-20.xinefont.gz
+share/xine/fonts/cc-24.xinefont.gz
+share/xine/fonts/cc-32.xinefont.gz
+share/xine/fonts/cci-16.xinefont.gz
+share/xine/fonts/cci-20.xinefont.gz
+share/xine/fonts/cci-24.xinefont.gz
+share/xine/fonts/cci-32.xinefont.gz
share/xine/fonts/cetus-16.xinefont.gz
share/xine/fonts/cetus-20.xinefont.gz
share/xine/fonts/cetus-24.xinefont.gz