aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mjpegtools
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-12-21 16:21:53 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-12-21 16:21:53 +0000
commit6d71d0934ca1b440427b5f7a70218873624b14e0 (patch)
treeb0e4acf3f3d1654cee3b4e9fc6b8cdf8b6bc0a40 /multimedia/mjpegtools
parentcac187fddf4d87d5b9a1d50646b2972b1fabb61d (diff)
downloadports-6d71d0934ca1b440427b5f7a70218873624b14e0.tar.gz
ports-6d71d0934ca1b440427b5f7a70218873624b14e0.zip
Fix breakage if libgnugetopt is installed prior to building this
port. Only depend on libgnugetopt in such scenario: less dependencies and decreases chance of problems with -CURRENT vs libgnugetopt. Submitted by: Michael Nottebrock <michaelnottebrock@gmx.net> et al Approved by: portmgr (self & no objections)
Notes
Notes: svn path=/head/; revision=71756
Diffstat (limited to 'multimedia/mjpegtools')
-rw-r--r--multimedia/mjpegtools/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/multimedia/mjpegtools/Makefile b/multimedia/mjpegtools/Makefile
index 21eb5437224a..2bbcdc0686b6 100644
--- a/multimedia/mjpegtools/Makefile
+++ b/multimedia/mjpegtools/Makefile
@@ -64,6 +64,14 @@ PLIST_SUB+= DIVX=''
.if exists(${LOCALBASE}/lib/libdv.so.2)
WITH_LIBDV= yes
.endif
+# LIBGNUGETOPT
+# If this is found in the system, the port tries to use it
+# Furthermore, we will only do this if gnugetopt is installed so
+# that we don't break -CURRENT since libgnugetopt is a problem for
+# -CURRENT right now
+.if exists(${LOCALBASE}/lib/libgnugetopt.so)
+WITH_LIBGNUGETOPT= yes
+.endif
# LIBMOVTAR
.if exists(${LOCALBASE}/lib/libmovtar.a)
WITH_LIBMOVTAR= yes
@@ -88,6 +96,10 @@ LIB_DEPENDS+= dv.2:${PORTSDIR}/multimedia/libdv
CONFIGURE_ARGS+= --with-dv=${LOCALBASE}
.endif
#
+.ifdef(WITH_LIBGNUGETOPT)
+LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+.endif
+#
.ifdef(WITH_LIBMOVTAR)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libmovtar.a:${PORTSDIR}/multimedia/libmovtar
@@ -156,6 +168,10 @@ post-patch:
@${REINPLACE_CMD} -E -e 's|^(have_pthread=).+$$|\1true|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
.endif
+.ifdef(WITH_LIBGNUGETOPT)
+ @${REINPLACE_CMD} -E -e 's|(AVIPLAY_LIBS \=.*)|\1 -lgnugetopt|' \
+ ${WRKSRC}/lavtools/Makefile.in
+.endif
post-configure:
@${CP} -f ${LOCALBASE}/bin/${LIBTOOL} ${WRKSRC}