aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mlt
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-11-03 07:03:42 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-11-03 07:03:42 +0000
commit39c0848259609d39a0bc14c20d0a35ed82cea617 (patch)
tree148aadc68636bf8aec440c914d4e8e7e001eccc2 /multimedia/mlt
parent8fd67d36e22b0317b5871b24cc8254351e51c805 (diff)
downloadports-39c0848259609d39a0bc14c20d0a35ed82cea617.tar.gz
ports-39c0848259609d39a0bc14c20d0a35ed82cea617.zip
- Fix build when upgrading from an old version.
PR: 162244 [1] Reported by: James Colannino <crankycyclops@gmail.com> via e-mail Andrei Lavreniyuk <andy.lavr@gmail.com> [1] Tested by: James Colannino <crankycyclops@gmail.com>
Notes
Notes: svn path=/head/; revision=284949
Diffstat (limited to 'multimedia/mlt')
-rw-r--r--multimedia/mlt/Makefile5
-rw-r--r--multimedia/mlt/files/patch-src__modules__linsys__Makefile11
2 files changed, 13 insertions, 3 deletions
diff --git a/multimedia/mlt/Makefile b/multimedia/mlt/Makefile
index ecc29d181889..6db0c2ae7d8b 100644
--- a/multimedia/mlt/Makefile
+++ b/multimedia/mlt/Makefile
@@ -29,8 +29,6 @@ USE_LDCONFIG= yes
# Required at least for frei0r detection.
CFLAGS+= -I${LOCALBASE}/include
-# Required at least by linsys module.
-LDFLAGS+= -L${LOCALBASE}/lib
NOT_FOR_ARCHS= sparc64
NOT_FOR_ARCHS_REASON_sparc64= does not compile on sparc64 (invokes i386 asm)
@@ -198,7 +196,8 @@ pre-configure:
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/src/modules/avformat/vdpau.c \
${WRKSRC}/src/modules/frei0r/factory.c \
- ${WRKSRC}/src/modules/jackrack/plugin_mgr.c
+ ${WRKSRC}/src/modules/jackrack/plugin_mgr.c \
+ ${WRKSRC}/src/modules/linsys/Makefile
${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/configure
${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
diff --git a/multimedia/mlt/files/patch-src__modules__linsys__Makefile b/multimedia/mlt/files/patch-src__modules__linsys__Makefile
new file mode 100644
index 000000000000..f7d3da97a359
--- /dev/null
+++ b/multimedia/mlt/files/patch-src__modules__linsys__Makefile
@@ -0,0 +1,11 @@
+--- ./src/modules/linsys/Makefile.orig 2011-11-02 17:34:58.740000641 +0100
++++ ./src/modules/linsys/Makefile 2011-11-02 17:35:07.133393857 +0100
+@@ -12,7 +12,7 @@
+
+ ifdef WITH_JPEG
+ CFLAGS += -DWITH_JPEG
+-LDFLAGS += -ljpeg
++LDFLAGS += -ljpeg -L/usr/local/lib
+ endif
+
+ SRCS := $(OBJS:.o=.c)