aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mplayer/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-01-17 19:55:14 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-01-17 19:55:14 +0000
commit65ceb81162a37a90f043dd2f2cd726cf48523651 (patch)
tree360f3c37e6f15b8d372af8d1fca2e159af32f5ff /multimedia/mplayer/Makefile
parent4ae2a526e6435d5bf4a999f60b7232c3134f4538 (diff)
downloadports-65ceb81162a37a90f043dd2f2cd726cf48523651.tar.gz
ports-65ceb81162a37a90f043dd2f2cd726cf48523651.zip
o Update to 0.60.1
o Add additional MASTER_SITES o Depend on mplayer-skins if WITH_GUI since GUI does not work without a skin o Added option WITH_XANIM PR: 33604 Submitted by: MAINTAINER, Alan Eldridge <ports@geeksrus.net> Reviewed by: pat
Notes
Notes: svn path=/head/; revision=53266
Diffstat (limited to 'multimedia/mplayer/Makefile')
-rw-r--r--multimedia/mplayer/Makefile46
1 files changed, 39 insertions, 7 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 079bed0ae495..9c073575225b 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -6,17 +6,21 @@
#
PORTNAME= mplayer
-PORTVERSION= 0.50.0.2
-PORTREVISION= 1
+PORTVERSION= 0.60.1
CATEGORIES= graphics
MASTER_SITES= http://ftp.mplayerhq.hu/MPlayer/releases/ \
+ http://www.mplayerhq.hu/MPlayer/releases/ \
+ http://www2.mplayerhq.hu/MPlayer/releases/ \
+ ftp://ftp.mplayerhq.hu/MPlayer/releases/ \
+ ftp://ftp2.mplayerhq.hu/MPlayer/releases/ \
http://www.stud.uni-karlsruhe.de/~uedc/mplayer/ \
http://www.rrr.de/~riggs/mplayer/
-DISTNAME= MPlayer-0.50
+DISTNAME= MPlayer-0.60
MAINTAINER= riggs@rrr.de
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+ giconv.2:${PORTSDIR}/converters/iconv \
SDL-1.1.3:${PORTSDIR}/devel/sdl12
RUN_DEPENDS= ${LOCALBASE}/share/mplayer/fonts:${PORTSDIR}/graphics/mplayer-fonts
@@ -26,8 +30,8 @@ USE_GMAKE= yes
USE_XLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}"
-CONFIGURE_ARGS= --disable-esd
+ PTHREAD_LIBS=${PTHREAD_LIBS}
+CONFIGURE_ARGS= --disable-mencoder
MAN1= mplayer.1
MANCOMPRESSED= no
@@ -35,17 +39,33 @@ MANCOMPRESSED= no
CONFFILES= codecs.conf example.conf
DOCFILES= DVB bugreports.html cd-dvd.html codecs-in.html \
codecs.html documentation.html faq.html skin-en.html \
- sound.html video.html tech/tech-eng.txt
+ DXR3 formats.html skin-en.html sound.html tech/tech-eng.txt \
+ video.html
.include <bsd.port.pre.mk>
+.if exists(${LOCALBASE}/lib/libdvdread.so.2)
+WITH_DVD= yes
+.endif
+
+.if exists(${X11BASE}/bin/xanim)
+WITH_XANIM= yes
+.endif
+
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
.endif
.if defined(WITH_GUI)
USE_GTK= yes
+
+RUN_DEPENDS+= ${SKIN_DETECTION_FILE}:${SKIN_PORT}
+
CONFIGURE_ARGS+= --enable-gui
+
+#SKIN_PORT= ${PORTSDIR}/graphics/mplayer-skins
+SKIN_PORT= ${.CURDIR}/../mplayer-skins
+SKIN_DETECTION_FILE!= ${MAKE} -f ${SKIN_PORT}/Makefile -V SKIN_DETECTION_FILE
.endif
.if defined(WITH_DVD)
@@ -61,6 +81,14 @@ LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
LIB_DEPENDS+= vorbis.1:${PORTSDIR}/audio/libvorbis
.endif
+.if defined(WITH_XANIM)
+BUILD_DEPENDS+= xanim:${PORTSDIR}/graphics/xanim
+
+CONFIGURE_ARGS+=--enable-xanim --with-xanimlibdir=${X11BASE}/lib/X11/xanim
+.else
+CONFIGURE_ARGS+=--disable-xanim
+.endif
+
# "enable" build for other archs
.if ${ARCH} == "i386"
.if defined(WITHOUT_MMX)
@@ -86,7 +114,8 @@ RUN_DEPENDS+= ${CODEC_DETECTION_FILE}:${CODEC_PORT}
CONFIGURE_ARGS+= --with-win32libdir=${LOCALBASE}/lib/win32
-CODEC_PORT= ${PORTSDIR}/graphics/win32-codecs
+#CODEC_PORT= ${PORTSDIR}/graphics/win32-codecs
+CODEC_PORT= ${.CURDIR}/../win32-codecs
CODEC_DETECTION_FILE!= ${MAKE} -f ${CODEC_PORT}/Makefile -V CODEC_DETECTION_FILE
.endif
.endif # ARCH == i386
@@ -108,6 +137,9 @@ pre-everything::
.if !defined(WITH_VORBIS)
@${ECHO_MSG} "You can enable VORBIS sound support by defining WITH_VORBIS."
.endif
+.if !defined(WITH_XANIM)
+ @${ECHO_MSG} "You can enable XAnim DLL support by defining WITH_XANIM."
+.endif
.if ${ARCH} == "i386"
.if !defined(WITHOUT_WIN32_CODECS)
@${ECHO_MSG} "You can disable support (this turns this into a X86 only port)"