aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mplayer/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-11-02 02:28:15 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-11-02 02:28:15 +0000
commitd3157e068c65a7d919c5bba620211e2d41a31cc6 (patch)
tree73efb051ea898f7da3277eb3b5d7506c219d3acc /multimedia/mplayer/Makefile
parentb7a639834e1ab4cf07968a7d2820f446b9650fd0 (diff)
downloadports-d3157e068c65a7d919c5bba620211e2d41a31cc6.tar.gz
ports-d3157e068c65a7d919c5bba620211e2d41a31cc6.zip
o Update to 0.90.0.9 [1]
o Add WITH_FREETYPE knob [2] PR: 44362 [2] Submitted by: maintainer [1], Pat Lashley <patl+freebsd@volant.org> [2] Reviewed by: maintainer
Notes
Notes: svn path=/head/; revision=69283
Diffstat (limited to 'multimedia/mplayer/Makefile')
-rw-r--r--multimedia/mplayer/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 6c9b9597f5a2..02b783f6abd1 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mplayer
-PORTVERSION= 0.90.0.8
-PORTREVISION= 2
+PORTVERSION= 0.90.0.9
CATEGORIES= graphics
MASTER_SITES= http://ftp.mplayerhq.hu/MPlayer/releases/ \
http://www.mplayerhq.hu/MPlayer/releases/ \
@@ -17,7 +16,7 @@ MASTER_SITES= http://ftp.mplayerhq.hu/MPlayer/releases/ \
ftp://ftp2.mplayerhq.hu/MPlayer/releases/ \
ftp://ftp.lug.udel.edu/MPlayer/releases/ \
http://www.rrr.de/~riggs/mplayer/
-DISTNAME= MPlayer-0.90pre8
+DISTNAME= MPlayer-0.90pre9
MAINTAINER= riggs@rrr.de
@@ -134,6 +133,12 @@ RUN_DEPENDS+= ${LOCALBASE}/live/liveMedia/libliveMedia.a:${PORTSDIR}/net/liveMe
BUILD_DEPENDS+= ${LOCALBASE}/live/liveMedia/libliveMedia.a:${PORTSDIR}/net/liveMedia
.endif
+.if defined(WITH_FREETYPE)
+CONFIGURE_ARGS+= --with-extraincdir=${LOCALBASE}/include/freetype2 \
+ --enable-freetype
+LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
+.endif
+
.if defined(WITH_XANIM)
BUILD_DEPENDS+= xanim:${PORTSDIR}/graphics/xanim
@@ -211,6 +216,13 @@ pre-everything::
.if !defined(WITH_XANIM)
@${ECHO_MSG} "You can enable XAnim DLL support by defining WITH_XANIM."
.endif
+.if !defined(WITH_LIVEMEDIA)
+ @${ECHO_MSG} "You can enable liveMedia support by defining WITH_LIVEMEDIA."
+.endif
+.if !defined(WITH_FREETYPE)
+ @${ECHO_MSG} "You can enable truetype font support by defining WITH_FREETYPE."
+ @${ECHO_MSG} " But use with caution. mplayer won't use the standard fonts anymore."
+.endif
.if ${ARCH} == "i386"
.if !defined(WITHOUT_WIN32_CODECS)
@${ECHO_MSG} "You can disable support (this turns this into a X86 only port)"