aboutsummaryrefslogtreecommitdiff
path: root/multimedia/pitivi
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2005-07-19 12:41:38 +0000
committerKoop Mast <kwm@FreeBSD.org>2005-07-19 12:41:38 +0000
commit520c5360982bc8959e9a33716421620b67416b45 (patch)
tree7fbc4642f989949c7880184304a75e940f1e8f41 /multimedia/pitivi
parenteeb0735e7bde98700ed5397378e6d2cd060f4090 (diff)
downloadports-520c5360982bc8959e9a33716421620b67416b45.tar.gz
ports-520c5360982bc8959e9a33716421620b67416b45.zip
Update to 0.1.10.
Notes
Notes: svn path=/head/; revision=139586
Diffstat (limited to 'multimedia/pitivi')
-rw-r--r--multimedia/pitivi/Makefile21
-rw-r--r--multimedia/pitivi/distinfo4
-rw-r--r--multimedia/pitivi/files/patch-gnl_gnlcomposition.c18
-rw-r--r--multimedia/pitivi/files/patch-src_pitivi-effectswindowproperties.c19
-rw-r--r--multimedia/pitivi/files/patch-src_pitivi-gstelementsettings.c17
-rw-r--r--multimedia/pitivi/files/patch-src_pitivi-lplayerwindow.c19
-rw-r--r--multimedia/pitivi/files/patch-src_pitivi-mainapp.c33
-rw-r--r--multimedia/pitivi/files/patch-src_pitivi-menu.c14
-rw-r--r--multimedia/pitivi/files/patch-src_pitivi-progressbar.c26
-rw-r--r--multimedia/pitivi/files/patch-src_pitivi-settings.c18
-rw-r--r--multimedia/pitivi/files/patch-src_pitivi-settingswindow.c17
-rw-r--r--multimedia/pitivi/files/patch-src_pitivi-sourcelistwindow.c14
-rw-r--r--multimedia/pitivi/files/patch-src_pitivi-timelinecellrenderer.c17
-rw-r--r--multimedia/pitivi/files/patch-src_pitivi-timelinemedia.c50
-rw-r--r--multimedia/pitivi/files/patch-src_pitivi-timelinewindow.c62
-rw-r--r--multimedia/pitivi/pkg-plist316
16 files changed, 74 insertions, 591 deletions
diff --git a/multimedia/pitivi/Makefile b/multimedia/pitivi/Makefile
index 69aa6bed915a..40c63281febb 100644
--- a/multimedia/pitivi/Makefile
+++ b/multimedia/pitivi/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pitivi
-PORTVERSION= 0.1.1
-PORTREVISION= 3
+PORTVERSION= 0.1.10
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,13 +14,16 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= kwm@FreeBSD.org
COMMENT= Gstreamer based non-linear audio/video editor
-CONFLICTS= gnonlin-0.*
+BUILD_DEPENDS= gnonlin-config:${PORTSDIR}/multimedia/gnonlin \
+ ${PYTHON_SITELIBDIR}/gst/_gst.so:${PORTSDIR}/multimedia/py-gstreamer
+RUN_DEPENDS= gnonlin-config:${PORTSDIR}/multimedia/gnonlin \
+ ${PYTHON_SITELIBDIR}/gst/_gst.so:${PORTSDIR}/multimedia/py-gstreamer
-USE_X_PREFIX= yes
+USE_BZIP2= yes
USE_GMAKE= yes
USE_REINPLACE= yes
-USE_GNOME= gnometarget gnomeprefix
-USE_GSTREAMER= gconf
+USE_GNOME= gnometarget gnomeprefix pygtk2 pkgconfig pygnome2
+USE_GSTREAMER= yes
USE_LIBTOOL_VER=15
USE_PYTHON= yes
GNU_CONFIGURE= yes
@@ -29,8 +31,9 @@ CONFIGURE_ARGS= --disable-docs-build
INSTALLS_SHLIB= yes
post-patch:
- @${REINPLACE_CMD} -e 's|-Werror||g' \
- ${WRKSRC}/gnl/Makefile.in \
- ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|/usr/bin/python|${LOCALBASE}/bin/python|g' \
+ ${WRKSRC}/bin/pitivi.in
+ @${REINPLACE_CMD} -e 's|0.1.9|0.1.10|g' \
+ ${WRKSRC}/pitivi/ui/mainwindow.py
.include <bsd.port.mk>
diff --git a/multimedia/pitivi/distinfo b/multimedia/pitivi/distinfo
index a75f76aa522b..f356610bf28e 100644
--- a/multimedia/pitivi/distinfo
+++ b/multimedia/pitivi/distinfo
@@ -1,2 +1,2 @@
-MD5 (pitivi-0.1.1.tar.gz) = 4cd843977ccc967a07f9e28733cbf349
-SIZE (pitivi-0.1.1.tar.gz) = 734595
+MD5 (pitivi-0.1.10.tar.bz2) = 9d9c0351e5d21a162c07baaaa56ec7b6
+SIZE (pitivi-0.1.10.tar.bz2) = 284126
diff --git a/multimedia/pitivi/files/patch-gnl_gnlcomposition.c b/multimedia/pitivi/files/patch-gnl_gnlcomposition.c
deleted file mode 100644
index 257da686fb74..000000000000
--- a/multimedia/pitivi/files/patch-gnl_gnlcomposition.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- gnl/gnlcomposition.c.orig Mon Dec 20 13:08:16 2004
-+++ gnl/gnlcomposition.c Mon Dec 20 13:09:18 2004
-@@ -860,6 +860,7 @@
- gnl_composition_nearest_cover_func (GnlComposition *comp, GstClockTime time, GnlDirection direction)
- {
- GList *objects = comp->objects;
-+ GstClockTime start;
-
- GST_INFO("Object:%s , Time[%lld], Direction:%d",
- gst_element_get_name(GST_ELEMENT(comp)),
-@@ -903,7 +904,6 @@
- GstClockTime last = G_MAXINT64;
- while (objects) {
- entry = (GnlCompositionEntry *) (objects->data);
-- GstClockTime start;
-
- start = entry->object->start;
-
diff --git a/multimedia/pitivi/files/patch-src_pitivi-effectswindowproperties.c b/multimedia/pitivi/files/patch-src_pitivi-effectswindowproperties.c
deleted file mode 100644
index 52da67f08ae7..000000000000
--- a/multimedia/pitivi/files/patch-src_pitivi-effectswindowproperties.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/pitivi-effectswindowproperties.c.orig Mon Dec 20 13:17:07 2004
-+++ src/pitivi-effectswindowproperties.c Mon Dec 20 13:17:47 2004
-@@ -130,6 +130,7 @@
- GtkWidget *button_ok;
- GtkWidget *button_apply;
- GtkWidget *button_cancel;
-+ PitiviEffectsWindowProperties *self;
-
- /* Invoke parent constructor. */
-
-@@ -137,7 +138,7 @@
- parent_class = G_OBJECT_CLASS (g_type_class_peek_parent (klass));
- obj = parent_class->constructor (type, n_construct_properties,
- construct_properties);
-- PitiviEffectsWindowProperties *self = (PitiviEffectsWindowProperties *) obj;
-+ self = (PitiviEffectsWindowProperties *) obj;
-
- /* do stuff. */
-
diff --git a/multimedia/pitivi/files/patch-src_pitivi-gstelementsettings.c b/multimedia/pitivi/files/patch-src_pitivi-gstelementsettings.c
deleted file mode 100644
index 7ef1c2dc7309..000000000000
--- a/multimedia/pitivi/files/patch-src_pitivi-gstelementsettings.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/pitivi-gstelementsettings.c.orig Mon Dec 20 13:56:47 2004
-+++ src/pitivi-gstelementsettings.c Mon Dec 20 13:57:28 2004
-@@ -872,12 +872,13 @@
- GObjectConstructParam * construct_properties)
- {
- GObject *obj;
-+ PitiviGstElementSettings *self;
- /* Invoke parent constructor. */
- obj = G_OBJECT_CLASS (parent_class)->constructor (type, n_construct_properties,
- construct_properties);
-
- /* do stuff. */
-- PitiviGstElementSettings *self = (PitiviGstElementSettings *) obj;
-+ self = (PitiviGstElementSettings *) obj;
-
- pitivi_gstelementsettings_create_gui (self);
-
diff --git a/multimedia/pitivi/files/patch-src_pitivi-lplayerwindow.c b/multimedia/pitivi/files/patch-src_pitivi-lplayerwindow.c
deleted file mode 100644
index db1e1c00500f..000000000000
--- a/multimedia/pitivi/files/patch-src_pitivi-lplayerwindow.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/pitivi-lplayerwindow.c.orig Mon Dec 20 13:58:25 2004
-+++ src/pitivi-lplayerwindow.c Mon Dec 20 13:59:02 2004
-@@ -374,13 +374,15 @@
- {
- GstElement *elem;
- GObject *obj;
-+ PitiviLPlayerWindow *self;
-+
- /* Invoke parent constructor. */
- obj = parent_class->constructor (type, n_construct_properties,
- construct_properties);
-
- /* do stuff. */
- PITIVI_DEBUG("lplayer creation !");
-- PitiviLPlayerWindow *self = (PitiviLPlayerWindow *) obj;
-+ self = (PitiviLPlayerWindow *) obj;
-
- pitivi_lplayerwindow_create_gui (self);
-
diff --git a/multimedia/pitivi/files/patch-src_pitivi-mainapp.c b/multimedia/pitivi/files/patch-src_pitivi-mainapp.c
deleted file mode 100644
index 84f973cd4664..000000000000
--- a/multimedia/pitivi/files/patch-src_pitivi-mainapp.c
+++ /dev/null
@@ -1,33 +0,0 @@
---- src/pitivi-mainapp.c.orig Mon Dec 20 13:10:23 2004
-+++ src/pitivi-mainapp.c Mon Dec 20 13:12:47 2004
-@@ -136,8 +136,8 @@
- void
- pitivi_mainapp_callb_effects (GtkWindow *win, gpointer data)
- {
-- PITIVI_DEBUG("removed the effects window...\n");
- PitiviMainApp *self = data;
-+ PITIVI_DEBUG("removed the effects window...\n");
- self->private->effectswin = NULL;
- }
-
-@@ -409,6 +409,10 @@
- guint n_construct_properties,
- GObjectConstructParam * construct_properties)
- {
-+ /* Invoke parent constructor. */
-+ PitiviMainAppClass *klass;
-+ GObjectClass *parent_class;
-+
- PitiviMainApp *self;
- gchar *settingsfile;
- GObject *obj;
-@@ -418,9 +422,6 @@
- width = gdk_screen_width ();
- height = gdk_screen_height ();
-
-- /* Invoke parent constructor. */
-- PitiviMainAppClass *klass;
-- GObjectClass *parent_class;
- klass = PITIVI_MAINAPP_CLASS (g_type_class_peek (PITIVI_MAINAPP_TYPE));
- parent_class = G_OBJECT_CLASS (g_type_class_peek_parent (klass));
- obj = parent_class->constructor (type, n_construct_properties,
diff --git a/multimedia/pitivi/files/patch-src_pitivi-menu.c b/multimedia/pitivi/files/patch-src_pitivi-menu.c
deleted file mode 100644
index e50203dbf0cb..000000000000
--- a/multimedia/pitivi/files/patch-src_pitivi-menu.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/pitivi-menu.c.orig Mon Dec 20 13:51:12 2004
-+++ src/pitivi-menu.c Mon Dec 20 13:51:40 2004
-@@ -215,9 +215,10 @@
- pitivi_menu_configure (PitiviMenu *self)
- {
- GError *error;
-+ PitiviMenuPrivate *priv;
-
- error = NULL;
-- PitiviMenuPrivate *priv = self->private;
-+ priv = self->private;
- if (priv->merge_id)
- gtk_ui_manager_remove_ui(priv->ui_manager, priv->merge_id);
- pitivi_menubar_configure (priv->ui_manager, priv);
diff --git a/multimedia/pitivi/files/patch-src_pitivi-progressbar.c b/multimedia/pitivi/files/patch-src_pitivi-progressbar.c
deleted file mode 100644
index e7fae8d3dac1..000000000000
--- a/multimedia/pitivi/files/patch-src_pitivi-progressbar.c
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/pitivi-progressbar.c.orig Mon Dec 20 13:14:17 2004
-+++ src/pitivi-progressbar.c Mon Dec 20 13:16:17 2004
-@@ -137,17 +137,19 @@
- guint n_construct_properties,
- GObjectConstructParam * construct_properties)
- {
-+ PitiviProgressBarClass *klass;
- GtkWidget *main_vbox;
- GObjectClass *parent_class;
-- PitiviProgressBarClass *klass;
--
-+ GObject *obj;
-+ PitiviProgressBar *self;
-+
- /* Invoke parent constructor. */
-
- klass = PITIVI_PROGRESSBAR_CLASS (g_type_class_peek (PITIVI_PROGRESSBAR_TYPE));
- parent_class = G_OBJECT_CLASS (g_type_class_peek_parent (klass));
-- GObject *obj = parent_class->constructor (type, n_construct_properties,
-+ obj = parent_class->constructor (type, n_construct_properties,
- construct_properties);
-- PitiviProgressBar *self = (PitiviProgressBar *) obj;
-+ self = (PitiviProgressBar *) obj;
-
- /* window properties */
- gtk_window_set_title (GTK_WINDOW(self), "Loading");
diff --git a/multimedia/pitivi/files/patch-src_pitivi-settings.c b/multimedia/pitivi/files/patch-src_pitivi-settings.c
deleted file mode 100644
index 51a1218f2926..000000000000
--- a/multimedia/pitivi/files/patch-src_pitivi-settings.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/pitivi-settings.c.orig Mon Dec 20 13:52:35 2004
-+++ src/pitivi-settings.c Mon Dec 20 13:54:23 2004
-@@ -385,6 +385,7 @@
- if (factory->numpadtemplates) {
- gint i;
- const GList *pads;
-+ PitiviSettingsMimeType *tmp_mime;
-
- pads = factory->padtemplates;
- for (i = 0; pads; i++, pads = g_list_next (pads)) {
-@@ -393,7 +394,6 @@
- GstCaps *tmp_caps;
-
- tmp_caps = (GstCaps *) padtemplate->caps;
-- PitiviSettingsMimeType *tmp_mime;
-
- if (!gst_caps_is_any (tmp_caps)) {
- if ((tmp_mime = pitivi_settings_search_flux (list, tmp_caps))) {
diff --git a/multimedia/pitivi/files/patch-src_pitivi-settingswindow.c b/multimedia/pitivi/files/patch-src_pitivi-settingswindow.c
deleted file mode 100644
index 5d7d122b8546..000000000000
--- a/multimedia/pitivi/files/patch-src_pitivi-settingswindow.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/pitivi-settingswindow.c.orig Mon Dec 20 13:55:04 2004
-+++ src/pitivi-settingswindow.c Mon Dec 20 13:55:54 2004
-@@ -701,12 +701,13 @@
- GObjectConstructParam * construct_properties)
- {
- GObject *obj;
-+ PitiviSettingsWindow *self;
- /* Invoke parent constructor. */
- obj = G_OBJECT_CLASS (parent_class)->constructor (type, n_construct_properties,
- construct_properties);
-
- /* do stuff. */
-- PitiviSettingsWindow *self = (PitiviSettingsWindow *) obj;
-+ self = (PitiviSettingsWindow *) obj;
-
- pitivi_settingswindow_create_gui (self);
-
diff --git a/multimedia/pitivi/files/patch-src_pitivi-sourcelistwindow.c b/multimedia/pitivi/files/patch-src_pitivi-sourcelistwindow.c
deleted file mode 100644
index 75655be0bf55..000000000000
--- a/multimedia/pitivi/files/patch-src_pitivi-sourcelistwindow.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/pitivi-sourcelistwindow.c.orig Mon Dec 20 13:38:58 2004
-+++ src/pitivi-sourcelistwindow.c Mon Dec 20 13:39:54 2004
-@@ -1406,9 +1406,10 @@
- }
- else
- {
-+ gchar *treepath;
- /* we need to set treepath too */
- save = g_strdup (self->private->treepath);
-- gchar *treepath = g_strdup_printf("%s:%d",
-+ treepath = g_strdup_printf("%s:%d",
- self->private->treepath,
- folder_select);
- g_free ( self->private->treepath );
diff --git a/multimedia/pitivi/files/patch-src_pitivi-timelinecellrenderer.c b/multimedia/pitivi/files/patch-src_pitivi-timelinecellrenderer.c
deleted file mode 100644
index 076c3764d7ff..000000000000
--- a/multimedia/pitivi/files/patch-src_pitivi-timelinecellrenderer.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/pitivi-timelinecellrenderer.c.orig Mon Dec 20 13:22:57 2004
-+++ src/pitivi-timelinecellrenderer.c Mon Dec 20 13:23:54 2004
-@@ -744,12 +744,13 @@
- }
- else
- {
-+ GtkWidget *linked_ref;
- gtk_container_remove (GTK_CONTAINER (parent), GTK_WIDGET (source));
- pitivi_add_to_layout (GTK_WIDGET (self), source, x, 0);
-
- /* linked widget */
-
-- GtkWidget *linked_ref = gtk_widget_ref (GTK_WIDGET (dragged->linked));
-+ linked_ref = gtk_widget_ref (GTK_WIDGET (dragged->linked));
- gtk_container_remove (GTK_CONTAINER (parent->linked_track), GTK_WIDGET (dragged->linked));
- pitivi_add_to_layout (GTK_WIDGET (self->linked_track), linked_ref, x, 0);
- gtk_widget_unref (linked_ref);
diff --git a/multimedia/pitivi/files/patch-src_pitivi-timelinemedia.c b/multimedia/pitivi/files/patch-src_pitivi-timelinemedia.c
deleted file mode 100644
index 46c1501a51ee..000000000000
--- a/multimedia/pitivi/files/patch-src_pitivi-timelinemedia.c
+++ /dev/null
@@ -1,50 +0,0 @@
---- src/pitivi-timelinemedia.c.orig Mon Dec 20 13:34:27 2004
-+++ src/pitivi-timelinemedia.c Mon Dec 20 13:37:47 2004
-@@ -845,7 +845,7 @@
- GdkEventButton *event)
- {
- PitiviCursor *cursor;
--
-+ gint x;
- PitiviTimelineMedia *this = PITIVI_TIMELINEMEDIA (widget);
- cursor = pitivi_getcursor_id (widget);
- if ((cursor->type == PITIVI_CURSOR_SELECT) && (event->button == 1))
-@@ -874,7 +874,7 @@
- this->private->menu = GTK_WIDGET (pitivi_create_menupopup (widget, TimeItemPopup, iNbTimeItemPopup));
- gtk_menu_popup(GTK_MENU (this->private->menu), NULL, NULL, NULL, this, event->button, event->time);
- }
-- gint x = event->x;
-+ x = event->x;
- if ( (x >= widget->allocation.width / 2 ) )
- this->resz = 0;
- else
-@@ -1170,13 +1170,14 @@
- {
- if (!this->cutted)
- {
-+ GtkWidget *w;
- this->cutted = TRUE;
-
- gtk_widget_hide (GTK_WIDGET(this));
- if (this->linked)
- gtk_widget_hide (GTK_WIDGET (this->linked));
-
-- GtkWidget *w = gtk_widget_get_toplevel (GTK_WIDGET(this));
-+ w = gtk_widget_get_toplevel (GTK_WIDGET(this));
- g_signal_emit_by_name (w, "copy-source", this);
- }
- else
-@@ -1187,11 +1188,12 @@
- {
- if (!this->copied)
- {
-+ GtkWidget *w;
- this->copied = TRUE;
-
- /* copy media */
-
-- GtkWidget *w = gtk_widget_get_toplevel (GTK_WIDGET(this));
-+ w = gtk_widget_get_toplevel (GTK_WIDGET(this));
- g_signal_emit_by_name (w, "copy-source", this);
- }
- else
diff --git a/multimedia/pitivi/files/patch-src_pitivi-timelinewindow.c b/multimedia/pitivi/files/patch-src_pitivi-timelinewindow.c
deleted file mode 100644
index afeb6bab6195..000000000000
--- a/multimedia/pitivi/files/patch-src_pitivi-timelinewindow.c
+++ /dev/null
@@ -1,62 +0,0 @@
---- src/pitivi-timelinewindow.c.orig Mon Dec 20 13:18:47 2004
-+++ src/pitivi-timelinewindow.c Mon Dec 20 13:21:52 2004
-@@ -470,9 +470,10 @@
- {
- gboolean activate;
- GList *childlist;
-+ GList *childwidget;
-
- activate = gtk_toggle_button_get_active(GTK_TOGGLE_BUTTON(widget));
-- GList *childwidget = gtk_container_get_children (GTK_CONTAINER (cells));
-+ childwidget = gtk_container_get_children (GTK_CONTAINER (cells));
- for (childlist = childwidget; childlist; childlist = childlist->next )
- {
- if (activate)
-@@ -546,7 +547,7 @@
- GtkWidget *nfo;
- GtkWidget *vbox_right, *vbox_left;
- int count = 0;
--
-+ GtkWidget * pHScrollbarRight;
-
- self->private->hpaned = gtk_hpaned_new();
- vbox_left = gtk_vbox_new (FALSE, 0);
-@@ -597,7 +598,7 @@
- // Left Scrollbar
- gtk_paned_pack1 (GTK_PANED(self->private->hpaned), vbox_left, FALSE, FALSE);
- // Right HScrollbar
-- GtkWidget * pHScrollbarRight = gtk_scrolled_window_new (NULL, NULL);
-+ pHScrollbarRight = gtk_scrolled_window_new (NULL, NULL);
- gtk_scrolled_window_set_policy (GTK_SCROLLED_WINDOW (pHScrollbarRight),
- GTK_POLICY_ALWAYS, GTK_POLICY_NEVER);
- gtk_scrolled_window_add_with_viewport (GTK_SCROLLED_WINDOW (pHScrollbarRight),
-@@ -1339,15 +1340,17 @@
- pitivi_timelinewindow_activate (PitiviTimelineWindow *self)
- {
- GList *childlist;
--
-+ PitiviProject *proj;
-+ gdouble videorate;
-+ GList *childwidget;
- /* Loading Select Cursor */
-
- load_cursor (GDK_WINDOW (GTK_WIDGET (self)->window), self->toolbox->pitivi_cursor, PITIVI_CURSOR_SELECT);
-
- /* Activating ruler */
-
-- PitiviProject *proj = PITIVI_WINDOWS(self)->mainapp->project;
-- gdouble videorate = pitivi_projectsettings_get_videorate(proj->settings);
-+ proj = PITIVI_WINDOWS(self)->mainapp->project;
-+ videorate = pitivi_projectsettings_get_videorate(proj->settings);
- g_object_set (self->hruler, "ruler-videorate", videorate, NULL);
-
- /* Activate Windows Menu */
-@@ -1357,7 +1360,7 @@
-
- /* Activate childs */
-
-- GList *childwidget = gtk_container_get_children (GTK_CONTAINER (self->private->layout_container));
-+ childwidget = gtk_container_get_children (GTK_CONTAINER (self->private->layout_container));
- for (childlist = childwidget; childlist; childlist = childlist->next )
- {
- if (GTK_IS_LAYOUT (childlist->data))
diff --git a/multimedia/pitivi/pkg-plist b/multimedia/pitivi/pkg-plist
index 496a94b72796..8ec4123a5e53 100644
--- a/multimedia/pitivi/pkg-plist
+++ b/multimedia/pitivi/pkg-plist
@@ -1,258 +1,62 @@
bin/pitivi
-etc/pitivi/pitivi
-include/gnl/gnl.h
-include/gnl/gnlcomposition.h
-include/gnl/gnlgroup.h
-include/gnl/gnlmarshal.h
-include/gnl/gnlobject.h
-include/gnl/gnloperation.h
-include/gnl/gnlsource.h
-include/gnl/gnltimeline.h
-include/gnl/gnltypes.h
-include/gnl/gnlversion.h
-lib/libgnl.a
-lib/libgnl.so
-lib/libgnl.so.0
-share/doc/gnonlin/GnlComposition.html
-share/doc/gnonlin/GnlGroup.html
-share/doc/gnonlin/GnlObject.html
-share/doc/gnonlin/GnlOperation.html
-share/doc/gnonlin/GnlSource.html
-share/doc/gnonlin/GnlTimeline.html
-share/doc/gnonlin/ch01.html
-share/doc/gnonlin/gnonlin-gnl.html
-share/doc/gnonlin/gnonlin-gnlmarshal.html
-share/doc/gnonlin/gnonlin-gnlversion.html
-share/doc/gnonlin/gnonlin.devhelp
-share/doc/gnonlin/index.html
-share/doc/gnonlin/index.sgml
-share/gnome/applications/pitivi.desktop
-share/gnome/pitivi/ui/main_menubar.xml
-share/gnome/pitivi/ui/pitivi-timeline.xml
-share/gnome/pitivi/ui/pitivi-toolbox.xml
-share/gnome/pixmaps/pitivi/backward.xpm
-share/gnome/pixmaps/pitivi/bg.xpm
-share/gnome/pixmaps/pitivi/bg_audio.xpm
-share/gnome/pixmaps/pitivi/bg_effects.xpm
-share/gnome/pixmaps/pitivi/bg_trans.xpm
-share/gnome/pixmaps/pitivi/bg_video.xpm
-share/gnome/pixmaps/pitivi/blank.xpm
-share/gnome/pixmaps/pitivi/forward.xpm
-share/gnome/pixmaps/pitivi/logo-pitivi.png
-share/gnome/pixmaps/pitivi/pause.xpm
-share/gnome/pixmaps/pitivi/pitivi-48.png
-share/gnome/pixmaps/pitivi/pitivi-cut.png
-share/gnome/pixmaps/pitivi/pitivi-ddl_resize.png
-share/gnome/pixmaps/pitivi/pitivi-ddr_resize.png
-share/gnome/pixmaps/pitivi/pitivi-dtl_resize.png
-share/gnome/pixmaps/pitivi/pitivi-dtr_resize.png
-share/gnome/pixmaps/pitivi/pitivi-effects-category-open.png
-share/gnome/pixmaps/pitivi/pitivi-effects-category.png
-share/gnome/pixmaps/pitivi/pitivi-effects-sound.png
-share/gnome/pixmaps/pitivi/pitivi-effects-soundtv.png
-share/gnome/pixmaps/pitivi/pitivi-effects-tv.png
-share/gnome/pixmaps/pitivi/pitivi-hand.png
-share/gnome/pixmaps/pitivi/pitivi-info.png
-share/gnome/pixmaps/pitivi/pitivi-logo-small.png
-share/gnome/pixmaps/pitivi/pitivi-logo-splash.png
-share/gnome/pixmaps/pitivi/pitivi-logo.png
-share/gnome/pixmaps/pitivi/pitivi-logo3.png
-share/gnome/pixmaps/pitivi/pitivi-new-sample.png
-share/gnome/pixmaps/pitivi/pitivi-newproject.png
-share/gnome/pixmaps/pitivi/pitivi-pointer.png
-share/gnome/pixmaps/pitivi/pitivi-resize.png
-share/gnome/pixmaps/pitivi/pitivi-select-all.png
-share/gnome/pixmaps/pitivi/pitivi-select-none.png
-share/gnome/pixmaps/pitivi/pitivi-selection-grow.png
-share/gnome/pixmaps/pitivi/pitivi-selection-shrink.png
-share/gnome/pixmaps/pitivi/pitivi-stock-h-resize.png
-share/gnome/pixmaps/pitivi/pitivi-stock-v-resize.png
-share/gnome/pixmaps/pitivi/pitivi-tools.png
-share/gnome/pixmaps/pitivi/pitivi-viewer-next.png
-share/gnome/pixmaps/pitivi/pitivi-viewer-pause.png
-share/gnome/pixmaps/pitivi/pitivi-viewer-play.png
-share/gnome/pixmaps/pitivi/pitivi-viewer-previous.png
-share/gnome/pixmaps/pitivi/pitivi-viewer-record.png
-share/gnome/pixmaps/pitivi/pitivi-viewer-stop.png
-share/gnome/pixmaps/pitivi/pitivi-viewer-volume-max.png
-share/gnome/pixmaps/pitivi/pitivi-viewer-volume-medium.png
-share/gnome/pixmaps/pitivi/pitivi-viewer-volume-min.png
-share/gnome/pixmaps/pitivi/pitivi-viewer-volume-zero.png
-share/gnome/pixmaps/pitivi/pitivi-viewer-volume.png
-share/gnome/pixmaps/pitivi/pitivi-zoom.png
-share/gnome/pixmaps/pitivi/pitivi_BPWS_effect.png
-share/gnome/pixmaps/pitivi/pitivi_IIr_effect.png
-share/gnome/pixmaps/pitivi/pitivi_LPWS_effect.png
-share/gnome/pixmaps/pitivi/pitivi_RevTV_effect.png
-share/gnome/pixmaps/pitivi/pitivi_adjust_effect.png
-share/gnome/pixmaps/pitivi/pitivi_agingTV_effect.png
-share/gnome/pixmaps/pitivi/pitivi_alpha_color_effect.png
-share/gnome/pixmaps/pitivi/pitivi_alpha_effect.png
-share/gnome/pixmaps/pitivi/pitivi_audio_rate_effect.png
-share/gnome/pixmaps/pitivi/pitivi_balance_effect.png
-share/gnome/pixmaps/pitivi/pitivi_box_effect.png
-share/gnome/pixmaps/pitivi/pitivi_crop_effect.png
-share/gnome/pixmaps/pitivi/pitivi_deinterlace_effect.png
-share/gnome/pixmaps/pitivi/pitivi_diceTV_effect.png
-share/gnome/pixmaps/pitivi/pitivi_edgeTV_effect.png
-share/gnome/pixmaps/pitivi/pitivi_envelope_volume_effect.png
-share/gnome/pixmaps/pitivi/pitivi_flipper_effect.png
-share/gnome/pixmaps/pitivi/pitivi_frame_effect.png
-share/gnome/pixmaps/pitivi/pitivi_gamma_effect.png
-share/gnome/pixmaps/pitivi/pitivi_median_effect.png
-share/gnome/pixmaps/pitivi/pitivi_pass_effect.png
-share/gnome/pixmaps/pitivi/pitivi_quarkTV_effect.png
-share/gnome/pixmaps/pitivi/pitivi_quark_effect.png
-share/gnome/pixmaps/pitivi/pitivi_rate_effect.png
-share/gnome/pixmaps/pitivi/pitivi_scaler_effect.png
-share/gnome/pixmaps/pitivi/pitivi_shagadelicTV_effect.png
-share/gnome/pixmaps/pitivi/pitivi_smooth_effect.png
-share/gnome/pixmaps/pitivi/pitivi_speed_effect.png
-share/gnome/pixmaps/pitivi/pitivi_stereo_effect.png
-share/gnome/pixmaps/pitivi/pitivi_synthetiser_effect.png
-share/gnome/pixmaps/pitivi/pitivi_vertigoTV_effect.png
-share/gnome/pixmaps/pitivi/pitivi_volume_effect.png
-share/gnome/pixmaps/pitivi/pitivi_warpTV_effect.png
-share/gnome/pixmaps/pitivi/play.xpm
-share/gnome/pixmaps/pitivi/smpte-failed.png
-share/gnome/pixmaps/pitivi/smpte1.png
-share/gnome/pixmaps/pitivi/smpte101.png
-share/gnome/pixmaps/pitivi/smpte102.png
-share/gnome/pixmaps/pitivi/smpte103.png
-share/gnome/pixmaps/pitivi/smpte104.png
-share/gnome/pixmaps/pitivi/smpte105.png
-share/gnome/pixmaps/pitivi/smpte106.png
-share/gnome/pixmaps/pitivi/smpte107.png
-share/gnome/pixmaps/pitivi/smpte108.png
-share/gnome/pixmaps/pitivi/smpte109.png
-share/gnome/pixmaps/pitivi/smpte110.png
-share/gnome/pixmaps/pitivi/smpte111.png
-share/gnome/pixmaps/pitivi/smpte112.png
-share/gnome/pixmaps/pitivi/smpte113.png
-share/gnome/pixmaps/pitivi/smpte114.png
-share/gnome/pixmaps/pitivi/smpte119.png
-share/gnome/pixmaps/pitivi/smpte120.png
-share/gnome/pixmaps/pitivi/smpte121.png
-share/gnome/pixmaps/pitivi/smpte122.png
-share/gnome/pixmaps/pitivi/smpte123.png
-share/gnome/pixmaps/pitivi/smpte124.png
-share/gnome/pixmaps/pitivi/smpte125.png
-share/gnome/pixmaps/pitivi/smpte127.png
-share/gnome/pixmaps/pitivi/smpte128.png
-share/gnome/pixmaps/pitivi/smpte129.png
-share/gnome/pixmaps/pitivi/smpte130.png
-share/gnome/pixmaps/pitivi/smpte131.png
-share/gnome/pixmaps/pitivi/smpte2.png
-share/gnome/pixmaps/pitivi/smpte201.png
-share/gnome/pixmaps/pitivi/smpte202.png
-share/gnome/pixmaps/pitivi/smpte203.png
-share/gnome/pixmaps/pitivi/smpte204.png
-share/gnome/pixmaps/pitivi/smpte205.png
-share/gnome/pixmaps/pitivi/smpte206.png
-share/gnome/pixmaps/pitivi/smpte207.png
-share/gnome/pixmaps/pitivi/smpte21.png
-share/gnome/pixmaps/pitivi/smpte211.png
-share/gnome/pixmaps/pitivi/smpte212.png
-share/gnome/pixmaps/pitivi/smpte213.png
-share/gnome/pixmaps/pitivi/smpte214.png
-share/gnome/pixmaps/pitivi/smpte22.png
-share/gnome/pixmaps/pitivi/smpte221.png
-share/gnome/pixmaps/pitivi/smpte222.png
-share/gnome/pixmaps/pitivi/smpte223.png
-share/gnome/pixmaps/pitivi/smpte224.png
-share/gnome/pixmaps/pitivi/smpte225.png
-share/gnome/pixmaps/pitivi/smpte226.png
-share/gnome/pixmaps/pitivi/smpte227.png
-share/gnome/pixmaps/pitivi/smpte228.png
-share/gnome/pixmaps/pitivi/smpte23.png
-share/gnome/pixmaps/pitivi/smpte231.png
-share/gnome/pixmaps/pitivi/smpte232.png
-share/gnome/pixmaps/pitivi/smpte233.png
-share/gnome/pixmaps/pitivi/smpte234.png
-share/gnome/pixmaps/pitivi/smpte235.png
-share/gnome/pixmaps/pitivi/smpte236.png
-share/gnome/pixmaps/pitivi/smpte24.png
-share/gnome/pixmaps/pitivi/smpte241.png
-share/gnome/pixmaps/pitivi/smpte242.png
-share/gnome/pixmaps/pitivi/smpte243.png
-share/gnome/pixmaps/pitivi/smpte244.png
-share/gnome/pixmaps/pitivi/smpte245.png
-share/gnome/pixmaps/pitivi/smpte246.png
-share/gnome/pixmaps/pitivi/smpte25.png
-share/gnome/pixmaps/pitivi/smpte251.png
-share/gnome/pixmaps/pitivi/smpte252.png
-share/gnome/pixmaps/pitivi/smpte253.png
-share/gnome/pixmaps/pitivi/smpte254.png
-share/gnome/pixmaps/pitivi/smpte26.png
-share/gnome/pixmaps/pitivi/smpte261.png
-share/gnome/pixmaps/pitivi/smpte262.png
-share/gnome/pixmaps/pitivi/smpte263.png
-share/gnome/pixmaps/pitivi/smpte264.png
-share/gnome/pixmaps/pitivi/smpte3.png
-share/gnome/pixmaps/pitivi/smpte301.png
-share/gnome/pixmaps/pitivi/smpte302.png
-share/gnome/pixmaps/pitivi/smpte303.png
-share/gnome/pixmaps/pitivi/smpte304.png
-share/gnome/pixmaps/pitivi/smpte305.png
-share/gnome/pixmaps/pitivi/smpte306.png
-share/gnome/pixmaps/pitivi/smpte310.png
-share/gnome/pixmaps/pitivi/smpte311.png
-share/gnome/pixmaps/pitivi/smpte312.png
-share/gnome/pixmaps/pitivi/smpte313.png
-share/gnome/pixmaps/pitivi/smpte314.png
-share/gnome/pixmaps/pitivi/smpte315.png
-share/gnome/pixmaps/pitivi/smpte316.png
-share/gnome/pixmaps/pitivi/smpte317.png
-share/gnome/pixmaps/pitivi/smpte320.png
-share/gnome/pixmaps/pitivi/smpte321.png
-share/gnome/pixmaps/pitivi/smpte322.png
-share/gnome/pixmaps/pitivi/smpte323.png
-share/gnome/pixmaps/pitivi/smpte324.png
-share/gnome/pixmaps/pitivi/smpte325.png
-share/gnome/pixmaps/pitivi/smpte326.png
-share/gnome/pixmaps/pitivi/smpte327.png
-share/gnome/pixmaps/pitivi/smpte328.png
-share/gnome/pixmaps/pitivi/smpte329.png
-share/gnome/pixmaps/pitivi/smpte340.png
-share/gnome/pixmaps/pitivi/smpte341.png
-share/gnome/pixmaps/pitivi/smpte342.png
-share/gnome/pixmaps/pitivi/smpte343.png
-share/gnome/pixmaps/pitivi/smpte344.png
-share/gnome/pixmaps/pitivi/smpte345.png
-share/gnome/pixmaps/pitivi/smpte350.png
-share/gnome/pixmaps/pitivi/smpte351.png
-share/gnome/pixmaps/pitivi/smpte352.png
-share/gnome/pixmaps/pitivi/smpte353.png
-share/gnome/pixmaps/pitivi/smpte4.png
-share/gnome/pixmaps/pitivi/smpte41.png
-share/gnome/pixmaps/pitivi/smpte42.png
-share/gnome/pixmaps/pitivi/smpte43.png
-share/gnome/pixmaps/pitivi/smpte44.png
-share/gnome/pixmaps/pitivi/smpte45.png
-share/gnome/pixmaps/pitivi/smpte46.png
-share/gnome/pixmaps/pitivi/smpte47.png
-share/gnome/pixmaps/pitivi/smpte48.png
-share/gnome/pixmaps/pitivi/smpte5.png
-share/gnome/pixmaps/pitivi/smpte6.png
-share/gnome/pixmaps/pitivi/smpte61.png
-share/gnome/pixmaps/pitivi/smpte62.png
-share/gnome/pixmaps/pitivi/smpte63.png
-share/gnome/pixmaps/pitivi/smpte64.png
-share/gnome/pixmaps/pitivi/smpte65.png
-share/gnome/pixmaps/pitivi/smpte66.png
-share/gnome/pixmaps/pitivi/smpte67.png
-share/gnome/pixmaps/pitivi/smpte68.png
-share/gnome/pixmaps/pitivi/smpte7.png
-share/gnome/pixmaps/pitivi/smpte71.png
-share/gnome/pixmaps/pitivi/smpte72.png
-share/gnome/pixmaps/pitivi/smpte73.png
-share/gnome/pixmaps/pitivi/smpte74.png
-share/gnome/pixmaps/pitivi/smpte8.png
-share/gnome/pixmaps/pitivi/stop.xpm
-share/gnome/pixmaps/pitivi/volume.xpm
-@dirrm share/gnome/pixmaps/pitivi
-@dirrm share/gnome/pitivi/ui
+lib/pitivi/__init__.py
+lib/pitivi/__init__.pyc
+lib/pitivi/__init__.pyo
+lib/pitivi/bin.py
+lib/pitivi/bin.pyc
+lib/pitivi/bin.pyo
+lib/pitivi/configure.py
+lib/pitivi/configure.pyc
+lib/pitivi/configure.pyo
+lib/pitivi/discoverer.py
+lib/pitivi/discoverer.pyc
+lib/pitivi/discoverer.pyo
+lib/pitivi/dnd.py
+lib/pitivi/dnd.pyc
+lib/pitivi/dnd.pyo
+lib/pitivi/effects.py
+lib/pitivi/effects.pyc
+lib/pitivi/effects.pyo
+lib/pitivi/objectfactory.py
+lib/pitivi/objectfactory.pyc
+lib/pitivi/objectfactory.pyo
+lib/pitivi/pitivi.py
+lib/pitivi/pitivi.pyc
+lib/pitivi/pitivi.pyo
+lib/pitivi/playground.py
+lib/pitivi/playground.pyc
+lib/pitivi/playground.pyo
+lib/pitivi/project.py
+lib/pitivi/project.pyc
+lib/pitivi/project.pyo
+lib/pitivi/settings.py
+lib/pitivi/settings.pyc
+lib/pitivi/settings.pyo
+lib/pitivi/sourcelist.py
+lib/pitivi/sourcelist.pyc
+lib/pitivi/sourcelist.pyo
+lib/pitivi/timeline.py
+lib/pitivi/timeline.pyc
+lib/pitivi/timeline.pyo
+lib/pitivi/ui/__init__.py
+lib/pitivi/ui/actions.xml
+lib/pitivi/ui/encodingdialog.glade
+lib/pitivi/ui/elementsettingsdialog.glade
+lib/pitivi/ui/exportsettingswidget.glade
+lib/pitivi/ui/exportsettingswidget.py
+lib/pitivi/ui/glade.py
+lib/pitivi/ui/gstwidget.py
+lib/pitivi/ui/mainwindow.py
+lib/pitivi/ui/projectsettings.glade
+lib/pitivi/ui/projectsettings.py
+lib/pitivi/ui/sourcefactories.py
+lib/pitivi/ui/timeline.py
+lib/pitivi/ui/timelineobjects.py
+lib/pitivi/ui/viewer.py
+share/gnome/pitivi/pixmaps/pitivi-file.png
+share/gnome/pitivi/pixmaps/pitivi-sound.png
+share/gnome/pitivi/pixmaps/pitivi-video.png
+@dirrm share/gnome/pitivi/pixmaps
@dirrm share/gnome/pitivi
-@dirrm share/doc/gnonlin
-@dirrm include/gnl
-@dirrm etc/pitivi
+@dirrm lib/pitivi/ui
+@dirrm lib/pitivi